aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2006-12-11 17:55:39 +0000
committerFlorian Fainelli <florian@openwrt.org>2006-12-11 17:55:39 +0000
commitb7d79b0d3c5c1d9d6f8a1397de4ab56288c0b5bc (patch)
treee16f91932a87efd680d69fb8456a9c6b5616388c /target
parent71b50f88fa6433b187e05db339a8f8694af0f81d (diff)
downloadupstream-b7d79b0d3c5c1d9d6f8a1397de4ab56288c0b5bc.tar.gz
upstream-b7d79b0d3c5c1d9d6f8a1397de4ab56288c0b5bc.tar.bz2
upstream-b7d79b0d3c5c1d9d6f8a1397de4ab56288c0b5bc.zip
Add different Wi-Fi profiles
SVN-Revision: 5761
Diffstat (limited to 'target')
-rw-r--r--target/linux/au1000-2.6/Makefile18
1 files changed, 18 insertions, 0 deletions
diff --git a/target/linux/au1000-2.6/Makefile b/target/linux/au1000-2.6/Makefile
index 258990f8b7..45b718135d 100644
--- a/target/linux/au1000-2.6/Makefile
+++ b/target/linux/au1000-2.6/Makefile
@@ -28,5 +28,23 @@ define Kernel/BuildImage
$(CP) $(LINUX_DIR)/arch/mips/boot/compressed/images/zImage.srec $(LINUX_DIR)/zImage.srec
endef
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+$(eval $(call Profile,Atheros))
+
+define Profile/Intel
+ NAME:=Intel IPW2200 WiFi
+ PACKAGES:=kmod-net-ipw2200
+endef
+$(eval $(call Profile,Intel))
+
+define Profile/Broadcom
+ NAME:=Broadcom BCM43xx WiFi
+ PACKAGES:=kmod-net-bcm43xx
+endef
+$(eval $(call Profile,Broadcom))
+
$(eval $(call BuildKernel))