aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <f.fainelli@gmail.com>2017-04-07 14:49:15 -0700
committerFlorian Fainelli <f.fainelli@gmail.com>2017-04-11 12:11:25 -0700
commitb319e304c8d394e44f45ca3ade9df0b3c880d1bd (patch)
tree4702f2c0040d10964592b83ed3998d045109feb7 /target
parentde5b8e5d2fe1fb43bad25dc13c7caf4158933eb5 (diff)
downloadupstream-b319e304c8d394e44f45ca3ade9df0b3c880d1bd.tar.gz
upstream-b319e304c8d394e44f45ca3ade9df0b3c880d1bd.tar.bz2
upstream-b319e304c8d394e44f45ca3ade9df0b3c880d1bd.zip
arm64: Remove Vexpress Foundation support
This required us to both download the Foundation emulator but also build a boot wrapper. QEMU is now fully usable and is a much better replacement. Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/arm64/image/Makefile12
-rw-r--r--target/linux/arm64/image/boot-wrapper/Makefile37
2 files changed, 0 insertions, 49 deletions
diff --git a/target/linux/arm64/image/Makefile b/target/linux/arm64/image/Makefile
index cc04b183fc..d52936808d 100644
--- a/target/linux/arm64/image/Makefile
+++ b/target/linux/arm64/image/Makefile
@@ -8,14 +8,7 @@ include $(TOPDIR)/rules.mk
include $(INCLUDE_DIR)/image.mk
define Image/Prepare
- -rm -rf $(KDIR)/linux-system.axf
cp $(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/Image $(KDIR)/Image
- $(MAKE) -C boot-wrapper clean
- $(MAKE) -C boot-wrapper compile
-endef
-
-define Build/Clean
- $(MAKE) -C boot-wrapper clean
endef
define Image/Build/QemuVirt
@@ -25,13 +18,8 @@ ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
endif
endef
-define Image/Build/VexpressFoundation
- $(CP) $(KDIR)/linux-system.axf $(BIN_DIR)/$(IMG_PREFIX)-vexpress-foundation.axf
-endef
-
define Image/BuildKernel
$(call Image/Build/QemuVirt)
- $(call Image/Build/VexpressFoundation)
endef
define Image/Build/squashfs
diff --git a/target/linux/arm64/image/boot-wrapper/Makefile b/target/linux/arm64/image/boot-wrapper/Makefile
deleted file mode 100644
index cf16f8045d..0000000000
--- a/target/linux/arm64/image/boot-wrapper/Makefile
+++ /dev/null
@@ -1,37 +0,0 @@
-#
-# Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-
-include $(TOPDIR)/rules.mk
-
-PKG_NAME:=aarch64-boot-wrapper
-PKG_RELEASE:=1
-
-PKG_SOURCE_PROTO:=git
-PKG_SOURCE_URL:=https://git.kernel.org/pub/scm/linux/kernel/git/mark/boot-wrapper-aarch64.git
-PKG_SOURCE_DATE:=2013-01-10
-PKG_SOURCE_VERSION:=c51dde817b5ed5b8f741b67ac51bd67bd87b4a2a
-PKG_MIRROR_HASH:=2f029a20c906af68e9fe067c1b0ed394e4c455e142454a039f41d1d82d6e17c8
-PKG_MAINTAINER:=Florian Fainelli <florian@openwrt.org>
-
-include $(INCLUDE_DIR)/kernel.mk
-include $(INCLUDE_DIR)/package.mk
-include $(INCLUDE_DIR)/image.mk
-
-define Build/Compile
- $(MAKE) -C $(PKG_BUILD_DIR) \
- KERNEL="../Image" \
- DTC="$(LINUX_DIR)/scripts/dtc/dtc" \
- FDT_SRC="$(LINUX_DIR)/arch/$(LINUX_KARCH)/boot/dts/arm/foundation-v8.dts" \
- CROSS_COMPILE="$(TARGET_CROSS)" \
- BOOTARGS="console=ttyAMA0 earlyprintk"
-endef
-
-define Build/InstallDev
- $(CP) $(PKG_BUILD_DIR)/linux-system.axf $(KDIR)/linux-system.axf
-endef
-
-$(eval $(call Build/DefaultTargets))