aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-08-03 15:04:28 +0000
committerNicolas Thill <nico@openwrt.org>2008-08-03 15:04:28 +0000
commitafcb4fbee4d9bc08b0a9acedcd2d61fed1599930 (patch)
tree3670aad12ce57e8a30d715031e21a54c8329e39a /target
parent8de805b27cf11da64eea89e96727d3632e40c1f8 (diff)
downloadupstream-afcb4fbee4d9bc08b0a9acedcd2d61fed1599930.tar.gz
upstream-afcb4fbee4d9bc08b0a9acedcd2d61fed1599930.tar.bz2
upstream-afcb4fbee4d9bc08b0a9acedcd2d61fed1599930.zip
fix typo in gcc version check
SVN-Revision: 12080
Diffstat (limited to 'target')
-rw-r--r--target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
index 48cffffcd4..17c08cd6c5 100644
--- a/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
+++ b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
@@ -7,7 +7,7 @@ Index: linux-2.6.26/arch/um/Makefile-i386
# a lot more stack due to the lack of sharing of stacklots. Also, gcc
# 4.3.0 needs -funit-at-a-time for extern inline functions.
-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
-+KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0430 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0403 ] ; then \
echo $(call cc-option,-fno-unit-at-a-time); \
else echo $(call cc-option,-funit-at-a-time); fi ;)