aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-11-18 11:59:22 +0100
committerMathias Kresin <dev@kresin.me>2017-11-22 08:21:52 +0100
commita783185e280f5b8d7ca5c7a1a4f5adad8a287637 (patch)
tree57e52da8dfd8ae78f98785c63b5d09dd2d6a04dc /target
parent6aa4b97a8a4e4d07895682e47184c5d49441b1bb (diff)
downloadupstream-a783185e280f5b8d7ca5c7a1a4f5adad8a287637.tar.gz
upstream-a783185e280f5b8d7ca5c7a1a4f5adad8a287637.tar.bz2
upstream-a783185e280f5b8d7ca5c7a1a4f5adad8a287637.zip
ramips: fix DCH-M225 support
Setting the pins of the UARTF group to GPIO+I2S at the time the I2C driver loads is to late for the wps GPIO button. The gpio-keys driver fails to load since the pin used by the wps button is not yet set to GPIO. The wps button with the rfkill keycode is essential for this wireless only board. Add the missing sound and I2C kernel modules corresponding to the device nodes. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/DCH-M225.dts7
-rw-r--r--target/linux/ramips/image/mt7620.mk2
2 files changed, 7 insertions, 2 deletions
diff --git a/target/linux/ramips/dts/DCH-M225.dts b/target/linux/ramips/dts/DCH-M225.dts
index 867335e957..5856036c95 100644
--- a/target/linux/ramips/dts/DCH-M225.dts
+++ b/target/linux/ramips/dts/DCH-M225.dts
@@ -90,7 +90,7 @@
#sound-dai-cells = <0>;
status = "okay";
pinctrl-names = "default";
- pinctrl-0 = <&gpio_i2s_pins>, <&wm8960_mclk_pins>;
+ pinctrl-0 = <&wm8960_mclk_pins>;
};
&spi0 {
@@ -158,6 +158,11 @@
ralink,function = "gpio";
};
+ gpio_i2s {
+ ralink,group = "uartf";
+ ralink,function = "gpio i2s";
+ };
+
pa {
ralink,group = "pa";
ralink,function = "pa";
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 796cc619a3..ab03cf1e16 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -139,7 +139,7 @@ define Device/dch-m225
seama-seal -m "signature=wapn22_dlink.2013gui_dap1320b" | \
check-size $$$$(IMAGE_SIZE)
DEVICE_TITLE := D-Link DCH-M225
- DEVICE_PACKAGES := kmod-mt76
+ DEVICE_PACKAGES := kmod-mt76 kmod-sound-core kmod-sound-mt7620 kmod-i2c-ralink
endef
TARGET_DEVICES += dch-m225