aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLuo chongjun <luochongjun@gl-inet.com>2018-11-05 10:03:05 +0800
committerJohn Crispin <john@phrozen.org>2018-11-26 12:05:45 +0100
commit9989fd5154fd8301bf363ddae0b5083220141865 (patch)
treefd816645a525f1f72f4bef2b7f44824f6bed363d /target
parent987b961537b7002eda21df97dd8bfebe8882bc6d (diff)
downloadupstream-9989fd5154fd8301bf363ddae0b5083220141865.tar.gz
upstream-9989fd5154fd8301bf363ddae0b5083220141865.tar.bz2
upstream-9989fd5154fd8301bf363ddae0b5083220141865.zip
ath79: add support for GL-iNet GL-X750
this patch adds supports for GL-X750. Specification: - SOC: QCA9531 (650MHz) - Flash: 16 MiB (W25Q128FVSG) - RAM: 128 MiB DDR2 - Ethernet: 10/100: 1xLAN + 10/100: 1xWAN - Wireless: 2.4GHz (bgn) and 5GHz (ac) - USB: 1x USB 2.0 port - Button: 1x reset button - LED: 5x LEDS (green) Flash instruction: The original firmware is openwrt, so both LuCI or sysupgrade can be used. Signed-off-by: Luo chongjun <luochongjun@gl-inet.com>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/01_leds3
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network5
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata4
-rw-r--r--target/linux/ath79/dts/qca9533_glinet_x750.dts46
-rw-r--r--target/linux/ath79/dts/qca9533_glinet_x750.dtsi95
-rw-r--r--target/linux/ath79/image/generic.mk8
6 files changed, 159 insertions, 2 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/01_leds b/target/linux/ath79/base-files/etc/board.d/01_leds
index 5b54c83674..47c900f6eb 100755
--- a/target/linux/ath79/base-files/etc/board.d/01_leds
+++ b/target/linux/ath79/base-files/etc/board.d/01_leds
@@ -33,6 +33,9 @@ etactica,eg200)
ucidef_set_led_oneshot "modbus" "Modbus" "$boardname:red:modbus" "100" "33"
ucidef_set_led_default "etactica" "etactica" "$boardname:red:etactica" "ignore"
;;
+glinet,x750)
+ ucidef_set_led_netdev "wan" "WAN" "gl-x750:green:wan" "eth0"
+ ;;
netgear,wnr612-v2|\
on,n150r)
ucidef_set_led_netdev "wan" "WAN" "netgear:green:wan" "eth0"
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index ef94388b15..fca9e42fb5 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -1,4 +1,4 @@
-#!/bin/sh
+!/bin/sh
. /lib/functions/system.sh
. /lib/functions/uci-defaults.sh
@@ -72,7 +72,8 @@ ath79_setup_interfaces()
ucidef_set_interface_lan "eth0" "dhcp"
;;
glinet,ar150|\
- glinet,ar300m)
+ glinet,ar300m|\
+ glinet,x750)
ucidef_set_interfaces_lan_wan "eth1" "eth0"
;;
iodata,etg3-r|\
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index dfe2d3ef31..b4bc20d1cf 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -87,6 +87,10 @@ board=$(board_name)
case "$FIRMWARE" in
"ath10k/cal-pci-0000:00:00.0.bin")
case $board in
+ glinet,x750)
+ ath10kcal_extract "art" 20480 2116
+ ath10kcal_patch_mac $(macaddr_add $(cat /sys/class/net/eth0/address) +1)
+ ;;
iodata,wn-ac1167dgr|\
iodata,wn-ac1600dgr2)
ath10kcal_extract "art" 20480 2116
diff --git a/target/linux/ath79/dts/qca9533_glinet_x750.dts b/target/linux/ath79/dts/qca9533_glinet_x750.dts
new file mode 100644
index 0000000000..7313f96d51
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_glinet_x750.dts
@@ -0,0 +1,46 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9533_glinet_x750.dtsi"
+
+&spi {
+ status = "okay";
+ num-cs = <0>;
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <25000000>;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x000000 0x040000>;
+ read-only;
+ };
+
+ partition@40000 {
+ label = "u-boot-env";
+ reg = <0x040000 0x010000>;
+ };
+
+ art: partition@50000 {
+ label = "art";
+ reg = <0x050000 0x010000>;
+ };
+
+ partition@60000 {
+ label = "firmware";
+ reg = <0x060000 0xfa0000>;
+ };
+
+ };
+ };
+};
diff --git a/target/linux/ath79/dts/qca9533_glinet_x750.dtsi b/target/linux/ath79/dts/qca9533_glinet_x750.dtsi
new file mode 100644
index 0000000000..b84c332137
--- /dev/null
+++ b/target/linux/ath79/dts/qca9533_glinet_x750.dtsi
@@ -0,0 +1,95 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "qca9533.dtsi"
+
+/ {
+ compatible = "glinet,x750", "qca,qca9533";
+ model = "GL.iNet GL-X750";
+
+ keys {
+ compatible = "gpio-keys-polled";
+ poll-interval = <20>;
+ pinctrl-names = "default";
+ pinctrl-0 = <&jtag_disable_pins>;
+
+ button0 {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio 3 GPIO_ACTIVE_LOW>;
+ };
+
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ power {
+ label = "gl-x750:green:power";
+ gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ wlan2g {
+ label = "gl-x750:green:wlan2g";
+ gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy1tpt";
+ };
+
+ wlan5g {
+ label = "gl-x750:green:wlan5g";
+ gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+ linux,default-trigger = "phy0tpt";
+ };
+
+ wan {
+ label = "gl-x750:green:wan";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+ 4g {
+ label = "gl-x750:green:4g";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ default-state = "off";
+ };
+ };
+};
+
+&pcie0 {
+ status = "okay";
+};
+
+&uart {
+ status = "okay";
+};
+
+&usb0 {
+ #address-cells = <1>;
+ #size-cells = <0>;
+ status = "okay";
+
+ hub_port: port@1 {
+ reg = <1>;
+ #trigger-source-cells = <0>;
+ };
+};
+
+&usb_phy {
+ status = "okay";
+};
+
+&eth0 {
+ status = "okay";
+ mtd-mac-address = <&art 0x0>;
+ phy-handle = <&swphy4>;
+};
+
+&eth1 {
+ mtd-mac-address = <&art 0x6>;
+};
+
+&wmac {
+ status = "okay";
+ mtd-cal-data = <&art 0x1000>;
+ mtd-mac-address = <&art 0x1002>;
+};
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 75e93998a9..3dbed22924 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -176,6 +176,14 @@ define Device/glinet_ar300m_nor
endef
TARGET_DEVICES += glinet_ar300m_nor
+define Device/glinet_x750
+ ATH_SOC := qca9533
+ DEVICE_TITLE := GL.iNet GL-ARX750
+ DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-ath10k ath10k-firmware-qca9887
+ IMAGE_SIZE := 16000k
+endef
+TARGET_DEVICES += glinet_x750
+
define Device/iodata_etg3-r
ATH_SOC := ar9342
DEVICE_TITLE := I-O DATA ETG3-R