aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-15 14:55:02 +0200
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-07-25 14:31:01 +0200
commit7392af752042337c99fd07dd7a7d75db5c6cd59b (patch)
treecf8929c4129420d40bec6bebcbea7b7491850139 /target
parentb9cf1f60811730a54c918d1118725e88e29e0950 (diff)
downloadupstream-7392af752042337c99fd07dd7a7d75db5c6cd59b.tar.gz
upstream-7392af752042337c99fd07dd7a7d75db5c6cd59b.tar.bz2
upstream-7392af752042337c99fd07dd7a7d75db5c6cd59b.zip
ramips: fix ralink_default_fw_size_16M
In ramips, there are the following predefined values for IMAGE_SIZE ralink_default_fw_size_4M 3866624 3776k 0x3B0000 ralink_default_fw_size_8M 8060928 7872k 0x7B0000 ralink_default_fw_size_16M 16121856 15744k 0xF60000 ralink_default_fw_size_32M 33226752 32448k 0x1FB0000 Out of those, the "16M" value is obviously odd, as it provides more room for the remaining partitions than the tree others. Of the devices in all subtargets, there are actually > 50 that have a firmware partition with 0xFB0000 size, while only 5 (!) have 0xF60000. From the former, many are set to ralink_default_fw_size_16M anyway, although it is wrong at the present point. Consequently, it makes sense to change ralink_default_fw_size_16M to 0xFB0000, and to update IMAGE_SIZE for the 5 devices with 0xF60000. Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile2
-rw-r--r--target/linux/ramips/image/mt7620.mk4
-rw-r--r--target/linux/ramips/image/mt7621.mk2
-rw-r--r--target/linux/ramips/image/mt76x8.mk2
-rw-r--r--target/linux/ramips/image/rt305x.mk2
5 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index 181c825873..b1f0612941 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -150,7 +150,7 @@ endef
ralink_default_fw_size_4M=3866624
ralink_default_fw_size_8M=8060928
-ralink_default_fw_size_16M=16121856
+ralink_default_fw_size_16M=16449536
ralink_default_fw_size_32M=33226752
ifeq ($(SUBTARGET),rt288x)
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 36cc7d5204..51030bc90b 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -490,7 +490,7 @@ TARGET_DEVICES += kimax_u35wf
define Device/kingston_mlw221
MTK_SOC := mt7620n
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ IMAGE_SIZE := 15744k
DEVICE_VENDOR := Kingston
DEVICE_MODEL := MLW221
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
@@ -500,7 +500,7 @@ TARGET_DEVICES += kingston_mlw221
define Device/kingston_mlwg2
MTK_SOC := mt7620n
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ IMAGE_SIZE := 15744k
DEVICE_VENDOR := Kingston
DEVICE_MODEL := MLWG2
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index f80a723c15..0902c4eedc 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -465,7 +465,7 @@ TARGET_DEVICES += netis_wf-2881
define Device/phicomm_k2p
MTK_SOC := mt7621
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ IMAGE_SIZE := 15744k
DEVICE_VENDOR := Phicomm
DEVICE_MODEL := K2P
SUPPORTED_DEVICES += k2p
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index fae9fb03cf..4382bef7fc 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -144,7 +144,7 @@ TARGET_DEVICES += mercury_mac1200r-v2
define Device/netgear_r6120
MTK_SOC := mt7628an
BLOCKSIZE := 64k
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ IMAGE_SIZE := 15744k
DEVICE_VENDOR := NETGEAR
DEVICE_MODEL := R6120
DEVICE_PACKAGES := kmod-mt76x2 kmod-usb2 kmod-usb-ohci
diff --git a/target/linux/ramips/image/rt305x.mk b/target/linux/ramips/image/rt305x.mk
index 2ba5e254e6..073f505d49 100644
--- a/target/linux/ramips/image/rt305x.mk
+++ b/target/linux/ramips/image/rt305x.mk
@@ -579,7 +579,7 @@ TARGET_DEVICES += huawei_d105
define Device/huawei_hg255d
MTK_SOC := rt3052
- IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ IMAGE_SIZE := 15744k
DEVICE_VENDOR := HuaWei
DEVICE_MODEL := HG255D
SUPPORTED_DEVICES += hg255d