aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-03-21 15:04:07 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-03-21 15:04:07 +0000
commit5e7833d044b0a11c7f05e38f52d5e9772aea468c (patch)
tree0ade379b05869a32d562dd93f0eeae5b8a2ada69 /target
parent285c45e7fd7cb54f759b17b455a0c81b5ba78962 (diff)
downloadupstream-5e7833d044b0a11c7f05e38f52d5e9772aea468c.tar.gz
upstream-5e7833d044b0a11c7f05e38f52d5e9772aea468c.tar.bz2
upstream-5e7833d044b0a11c7f05e38f52d5e9772aea468c.zip
Add image generation for edimax routers
SVN-Revision: 6627
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120-2.6/image/Makefile13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/adm5120-2.6/image/Makefile b/target/linux/adm5120-2.6/image/Makefile
index 2043ffa9e5..a41fde9330 100644
--- a/target/linux/adm5120-2.6/image/Makefile
+++ b/target/linux/adm5120-2.6/image/Makefile
@@ -34,8 +34,21 @@ define trxalign/squashfs
-a 1024
endef
+define Image/Build/Compex
+ $(CP) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).trx
+endef
+
+define Image/Build/Edimax
+ $(STAGING_DIR)/bin/mksyshdr csys $(KDIR)/vmlinux
+ cat csys $(KDIR)/vmlinux $(KDIR)/root.$(1) > $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(3)-$(2).img
+endef
+
define Image/Build
$(STAGING_DIR)/bin/trx -o $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1).trx -f $(KDIR)/loader.gz -f $(KDIR)/vmlinux.lzma $(call trxalign/$(1)) -f $(KDIR)/root.$(1)
+ifneq ($(1),jffs2-128K)
+ $(call Image/Build/Compex,$(1),wp54g,$(patsubst jffs2-%,jffs2,$(1)))
+ $(call Image/Build/Edimax,$(1),br6104,$(patsubst jffs2-%,jffs2,$(1)))
+endif
endef
$(eval $(call BuildImage))