aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2008-07-28 12:36:09 +0000
committerNicolas Thill <nico@openwrt.org>2008-07-28 12:36:09 +0000
commit5ca686b513292738c9334cb1b15b31a6336416ff (patch)
tree219e810e9768ca974cb4af91c1ddd6823dff75c9 /target
parent44c4cd23f1b13f9a544fd4940b4e774e4ec31e04 (diff)
downloadupstream-5ca686b513292738c9334cb1b15b31a6336416ff.tar.gz
upstream-5ca686b513292738c9334cb1b15b31a6336416ff.tar.bz2
upstream-5ca686b513292738c9334cb1b15b31a6336416ff.zip
add a fix to prevent startup crashes on i386 when built with gcc < 4.3
SVN-Revision: 11969
Diffstat (limited to 'target')
-rw-r--r--target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
new file mode 100644
index 0000000000..48cffffcd4
--- /dev/null
+++ b/target/linux/uml/patches/001-gcc4_unit_at_a_time_i386_fix.patch
@@ -0,0 +1,13 @@
+Index: linux-2.6.26/arch/um/Makefile-i386
+===================================================================
+--- linux-2.6.26.orig/arch/um/Makefile-i386 2008-07-28 13:43:40.412036547 +0200
++++ linux-2.6.26/arch/um/Makefile-i386 2008-07-28 13:44:00.234033125 +0200
+@@ -35,7 +35,7 @@
+ # Disable unit-at-a-time mode on pre-gcc-4.0 compilers, it makes gcc use
+ # a lot more stack due to the lack of sharing of stacklots. Also, gcc
+ # 4.3.0 needs -funit-at-a-time for extern inline functions.
+-KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0400 ] ; then \
++KBUILD_CFLAGS += $(shell if [ $(call cc-version) -lt 0430 ] ; then \
+ echo $(call cc-option,-fno-unit-at-a-time); \
+ else echo $(call cc-option,-funit-at-a-time); fi ;)
+