aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2019-01-27 19:34:42 +0100
committerHauke Mehrtens <hauke@hauke-m.de>2019-01-27 19:35:46 +0100
commit50b3044eebea8a3f840babaadc4e850214ac29c5 (patch)
treec9eac115739405bc940323da0027fb9c6941aa8e /target
parent617e41464383630055ef9fc6e6e5e1333b492b7d (diff)
downloadupstream-50b3044eebea8a3f840babaadc4e850214ac29c5.tar.gz
upstream-50b3044eebea8a3f840babaadc4e850214ac29c5.tar.bz2
upstream-50b3044eebea8a3f840babaadc4e850214ac29c5.zip
brcm2708: Fix kmod-regmap split
There are more regmap dependencies missing in the brcm2708 target. Fixes: fd5c16870169 ("kernel: Build: Split kmod-regmap") Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm2708/modules.mk51
1 files changed, 34 insertions, 17 deletions
diff --git a/target/linux/brcm2708/modules.mk b/target/linux/brcm2708/modules.mk
index dc7dc54624..be4e08995e 100644
--- a/target/linux/brcm2708/modules.mk
+++ b/target/linux/brcm2708/modules.mk
@@ -75,7 +75,7 @@ define KernelPackage/sound-soc-bcm2835-i2s
FILES:= \
$(LINUX_DIR)/sound/soc/bcm/snd-soc-bcm2835-i2s.ko
AUTOLOAD:=$(call AutoLoad,68,snd-soc-bcm2835-i2s)
- DEPENDS:=@TARGET_brcm2708 +kmod-regmap-mmio +kmod-sound-soc-core
+ DEPENDS:=@TARGET_brcm2708 +kmod-sound-soc-core
$(call AddDepends/sound)
endef
@@ -119,7 +119,8 @@ define KernelPackage/sound-soc-adau1977-adc
snd-soc-adau1977-adc)
DEPENDS:= \
kmod-sound-soc-bcm2835-i2s \
- +kmod-i2c-bcm2708
+ +kmod-i2c-bcm2708 \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -145,7 +146,8 @@ define KernelPackage/sound-soc-allo-boss-dac
DEPENDS:= \
@LINUX_4_14 \
+kmod-i2c-bcm2708 \
- kmod-sound-soc-bcm2835-i2s
+ kmod-sound-soc-bcm2835-i2s \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -171,7 +173,8 @@ define KernelPackage/sound-soc-allo-digione
DEPENDS:= \
@LINUX_4_14 \
+kmod-i2c-bcm2708 \
- kmod-sound-soc-bcm2835-i2s
+ kmod-sound-soc-bcm2835-i2s \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -196,7 +199,8 @@ define KernelPackage/sound-soc-allo-piano-dac
snd-soc-allo-piano-dac)
DEPENDS:= \
kmod-sound-soc-bcm2835-i2s \
- +kmod-i2c-bcm2708
+ +kmod-i2c-bcm2708 \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -222,7 +226,8 @@ define KernelPackage/sound-soc-allo-piano-dac-plus
DEPENDS:= \
@LINUX_4_14 \
+kmod-i2c-bcm2708 \
- kmod-sound-soc-bcm2835-i2s
+ kmod-sound-soc-bcm2835-i2s \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -250,8 +255,8 @@ define KernelPackage/sound-soc-allo-katana-codec
DEPENDS:= \
@LINUX_4_14 \
+kmod-i2c-bcm2708 \
- +kmod-regmap-core \
- kmod-sound-soc-bcm2835-i2s
+ kmod-sound-soc-bcm2835-i2s \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -277,7 +282,8 @@ define KernelPackage/sound-soc-audioinjector-octo-soundcard
DEPENDS:= \
@LINUX_4_14 \
+kmod-i2c-bcm2708 \
- kmod-sound-soc-bcm2835-i2s
+ kmod-sound-soc-bcm2835-i2s \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -300,7 +306,9 @@ define KernelPackage/sound-soc-audioinjector-pi-soundcard
snd-soc-audioinjector-pi-soundcard)
DEPENDS:= \
kmod-sound-soc-bcm2835-i2s \
- +kmod-i2c-bcm2708
+ +kmod-i2c-bcm2708 \
+ +kmod-regmap-i2c \
+ +kmod-regmap-spi
$(call AddDepends/sound)
endef
@@ -327,7 +335,9 @@ define KernelPackage/sound-soc-digidac1-soundcard
snd-soc-digidac1-soundcard)
DEPENDS:= \
kmod-sound-soc-bcm2835-i2s \
- +kmod-i2c-bcm2708
+ +kmod-i2c-bcm2708 \
+ +kmod-regmap-i2c \
+ +kmod-regmap-spi
$(call AddDepends/sound)
endef
@@ -371,7 +381,8 @@ define KernelPackage/sound-soc-dionaudio-loco-v2
AUTOLOAD:=$(call AutoLoad,68,snd-soc-pcm512x snd-soc-pcm512x-i2c \
snd-soc-dionaudio-loco)
DEPENDS:= \
- kmod-sound-soc-bcm2835-i2s
+ kmod-sound-soc-bcm2835-i2s \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -392,7 +403,8 @@ define KernelPackage/sound-soc-fe-pi
AUTOLOAD:=$(call AutoLoad,68,snd-soc-sgtl5000 \
snd-soc-fe-pi-audio)
DEPENDS:= \
- kmod-sound-soc-bcm2835-i2s
+ kmod-sound-soc-bcm2835-i2s \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -502,7 +514,8 @@ define KernelPackage/sound-soc-hifiberry-amp
AUTOLOAD:=$(call AutoLoad,68,snd-soc-tas5713 snd-soc-hifiberry-amp)
DEPENDS:= \
kmod-sound-soc-bcm2835-i2s \
- +kmod-i2c-bcm2708
+ +kmod-i2c-bcm2708 \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -526,7 +539,8 @@ define KernelPackage/sound-soc-iqaudio-dac
snd-soc-iqaudio-dac)
DEPENDS:= \
kmod-sound-soc-bcm2835-i2s \
- +kmod-i2c-bcm2708
+ +kmod-i2c-bcm2708 \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -550,7 +564,8 @@ define KernelPackage/sound-soc-iqaudio-digi
snd-soc-iqaudio-digi)
DEPENDS:= \
kmod-sound-soc-bcm2835-i2s \
- +kmod-i2c-bcm2708
+ +kmod-i2c-bcm2708 \
+ +kmod-regmap-i2c
$(call AddDepends/sound)
endef
@@ -723,7 +738,9 @@ define KernelPackage/sound-soc-rpi-proto
AUTOLOAD:=$(call AutoLoad,68,snd-soc-wm8731 snd-soc-rpi-proto)
DEPENDS:= \
kmod-sound-soc-bcm2835-i2s \
- +kmod-i2c-bcm2708
+ +kmod-i2c-bcm2708 \
+ +kmod-regmap-i2c \
+ +kmod-regmap-spi
$(call AddDepends/sound)
endef