aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHauke Mehrtens <hauke@hauke-m.de>2017-07-15 22:51:25 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2017-09-18 18:36:26 +0200
commit4b81bb13f4005f243d14820a688150be5c350182 (patch)
treeb33fa51c34eef52236d0c88391896d8812dd0cb0 /target
parentb9a35920bf45c3dfa950acdd187dcb5f80341e69 (diff)
downloadupstream-4b81bb13f4005f243d14820a688150be5c350182.tar.gz
upstream-4b81bb13f4005f243d14820a688150be5c350182.tar.bz2
upstream-4b81bb13f4005f243d14820a688150be5c350182.zip
sunxi: fix build of rtc package when module not available
If the Kconfig option CONFIG_RTC_DRV_SUNXI is not selected this package should be be build. Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/sunxi/modules.mk4
1 files changed, 2 insertions, 2 deletions
diff --git a/target/linux/sunxi/modules.mk b/target/linux/sunxi/modules.mk
index 99b82a3b5f..b8ea7d5cb6 100644
--- a/target/linux/sunxi/modules.mk
+++ b/target/linux/sunxi/modules.mk
@@ -10,8 +10,8 @@ define KernelPackage/rtc-sunxi
DEPENDS:=@TARGET_sunxi
$(call AddDepends/rtc)
KCONFIG:= \
- CONFIG_RTC_CLASS=y \
- CONFIG_RTC_DRV_SUNXI=m
+ CONFIG_RTC_DRV_SUNXI \
+ CONFIG_RTC_CLASS=y
FILES:=$(LINUX_DIR)/drivers/rtc/rtc-sunxi.ko
AUTOLOAD:=$(call AutoLoad,50,rtc-sunxi)
endef