aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorCezary Jackiewicz <cezary@eko.one.pl>2017-01-04 18:51:35 +0100
committerFelix Fietkau <nbd@nbd.name>2017-01-06 15:35:20 +0100
commit4235cd0d951b588892f4520e88c7bd219668cee1 (patch)
tree8607189745f2f64d521fc801ecd84ff3ad1c18e9 /target
parent476e77c3b7aa055fa5424a2f7ef843d307c4d20d (diff)
downloadupstream-4235cd0d951b588892f4520e88c7bd219668cee1.tar.gz
upstream-4235cd0d951b588892f4520e88c7bd219668cee1.tar.bz2
upstream-4235cd0d951b588892f4520e88c7bd219668cee1.zip
x86: add kernel module for AMD CS5535/CS5536 audio chipset
Add support for the integrated AC97 sound device on motherboards with AMD CS5535/CS5536 chipsets. Tested on Wyse Winterm S30. Signed-off-by: Cezary Jackiewicz <cezary@eko.one.pl>
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/modules.mk21
1 files changed, 21 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
new file mode 100644
index 0000000000..656500b290
--- /dev/null
+++ b/target/linux/x86/modules.mk
@@ -0,0 +1,21 @@
+#
+# Copyright (C) 2017 Cezary Jackiewicz <cezary@eko.one.pll>
+#
+# This is free software, licensed under the GNU General Public License v2.
+#
+
+define KernelPackage/sound-cs5535audio
+ TITLE:=CS5535/CS5536 Audio Controller
+ DEPENDS:=@TARGET_x86_geode +kmod-ac97
+ KCONFIG:=CONFIG_SND_CS5535AUDIO
+ FILES:=$(LINUX_DIR)/sound/pci/cs5535audio/snd-cs5535audio.ko
+ AUTOLOAD:=$(call AutoLoad,36,snd-cs5535audio)
+ $(call AddDepends/sound)
+endef
+
+define KernelPackage/sound-cs5535audio/description
+ Support for the integrated AC97 sound device on motherboards
+ with AMD CS5535/CS5536 chipsets.
+endef
+
+$(eval $(call KernelPackage,sound-cs5535audio))