aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRosen Penev <rosenp@gmail.com>2016-10-29 20:50:45 -0700
committerJohn Crispin <john@phrozen.org>2016-10-31 16:41:26 +0100
commit369884c2a18cf082f0d13652deaf2415700dc842 (patch)
tree81eae9f5a74952802a44ced2869192805b50fa1c /target
parent0744b6a044a4d97006905b95658b9b5d854f3dd1 (diff)
downloadupstream-369884c2a18cf082f0d13652deaf2415700dc842.tar.gz
upstream-369884c2a18cf082f0d13652deaf2415700dc842.tar.bz2
upstream-369884c2a18cf082f0d13652deaf2415700dc842.zip
ramips: Add RTC driver to kernel for working hctosys
Build the RTC driver into the kernel, (and remove the optional module), in order to make hctosys working. (Currently the module is loaded after hctosys has failed previously) Signed-off-by: Rosen Penev <rosenp@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7621.mk4
-rw-r--r--target/linux/ramips/mt7621/config-4.41
2 files changed, 3 insertions, 2 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index 234c7a76d9..e0fbb61119 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -96,7 +96,7 @@ define Device/pbr-m1
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_TITLE := PBR-M1
DEVICE_PACKAGES := kmod-usb3 kmod-usb-ledtrig-usbport kmod-ata-core kmod-ata-ahci \
- kmod-rtc-pcf8563 kmod-i2c-mt7621
+ kmod-i2c-mt7621
endef
TARGET_DEVICES += pbr-m1
@@ -119,7 +119,7 @@ define Device/witi
IMAGE_SIZE := $(ralink_default_fw_size_16M)
DEVICE_TITLE := MQmaker WiTi
DEVICE_PACKAGES := kmod-usb3 kmod-usb-ledtrig-usbport kmod-ata-core kmod-ata-ahci \
- kmod-rtc-pcf8563 kmod-i2c-mt7621
+ kmod-i2c-mt7621
endef
TARGET_DEVICES += witi
diff --git a/target/linux/ramips/mt7621/config-4.4 b/target/linux/ramips/mt7621/config-4.4
index 9132d894df..47b208b773 100644
--- a/target/linux/ramips/mt7621/config-4.4
+++ b/target/linux/ramips/mt7621/config-4.4
@@ -214,6 +214,7 @@ CONFIG_RESET_CONTROLLER=y
CONFIG_RFS_ACCEL=y
CONFIG_RPS=y
CONFIG_RTC_CLASS=y
+CONFIG_RTC_DRV_PCF8563=y
CONFIG_SCHED_HRTICK=y
# CONFIG_SCHED_INFO is not set
CONFIG_SCHED_SMT=y