aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDjango Armstrong <iamdjango@hotmail.com>2019-01-20 16:46:42 +0000
committerMathias Kresin <dev@kresin.me>2019-01-26 21:46:33 +0100
commit1c2f7b511514d43d8a826b26e09817b2750a2bf4 (patch)
tree1d704f9637e879606be61a01a7a3b494e5668ff8 /target
parent2a4e756085ad88969dbab32961119fe65e3b46b3 (diff)
downloadupstream-1c2f7b511514d43d8a826b26e09817b2750a2bf4.tar.gz
upstream-1c2f7b511514d43d8a826b26e09817b2750a2bf4.tar.bz2
upstream-1c2f7b511514d43d8a826b26e09817b2750a2bf4.zip
ath79: add support for Devolo WiFi Pro 1750e
Hardware -------- CPU: Qualcomm Atheros QCA9558 RAM: 128M DDR2 FLASH: 16MiB ETH: 1x Atheros AR8035 (PoE in) 1x Atheros AR8033 WiFi2: QCA9558 3T3R (SiGE SE2565T 2.4 GHz power amp x3) WiFi5: QCA9880 3T3R (Skyworks 5003L1 5 GHz power amp x3) BTN: 1x Reset 1x WPS 1x USB eject LED: 1x LED blue 1x LED red BEEP: 1x GPIO attached piezo beeper UART: 3.3V GND TX RX (115200-N-8) (3.3V is pin closest to rear ports) Dupont 4 pin header Rear RJ45 serial port non-functional USB: 1x v2.0 Installation ------------ Make sure you set a password for the root user as prompted on first setup! 1. Upload OpenWRT sysupgrade image via SSH to the device. Use /tmp as the destination folder on the device. User is root, password previously set in the web interface. 2. Install OpenWRT with > sysupgrade -n -F /tmp/<openwrt-image-name> Signed-off-by: Django Armstrong <iamdjango@hotmail.com>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ath79/base-files/etc/board.d/02_network3
-rw-r--r--target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata1
-rw-r--r--target/linux/ath79/dts/qca9558_devolo_dvl1750e.dts83
-rw-r--r--target/linux/ath79/image/generic.mk8
4 files changed, 94 insertions, 1 deletions
diff --git a/target/linux/ath79/base-files/etc/board.d/02_network b/target/linux/ath79/base-files/etc/board.d/02_network
index 1569b110bd..4197f331b7 100755
--- a/target/linux/ath79/base-files/etc/board.d/02_network
+++ b/target/linux/ath79/base-files/etc/board.d/02_network
@@ -62,7 +62,8 @@ ath79_setup_interfaces()
ucidef_add_switch "switch0" \
"0@eth0" "1:lan:1" "3:lan:4" "4:lan:3" "5:lan:2" "2:wan"
;;
- devolo,dvl1200e)
+ devolo,dvl1200e|\
+ devolo,dvl1750e)
ucidef_set_interface_lan "eth0 eth1"
;;
dlink,dir-825-b1)
diff --git a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
index 76efa24b52..84e43ceee5 100644
--- a/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
+++ b/target/linux/ath79/base-files/etc/hotplug.d/firmware/11-ath10k-caldata
@@ -90,6 +90,7 @@ case "$FIRMWARE" in
devolo,dvl1200e|\
devolo,dvl1200i|\
devolo,dvl1750c|\
+ devolo,dvl1750e|\
devolo,dvl1750i)
ath10kcal_extract "art" 20480 2116
ath10kcal_patch_mac_crc $(macaddr_add $(mtd_get_mac_binary art 0) -1)
diff --git a/target/linux/ath79/dts/qca9558_devolo_dvl1750e.dts b/target/linux/ath79/dts/qca9558_devolo_dvl1750e.dts
new file mode 100644
index 0000000000..2570eb7cea
--- /dev/null
+++ b/target/linux/ath79/dts/qca9558_devolo_dvl1750e.dts
@@ -0,0 +1,83 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "qca9558_devolo_dvl1xxx.dtsi"
+
+/ {
+ compatible = "devolo,dvl1750e", "qca,qca9557";
+ model = "devolo WiFi pro 1750e";
+
+ aliases {
+ led-boot = &status_blue;
+ led-failsafe = &status_red;
+ led-running = &status_blue;
+ led-upgrade = &status_red;
+ };
+
+ keys {
+ wps {
+ label = "WPS Button";
+ linux,code = <KEY_WPS_BUTTON>;
+ gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+
+ usb_eject {
+ label = "USB Eject Button";
+ linux,code = <BTN_0>;
+ linux,input-type = <EV_SW>;
+ gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ status_blue: status_blue {
+ label = "dvl1750e:blue:status";
+ gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+ default-state = "on";
+ };
+
+ status_red: status_red {
+ label = "dvl1750e:red:status";
+ gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+ };
+ };
+
+ beeper {
+ compatible = "gpio-beeper";
+ gpios = <&gpio 4 GPIO_ACTIVE_HIGH>;
+ };
+
+
+ gpio_export {
+ compatible = "gpio-export";
+
+ gpio_usb_power {
+ gpio-export,name = "devolo:power:usb";
+ gpio-export,output = <1>;
+ gpios = <&gpio 11 GPIO_ACTIVE_HIGH>;
+ };
+ };
+};
+
+&usb_phy0 {
+ status = "okay";
+};
+
+&usb0 {
+ status = "okay";
+};
+
+&mdio1 {
+ status = "okay";
+};
+
+&eth1 {
+ status = "okay";
+};
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index 22ba5305b1..9d0412fe97 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -186,6 +186,14 @@ define Device/devolo_dvl1750c
endef
TARGET_DEVICES += devolo_dvl1750c
+define Device/devolo_dvl1750e
+ ATH_SOC := qca9558
+ DEVICE_TITLE := devolo WiFi pro 1750e
+ DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca988x-ct
+ IMAGE_SIZE := 15936k
+endef
+TARGET_DEVICES += devolo_dvl1750e
+
define Device/devolo_dvl1750i
ATH_SOC := qca9558
DEVICE_TITLE := devolo WiFi pro 1750i