aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-03-21 18:10:55 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-03-21 18:10:55 +0000
commit16d645378e09d091305085f308df972d94bb9398 (patch)
treeccde8fbab164ae935ae2cbec2defa8d3e438d57f /target
parent3bd14c6197013ac10740154b0f3c019829ff8f59 (diff)
downloadupstream-16d645378e09d091305085f308df972d94bb9398.tar.gz
upstream-16d645378e09d091305085f308df972d94bb9398.tar.bz2
upstream-16d645378e09d091305085f308df972d94bb9398.zip
Enable profiles for adm5120
SVN-Revision: 6629
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120-2.6/profiles/100-Atheros.mk17
-rw-r--r--target/linux/adm5120-2.6/profiles/110-None.mk17
2 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/adm5120-2.6/profiles/100-Atheros.mk b/target/linux/adm5120-2.6/profiles/100-Atheros.mk
new file mode 100644
index 0000000000..029586848f
--- /dev/null
+++ b/target/linux/adm5120-2.6/profiles/100-Atheros.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Atheros
+ NAME:=Atheros WiFi (default)
+ PACKAGES:=kmod-madwifi
+endef
+
+define Profile/Atheros/Description
+ Package set compatible with hardware using Atheros WiFi cards
+endef
+$(eval $(call Profile,Atheros))
+
diff --git a/target/linux/adm5120-2.6/profiles/110-None.mk b/target/linux/adm5120-2.6/profiles/110-None.mk
new file mode 100644
index 0000000000..2fcfacde9f
--- /dev/null
+++ b/target/linux/adm5120-2.6/profiles/110-None.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/None
+ NAME:=No WiFi
+ PACKAGES:=
+endef
+
+define Profile/None/Description
+ Package set without WiFi support
+endef
+$(eval $(call Profile,None))
+