aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAlexander Wördekemper <alexwoerde@web.de>2019-05-16 16:24:43 +0200
committerPetr Štetiar <ynezz@true.cz>2019-05-20 21:25:00 +0200
commit0f6b944c923537b9bc08da23f363b409d1e564b3 (patch)
tree8122dc77e5de055e5a1100926b9525e99195b8a6 /target
parent2f1a11d0089c9d4b675b0e1e8806e1e8e3be5a02 (diff)
downloadupstream-0f6b944c923537b9bc08da23f363b409d1e564b3.tar.gz
upstream-0f6b944c923537b9bc08da23f363b409d1e564b3.tar.bz2
upstream-0f6b944c923537b9bc08da23f363b409d1e564b3.zip
ath79: glinet_gl-ar750s: Add USB power & microSD
The GL.iNet AR750S USB and microSD port is currently not working out of the box. GPIO 7 is used to control the power of the USB port. Add GPIO 7 as a fixed-regulator for the port. Also add &usb1 to DTS to get the microSD port to work. Signed-off-by: Alexander Wördekemper <alexwoerde@web.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts29
-rw-r--r--target/linux/ath79/image/generic.mk2
2 files changed, 23 insertions, 8 deletions
diff --git a/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
index 378de5de90..0145a24fba 100644
--- a/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
+++ b/target/linux/ath79/dts/qca9563_glinet_gl-ar750s.dts
@@ -62,6 +62,19 @@
linux,default-trigger = "phy0tpt";
};
};
+
+ usb_vbus: regulator-usb-vbus {
+ compatible = "regulator-fixed";
+
+ regulator-name = "USB_VBUS";
+
+ regulator-min-microvolt = <5000000>;
+ regulator-max-microvolt = <5000000>;
+ regulator-always-on;
+
+ gpio = <&gpio 7 GPIO_ACTIVE_HIGH>;
+ enable-active-high;
+ };
};
&spi {
@@ -113,20 +126,22 @@
};
&usb0 {
- #address-cells = <1>;
- #size-cells = <0>;
status = "okay";
-
- hub_port: port@1 {
- reg = <1>;
- #trigger-source-cells = <0>;
- };
+ vbus-supply = <&usb_vbus>;
};
&usb_phy0 {
status = "okay";
};
+&usb1 {
+ status = "okay";
+};
+
+&usb_phy1 {
+ status = "okay";
+};
+
&mdio0 {
status = "okay";
phy-mask = <0>;
diff --git a/target/linux/ath79/image/generic.mk b/target/linux/ath79/image/generic.mk
index dd5843d436..b8558a59f0 100644
--- a/target/linux/ath79/image/generic.mk
+++ b/target/linux/ath79/image/generic.mk
@@ -383,7 +383,7 @@ TARGET_DEVICES += glinet_gl-ar300m-nor
define Device/glinet_gl-ar750s
ATH_SOC := qca9563
DEVICE_TITLE := GL.iNet GL-AR750S
- DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9887-ct
+ DEVICE_PACKAGES := kmod-usb2 kmod-ath10k-ct ath10k-firmware-qca9887-ct block-mount
IMAGE_SIZE := 16000k
SUPPORTED_DEVICES += gl-ar750s
endef