aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorTomasz Maciej Nowak <tomek_n@o2.pl>2019-05-11 19:37:29 +0200
committerHauke Mehrtens <hauke@hauke-m.de>2019-05-11 23:11:04 +0200
commitef384c68e7271a6e9a652e26fe8adf4c822f0213 (patch)
treece4b8cc260d224712f0032a51bf1d09c3f644609 /target
parentf0c2bac25287858dedd0756e6ba75677f8320da9 (diff)
downloadupstream-ef384c68e7271a6e9a652e26fe8adf4c822f0213.tar.gz
upstream-ef384c68e7271a6e9a652e26fe8adf4c822f0213.tar.bz2
upstream-ef384c68e7271a6e9a652e26fe8adf4c822f0213.zip
mvebu: image: stack repeated variables
All of arm64 devices have part of variables repeatedly defined. Stack them to common define, and reference it in each device recipe. Signed-off-by: Tomasz Maciej Nowak <tomek_n@o2.pl>
Diffstat (limited to 'target')
-rw-r--r--target/linux/mvebu/image/Makefile8
-rw-r--r--target/linux/mvebu/image/cortex-a53.mk12
-rw-r--r--target/linux/mvebu/image/cortex-a72.mk20
3 files changed, 15 insertions, 25 deletions
diff --git a/target/linux/mvebu/image/Makefile b/target/linux/mvebu/image/Makefile
index 72b14e344b..5f4ab89716 100644
--- a/target/linux/mvebu/image/Makefile
+++ b/target/linux/mvebu/image/Makefile
@@ -83,6 +83,14 @@ define Device/Default
endef
DEVICE_VARS += UBOOT
+define Device/Default-arm64
+ DTS_DIR := $(DTS_DIR)/marvell
+ IMAGES := sdcard.img.gz
+ IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+endef
+
define Device/UBI
IMAGES := sysupgrade.bin
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
diff --git a/target/linux/mvebu/image/cortex-a53.mk b/target/linux/mvebu/image/cortex-a53.mk
index dd6176100b..a102f52481 100644
--- a/target/linux/mvebu/image/cortex-a53.mk
+++ b/target/linux/mvebu/image/cortex-a53.mk
@@ -1,25 +1,17 @@
ifeq ($(SUBTARGET),cortexa53)
define Device/globalscale-espressobin
- KERNEL_NAME := Image
- KERNEL := kernel-bin
+ $(call Device/Default-arm64)
DEVICE_TITLE := ESPRESSObin (Marvell Armada 3700 Community Board)
- IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-3720-espressobin
- DTS_DIR := $(DTS_DIR)/marvell
SUPPORTED_DEVICES := globalscale,espressobin
endef
TARGET_DEVICES += globalscale-espressobin
define Device/armada-3720-db
- KERNEL_NAME := Image
- KERNEL := kernel-bin
+ $(call Device/Default-arm64)
DEVICE_TITLE := Marvell Armada 3720 Development Board DB-88F3720-DDR3
- IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-3720-db
- DTS_DIR := $(DTS_DIR)/marvell
SUPPORTED_DEVICES := marvell,armada-3720-db
endef
TARGET_DEVICES += armada-3720-db
diff --git a/target/linux/mvebu/image/cortex-a72.mk b/target/linux/mvebu/image/cortex-a72.mk
index 25bcf534bc..824f6b5d0f 100644
--- a/target/linux/mvebu/image/cortex-a72.mk
+++ b/target/linux/mvebu/image/cortex-a72.mk
@@ -1,38 +1,28 @@
ifeq ($(SUBTARGET),cortexa72)
define Device/armada-macchiatobin
- KERNEL_NAME := Image
- KERNEL := kernel-bin
+ $(call Device/Default-arm64)
DEVICE_TITLE := MACCHIATObin (SolidRun Armada 8040 Community Board)
DEVICE_PACKAGES += kmod-i2c-core kmod-i2c-mux kmod-i2c-mux-pca954x
- IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-scr | boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-8040-mcbin
- DTS_DIR := $(DTS_DIR)/marvell
SUPPORTED_DEVICES := marvell,armada8040-mcbin
endef
TARGET_DEVICES += armada-macchiatobin
define Device/armada-8040-db
- KERNEL_NAME := Image
- KERNEL := kernel-bin
+ $(call Device/Default-arm64)
DEVICE_TITLE := Marvell Armada 8040 DB board
- IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-8040-db
- DTS_DIR := $(DTS_DIR)/marvell
+ IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
SUPPORTED_DEVICES := marvell,armada8040-db
endef
TARGET_DEVICES += armada-8040-db
define Device/armada-7040-db
- KERNEL_NAME := Image
- KERNEL := kernel-bin
+ $(call Device/Default-arm64)
DEVICE_TITLE := Marvell Armada 7040 DB board
- IMAGES := sdcard.img.gz
- IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
DEVICE_DTS := armada-7040-db
- DTS_DIR := $(DTS_DIR)/marvell
+ IMAGE/sdcard.img.gz := boot-img-ext4 | sdcard-img-ext4 | gzip | append-metadata
SUPPORTED_DEVICES := marvell,armada7040-db
endef
TARGET_DEVICES += armada-7040-db