aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-04-18 10:19:28 +0000
committerJohn Crispin <john@openwrt.org>2015-04-18 10:19:28 +0000
commitd9ebcce56cf191cf0c13612c62c4097be1bc087a (patch)
treea48ceeedc63508928311ee281947e803cc8cf9fd /target
parent09c4b0e8f357fef0d42c20f004571353b7ace2a5 (diff)
downloadupstream-d9ebcce56cf191cf0c13612c62c4097be1bc087a.tar.gz
upstream-d9ebcce56cf191cf0c13612c62c4097be1bc087a.tar.bz2
upstream-d9ebcce56cf191cf0c13612c62c4097be1bc087a.zip
ar71xx/image: remove duplicated rootfs in new tplink initramfs images
The new building code included the rootfs twice when building tplink initramfs images. To make it more readable move initramfs into an own build step Build/mktplinkfw-initramfs. Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 45491
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile18
1 files changed, 14 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4819ab983b..49c3ca04b2 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -56,10 +56,20 @@ define Build/mktplinkfw
-k $(word 1,$^) \
-r $@ \
-o $@.new \
+ -j -X 0x40000 \
-a $(call rootfs_align,$(FILESYSTEM)) \
- $(if $(findstring sysupgrade,$1),-j -X 0x40000 -s) \
- $(if $(findstring factory,$1),-j -X 0x40000) \
- $(if $(findstring initramfs,$1),-s -c)
+ $(if $(findstring sysupgrade,$1),-s)
+ @mv $@.new $@
+endef
+
+# -c combined image
+define Build/mktplinkfw-initramfs
+ $(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -H $(TPLINK_HWID) -W $(TPLINK_HWREV) -F $(TPLINK_FLASHLAYOUT) -N OpenWrt -V $(REVISION) \
+ -k $@ \
+ -o $@.new \
+ -s \
+ -c
@mv $@.new $@
endef
@@ -138,7 +148,7 @@ TARGET_DEVICES += wndr3700 wndr3700v2 wndr3800 wndr3800ch wndrmac wndrmacv2
define Device/tplink
TPLINK_HWREV := 0x1
KERNEL := kernel-bin | patch-cmdline | lzma
- KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | mktplinkfw initramfs
+ KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | mktplinkfw-initramfs
IMAGES := sysupgrade.bin factory.bin
IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade
IMAGE/factory.bin := append-rootfs | mktplinkfw factory