aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRoger Pueyo Centelles <roger.pueyo@guifi.net>2018-10-24 18:07:43 +0200
committerMathias Kresin <dev@kresin.me>2018-11-28 01:11:38 +0100
commitcb6a8aa584a2be62aeac9b5b1573303d5615c672 (patch)
tree6af5045804ef5b0966f0adab01e7ca03fd0a9a43 /target
parentdf3e0b580644bd8434a690802e3c5c18a6e38098 (diff)
downloadupstream-cb6a8aa584a2be62aeac9b5b1573303d5615c672.tar.gz
upstream-cb6a8aa584a2be62aeac9b5b1573303d5615c672.tar.bz2
upstream-cb6a8aa584a2be62aeac9b5b1573303d5615c672.zip
ramips: mt7620: add DIR-810L's mt7610e 5 GHz radio
The 5 GHz radio of this device uses an mt7610e pci-e chip, which has been recently added support. Tested on the actual device as AP and client, TCP throughput ~90 Mbps U/D. Signed-off-by: Roger Pueyo Centelles <roger.pueyo@guifi.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/dts/DIR-810L.dts8
-rw-r--r--target/linux/ramips/image/mt7620.mk3
2 files changed, 10 insertions, 1 deletions
diff --git a/target/linux/ramips/dts/DIR-810L.dts b/target/linux/ramips/dts/DIR-810L.dts
index b38290af53..c6d437820d 100644
--- a/target/linux/ramips/dts/DIR-810L.dts
+++ b/target/linux/ramips/dts/DIR-810L.dts
@@ -143,3 +143,11 @@
&wmac {
ralink,mtd-eeprom = <&factory 0>;
};
+
+&pcie0 {
+ wifi@0,0 {
+ reg = <0x0000 0 0 0 0>;
+ mediatek,mtd-eeprom = <&factory 0x8000>;
+ ieee80211-freq-limit = <5000000 6000000>;
+ };
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index bf04a75ea1..a7aeaf130c 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -154,8 +154,9 @@ TARGET_DEVICES += dch-m225
define Device/dir-810l
DTS := DIR-810L
- IMAGE_SIZE := 6720k
+ DEVICE_PACKAGES := kmod-mt76x0e
DEVICE_TITLE := D-Link DIR-810L
+ IMAGE_SIZE := 6720k
endef
TARGET_DEVICES += dir-810l