aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-09 19:23:22 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-09 19:23:22 +0000
commitc0fb2f61f4e1e6cb97a171e624b479e5fb451934 (patch)
tree28d455ab73ef0ab5b5aad5034c85a798bf76c6c0 /target
parent27baec04a1d707d5b6229509c66630bd6864a704 (diff)
downloadupstream-c0fb2f61f4e1e6cb97a171e624b479e5fb451934.tar.gz
upstream-c0fb2f61f4e1e6cb97a171e624b479e5fb451934.tar.bz2
upstream-c0fb2f61f4e1e6cb97a171e624b479e5fb451934.zip
add custom GPIO-based I2C driver
SVN-Revision: 9218
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120/files/drivers/i2c/busses/i2c-gpio-custom.c71
-rw-r--r--target/linux/adm5120/patches-2.6.22/300-i2c_gpio_custom.patch53
-rw-r--r--target/linux/generic-2.6/config-2.6.221
3 files changed, 125 insertions, 0 deletions
diff --git a/target/linux/adm5120/files/drivers/i2c/busses/i2c-gpio-custom.c b/target/linux/adm5120/files/drivers/i2c/busses/i2c-gpio-custom.c
new file mode 100644
index 0000000000..a019fafcc8
--- /dev/null
+++ b/target/linux/adm5120/files/drivers/i2c/busses/i2c-gpio-custom.c
@@ -0,0 +1,71 @@
+/*
+ * Custom GPIO-based I2C driver
+ *
+ * Copyright (C) 2007 Gabor Juhos <juhosg at openwrt.org>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ */
+
+#include <linux/kernel.h>
+#include <linux/module.h>
+#include <linux/init.h>
+#include <linux/platform_device.h>
+
+#include <linux/i2c-gpio.h>
+
+#define DRV_NAME "i2c-gpio-custom"
+#define DRV_DESC "Custom GPIO I2C device driver"
+
+static unsigned int sda = CONFIG_I2C_GPIO_CUSTOM_SDA;
+static unsigned int scl = CONFIG_I2C_GPIO_CUSTOM_SCL;
+static int id = CONFIG_I2C_GPIO_CUSTOM_DEVICE_ID;
+
+module_param(sda, uint, S_IRUGO);
+MODULE_PARM_DESC(sda, "GPIO pin for SDA");
+
+module_param(scl, uint, S_IRUGO);
+MODULE_PARM_DESC(scl, "GPIO pin for SCL");
+
+module_param(id, int, S_IRUGO);
+MODULE_PARM_DESC(id, "device id of the i2c-gpio device");
+
+static struct i2c_gpio_platform_data i2c_data;
+static struct platform_device i2c_device;
+
+static void i2c_gpio_custom_release(struct platform_device *pdev)
+{
+ /* nothing to do */
+}
+
+static int __init i2c_gpio_custom_init(void)
+{
+ int err;
+
+ i2c_data.sda_pin = sda;
+ i2c_data.scl_pin = scl;
+
+ i2c_device.name = "i2c-gpio";
+ i2c_device.id = id;
+
+ i2c_device.dev.platform_data = &i2c_data,
+ i2c_device.dev.release = i2c_gpio_custom_release,
+
+ err = platform_device_register(&i2c_device);
+
+ return err;
+}
+
+static void __exit i2c_gpio_custom_exit(void)
+{
+ platform_device_unregister(&i2c_device);
+}
+
+module_init(i2c_gpio_custom_init);
+module_exit(i2c_gpio_custom_exit);
+
+MODULE_LICENSE("GPL v2");
+MODULE_AUTHOR("Gabor Juhos <juhosg at openwrt.org >");
+MODULE_DESCRIPTION(DRV_DESC);
+
diff --git a/target/linux/adm5120/patches-2.6.22/300-i2c_gpio_custom.patch b/target/linux/adm5120/patches-2.6.22/300-i2c_gpio_custom.patch
new file mode 100644
index 0000000000..2bbb197d69
--- /dev/null
+++ b/target/linux/adm5120/patches-2.6.22/300-i2c_gpio_custom.patch
@@ -0,0 +1,53 @@
+--- linux-2.6.22.4.orig/drivers/i2c/busses/Kconfig 2007-08-21 06:33:06.000000000 +0200
++++ linux-2.6.22.4/drivers/i2c/busses/Kconfig 2007-10-09 12:53:13.000000000 +0200
+@@ -125,6 +125,40 @@
+ This is a very simple bitbanging I2C driver utilizing the
+ arch-neutral GPIO API to control the SCL and SDA lines.
+
++config I2C_GPIO_CUSTOM
++ tristate "Custom GPIO-based I2C device"
++ depends on GENERIC_GPIO
++ select I2C_GPIO
++ help
++ This is an I2C driver to register a custom i2c-gpio device.
++
++ This support is also available as a module. If so, the module
++ will be called i2c-gpio-dev.
++
++config I2C_GPIO_CUSTOM_SDA
++ int "Custom GPIO pin for SDA"
++ depends on I2C_GPIO_CUSTOM
++ default "0"
++ help
++ Enter the GPIO pin number used for the SDA signal. This value can
++ also be specified with a module parameter.
++
++config I2C_GPIO_CUSTOM_SCL
++ int "Custom GPIO pin for SCL"
++ depends on I2C_GPIO_CUSTOM
++ default "1"
++ help
++ Enter the GPIO pin number used for the SCL signal. This value can
++ also be specified with a module parameter.
++
++config I2C_GPIO_CUSTOM_DEVICE_ID
++ int "Custom GPIO device id"
++ depends on I2C_GPIO_CUSTOM
++ default "0"
++ help
++ Enter the number used for the device id of the custom i2c-gpio device.
++ This value can also be specified with a module parameter.
++
+ config I2C_HYDRA
+ tristate "CHRP Apple Hydra Mac I/O I2C interface"
+ depends on PCI && PPC_CHRP && EXPERIMENTAL
+--- linux-2.6.22.4.orig/drivers/i2c/busses/Makefile 2007-08-21 06:33:06.000000000 +0200
++++ linux-2.6.22.4/drivers/i2c/busses/Makefile 2007-10-09 12:07:45.000000000 +0200
+@@ -13,6 +13,7 @@
+ obj-$(CONFIG_I2C_BLACKFIN_TWI) += i2c-bfin-twi.o
+ obj-$(CONFIG_I2C_ELEKTOR) += i2c-elektor.o
+ obj-$(CONFIG_I2C_GPIO) += i2c-gpio.o
++obj-$(CONFIG_I2C_GPIO_CUSTOM) += i2c-gpio-custom.o
+ obj-$(CONFIG_I2C_HYDRA) += i2c-hydra.o
+ obj-$(CONFIG_I2C_I801) += i2c-i801.o
+ obj-$(CONFIG_I2C_I810) += i2c-i810.o
diff --git a/target/linux/generic-2.6/config-2.6.22 b/target/linux/generic-2.6/config-2.6.22
index ceed58e594..9b07183880 100644
--- a/target/linux/generic-2.6/config-2.6.22
+++ b/target/linux/generic-2.6/config-2.6.22
@@ -387,6 +387,7 @@ CONFIG_HZ_100=y
# CONFIG_I2C_DEBUG_CORE is not set
# CONFIG_I2C_ELEKTOR is not set
# CONFIG_I2C_GPIO is not set
+# CONFIG_I2C_GPIO_CUSTOM is not set
# CONFIG_I2C_I801 is not set
# CONFIG_I2C_I810 is not set
# CONFIG_I2C_NFORCE2 is not set