aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2007-10-05 14:50:53 +0000
committerGabor Juhos <juhosg@openwrt.org>2007-10-05 14:50:53 +0000
commitbcdd5d9b14847fef0cb566c0022d4cd1919a8ee5 (patch)
treeeff64e929c9f37304198dc1eb518032c8e0bafec /target
parent8c47e7b84283dd2bd95a564a4b5043c735083213 (diff)
downloadupstream-bcdd5d9b14847fef0cb566c0022d4cd1919a8ee5.tar.gz
upstream-bcdd5d9b14847fef0cb566c0022d4cd1919a8ee5.tar.bz2
upstream-bcdd5d9b14847fef0cb566c0022d4cd1919a8ee5.zip
Edimax BR-6104K/KP specific fixes * add profile for Edimax BR-6104KP which contains the experimental USB driver by default * generate CSYS style images which are uploadable via ADMBoot/TFTPBoot (saves 64KB of space) * update kernel configuration
SVN-Revision: 9141
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120/image/router_le.mk14
-rw-r--r--target/linux/adm5120/router_be/config-2.6.221
-rw-r--r--target/linux/adm5120/router_le/config-2.6.221
-rw-r--r--target/linux/adm5120/router_le/profiles/Edimax.mk17
4 files changed, 26 insertions, 7 deletions
diff --git a/target/linux/adm5120/image/router_le.mk b/target/linux/adm5120/image/router_le.mk
index 9f1aa9b2be..f910971599 100644
--- a/target/linux/adm5120/image/router_le.mk
+++ b/target/linux/adm5120/image/router_le.mk
@@ -16,7 +16,11 @@ define Image/Build/Edimax
$(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d -w \
-r $(KDIR)/loader-$(2).gz \
-x $(call imgname,$(1),$(2)).trx \
- $(call imgname,$(1),$(2)).bin
+ $(call imgname,$(1),$(2))-webui.bin
+ $(STAGING_DIR_HOST)/bin/mkcsysimg -B $(2) -d \
+ -r $(KDIR)/loader-$(2).gz \
+ -x $(call imgname,$(1),$(2)).trx \
+ $(call imgname,$(1),$(2))-xmodem.bin
endef
define Image/Build/Infineon
@@ -195,10 +199,6 @@ define Image/Build/Board/BR6104K/squashfs
$(call Image/Build/Board/BR6104K,squashfs)
endef
-define Image/Build/Board/BR6104K/jffs2-64k
- $(call Image/Build/Board/BR6104K,jffs2-64k)
-endef
-
define Image/Build/Board/BR6104K/Initramfs
$(call Image/Build/LZMAKernel/Admboot,br-6104k,gz)
endef
@@ -308,6 +308,10 @@ define Image/Build/Profile/CAS771W
$(call Image/Build/Board/CAS771W/$(1))
endef
+define Image/Build/Profile/BR6104KP
+ $(call Image/Build/Board/BR6104K/$(1))
+endef
+
define Image/Build/Profile/RouterBoard
$(call Image/Build/Board/RB1xx/$(1))
endef
diff --git a/target/linux/adm5120/router_be/config-2.6.22 b/target/linux/adm5120/router_be/config-2.6.22
index 43476e2321..0fca8f8fb1 100644
--- a/target/linux/adm5120/router_be/config-2.6.22
+++ b/target/linux/adm5120/router_be/config-2.6.22
@@ -230,7 +230,6 @@ CONFIG_TMPFS_POSIX_ACL=y
# CONFIG_TOSHIBA_RBTX4938 is not set
CONFIG_TRAD_SIGNALS=y
# CONFIG_UNUSED_SYMBOLS is not set
-CONFIG_USB=y
# CONFIG_USBPCWATCHDOG is not set
# CONFIG_USB_ACM is not set
CONFIG_USB_ADM5120_HCD=m
diff --git a/target/linux/adm5120/router_le/config-2.6.22 b/target/linux/adm5120/router_le/config-2.6.22
index 0f93b1affa..a876583603 100644
--- a/target/linux/adm5120/router_le/config-2.6.22
+++ b/target/linux/adm5120/router_le/config-2.6.22
@@ -239,7 +239,6 @@ CONFIG_TMPFS_POSIX_ACL=y
# CONFIG_TOSHIBA_RBTX4938 is not set
CONFIG_TRAD_SIGNALS=y
# CONFIG_UNUSED_SYMBOLS is not set
-CONFIG_USB=y
# CONFIG_USBPCWATCHDOG is not set
# CONFIG_USB_ACM is not set
CONFIG_USB_ADM5120_HCD=m
diff --git a/target/linux/adm5120/router_le/profiles/Edimax.mk b/target/linux/adm5120/router_le/profiles/Edimax.mk
new file mode 100644
index 0000000000..34798b2381
--- /dev/null
+++ b/target/linux/adm5120/router_le/profiles/Edimax.mk
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/BR6104KP
+ NAME:=Edimax BR-6104KP
+ PACKAGES:=kmod-usb-core kmod-usb-adm5120
+endef
+
+define Profile/BR6104KP/Description
+ Package set optimized for the Edimax BR-6104KP
+endef
+
+$(eval $(call Profile,BR6104KP))