aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorSungbo Eo <mans0n@gorani.run>2019-10-07 21:33:51 +0900
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-21 12:29:37 +0100
commitb6c80f85cb7bec6750fb0687b216e596a8db65a6 (patch)
tree648cc92e53275aaf50e3f7c3bfa9b42aac04171b /target
parente945c43142ab3ab374d3f671079d4008d3807bd7 (diff)
downloadupstream-b6c80f85cb7bec6750fb0687b216e596a8db65a6.tar.gz
upstream-b6c80f85cb7bec6750fb0687b216e596a8db65a6.tar.bz2
upstream-b6c80f85cb7bec6750fb0687b216e596a8db65a6.zip
ramips: set uImage name of WeVO 11AC NAS and W2914NS v2
The stock firmware and bootloader only accept uImage with names that match certain patterns. This patch enables OpenWrt installation from stock firmware without having to reflash the bootloader or access the UART console. Installation via web interface: 1. Flash **initramfs** image through the stock web interface. 2. Boot into OpenWrt and perform sysupgrade with sysupgrade image. Signed-off-by: Sungbo Eo <mans0n@gorani.run> (cherry picked from commit 19800ac095f6ddbba03ccab08e5197b1eec4a49e) [backported] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7621.mk2
1 files changed, 2 insertions, 0 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index aab6097d33..f13e9c8a4f 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -87,6 +87,7 @@ endef
define Device/11acnas
DTS := 11ACNAS
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ UIMAGE_NAME := 11AC-NAS-Router(0.0.0)
DEVICE_TITLE := WeVO 11AC NAS Router
DEVICE_PACKAGES := kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic
endef
@@ -509,6 +510,7 @@ TARGET_DEVICES += vr500
define Device/w2914nsv2
DTS := W2914NSV2
IMAGE_SIZE := $(ralink_default_fw_size_16M)
+ UIMAGE_NAME := W2914NS-V2(0.0.0)
DEVICE_TITLE := WeVO W2914NS v2
DEVICE_PACKAGES := \
kmod-mt7603 kmod-mt76x2 kmod-usb3 kmod-usb-ledtrig-usbport wpad-basic