aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMatthias Schiffer <mschiffer@universe-factory.net>2018-06-06 00:27:42 +0200
committerMatthias Schiffer <mschiffer@universe-factory.net>2018-06-06 22:25:52 +0200
commit8d851a95b7f581a844160b892e0e52b9bb5b9a68 (patch)
tree291c9fa86edae43e7f347c1ac537ba91793e89ef /target
parenta28e46b7cc3da7f7b0f8c20e23fe4563bb8fcc52 (diff)
downloadupstream-8d851a95b7f581a844160b892e0e52b9bb5b9a68.tar.gz
upstream-8d851a95b7f581a844160b892e0e52b9bb5b9a68.tar.bz2
upstream-8d851a95b7f581a844160b892e0e52b9bb5b9a68.zip
ar71xx: lzma-loader: set page size to 4KB
The text section in the ELF loader is aligned to the maximum page size, which defaults to 64KB. Reduce it to the actual page size to avoid wasting flash space for this alignment. Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/lzma-loader/src/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/lzma-loader/src/Makefile b/target/linux/ar71xx/image/lzma-loader/src/Makefile
index c54f64a550..7773f027a2 100644
--- a/target/linux/ar71xx/image/lzma-loader/src/Makefile
+++ b/target/linux/ar71xx/image/lzma-loader/src/Makefile
@@ -97,7 +97,7 @@ loader2.o: loader.bin
$(LD) -r -b binary --oformat $(O_FORMAT) -o $@ $<
loader.elf: loader2.o
- $(LD) -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
+ $(LD) -z max-page-size=0x1000 -e startup -T loader2.lds -Ttext $(LOADADDR) -o $@ $<
mrproper: clean