aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2015-11-02 10:17:15 +0000
committerJohn Crispin <john@openwrt.org>2015-11-02 10:17:15 +0000
commit7cc3beff324d2418c261b59a25dcf180b56232de (patch)
treee9d0bd2b25ca49d16804e6406a64fb04df2fcf8d /target
parente5e196b5b9cf146680efaca5cd24c591efd66806 (diff)
downloadupstream-7cc3beff324d2418c261b59a25dcf180b56232de.tar.gz
upstream-7cc3beff324d2418c261b59a25dcf180b56232de.tar.bz2
upstream-7cc3beff324d2418c261b59a25dcf180b56232de.zip
ar71xx: Add support for wdr7500v3
The device is similar to Archer C7 v2, but with 8M of flash, and 6 external antennas. Reason for breaking the naming pattern is that sticker on the back mentions "WDR7500" and has no mention of "Archer". Signed-off-by: Srdjan Rosic <rosic@google.com> SVN-Revision: 47344
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile9
1 files changed, 8 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index ddc0fc1b15..7bf2f278eb 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -372,7 +372,14 @@ define Device/archer-c7-v2
DEVICE_PROFILE := ARCHERC7
TPLINK_HWID := 0xc7000002
endef
-TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2
+
+define Device/tl-wdr7500-v3
+ $(Device/tplink-8mlzma)
+ BOARDNAME := ARCHER-C7
+ DEVICE_PROFILE := ARCHERC7
+ TPLINK_HWID := 0x75000003
+endef
+TARGET_DEVICES += archer-c5-v1 archer-c7-v1 archer-c7-v2 tl-wdr7500-v3
define Device/antminer-s1
$(Device/tplink-8mlzma)