aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <john@openwrt.org>2007-10-11 23:16:52 +0000
committerJohn Crispin <john@openwrt.org>2007-10-11 23:16:52 +0000
commit7745eb277df6c599506502823285b75d6733097f (patch)
tree52e8121ba3cf65ea5062583471fe517b43c16ab9 /target
parenta320eec777ec87541b7c4982d482fd153c4a66e2 (diff)
downloadupstream-7745eb277df6c599506502823285b75d6733097f.tar.gz
upstream-7745eb277df6c599506502823285b75d6733097f.tar.bz2
upstream-7745eb277df6c599506502823285b75d6733097f.zip
move atheros to 2.6.23
SVN-Revision: 9265
Diffstat (limited to 'target')
-rw-r--r--target/linux/atheros/Makefile2
-rw-r--r--target/linux/atheros/config-2.6.23 (renamed from target/linux/atheros/config-2.6.22)0
-rw-r--r--target/linux/atheros/files/arch/mips/atheros/board.c2
3 files changed, 3 insertions, 1 deletions
diff --git a/target/linux/atheros/Makefile b/target/linux/atheros/Makefile
index b1a2f570ae..453f896b51 100644
--- a/target/linux/atheros/Makefile
+++ b/target/linux/atheros/Makefile
@@ -11,7 +11,7 @@ BOARD:=atheros
BOARDNAME:=Atheros
FEATURES:=squashfs jffs2
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.23
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/atheros/config-2.6.22 b/target/linux/atheros/config-2.6.23
index de6e4b6f9d..de6e4b6f9d 100644
--- a/target/linux/atheros/config-2.6.22
+++ b/target/linux/atheros/config-2.6.23
diff --git a/target/linux/atheros/files/arch/mips/atheros/board.c b/target/linux/atheros/files/arch/mips/atheros/board.c
index 1ea66c0c19..ebb4a5afef 100644
--- a/target/linux/atheros/files/arch/mips/atheros/board.c
+++ b/target/linux/atheros/files/arch/mips/atheros/board.c
@@ -29,6 +29,8 @@
char *board_config, *radio_config;
+extern int early_serial_setup(struct uart_port *port);
+
static u8 *find_board_config(char *flash_limit)
{
char *addr;