aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChristoph Krapp <achterin@googlemail.com>2019-08-29 20:12:30 +0200
committerDaniel Golle <daniel@makrotopia.org>2020-01-21 13:15:39 +0200
commit67595ce3805262a8dacd49077863f1b1599b28a9 (patch)
tree45c0f82da92e0f511ac7b0264582d70f5882596b /target
parent9c6913ccad078c075cb687f10aeeb6cfc9cc4805 (diff)
downloadupstream-67595ce3805262a8dacd49077863f1b1599b28a9.tar.gz
upstream-67595ce3805262a8dacd49077863f1b1599b28a9.tar.bz2
upstream-67595ce3805262a8dacd49077863f1b1599b28a9.zip
ramips: add factory image for Netgear R6350
This adds factory image generation for all three devices. These images can be flashed via WebUI for easy installation. Thanks to David Bauer for the inspiration. Signed-off-by: Christoph Krapp <achterin@googlemail.com> [altered commit to only include the R6350] Signed-off-by: David Bauer <mail@david-bauer.net> (cherry picked from commit 3c8df280a96bbd81357d6eb52845e6b5fa7162fe) Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/mt7621.mk7
1 files changed, 6 insertions, 1 deletions
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index fd3a8e558e..8efda0784c 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -368,7 +368,12 @@ define Device/netgear_r6350
KERNEL_SIZE := 4096k
IMAGE_SIZE := 40960k
UBINIZE_OPTS := -E 5
- IMAGES += kernel.bin rootfs.bin
+ SERCOMM_HWID := CHJ
+ SERCOMM_HWVER := A001
+ SERCOMM_SWVER := 0x0052
+ IMAGES += factory.img kernel.bin rootfs.bin
+ IMAGE/factory.img := pad-extra 2048k | append-kernel | pad-to 6144k | append-ubi | \
+ pad-to $$$$(BLOCKSIZE) | sercom-footer | pad-to 128 | zip $$$$(DEVICE_MODEL).bin | sercom-seal
IMAGE/sysupgrade.bin := sysupgrade-tar | append-metadata
IMAGE/kernel.bin := append-kernel
IMAGE/rootfs.bin := append-ubi | check-size $$$$(IMAGE_SIZE)