aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-12-17 00:30:21 +0100
committerMathias Kresin <dev@kresin.me>2017-12-21 01:05:16 +0100
commit6545c71d2c7c766e9caadd379192d39a94c949ad (patch)
treeacff36e30eb6557163769b4d58a6c85daf20e9f2 /target
parent7d3ec5f8332859be4c5da6275df1cbdfad6e73b5 (diff)
downloadupstream-6545c71d2c7c766e9caadd379192d39a94c949ad.tar.gz
upstream-6545c71d2c7c766e9caadd379192d39a94c949ad.tar.bz2
upstream-6545c71d2c7c766e9caadd379192d39a94c949ad.zip
ramips: sync image filename with boardname
Use <manufacturer>_<modelname> as image name for board using the devicetree compat string as boardname. Replace the underline of the device define, to keep the SUPPORTED_DEVICES in sync with a devicetree compat string based boardname. Override the default SUPPORTED_DEVICES for board which are having an userspace boardname with an underline. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ramips/image/Makefile2
-rw-r--r--target/linux/ramips/image/mt7620.mk6
-rw-r--r--target/linux/ramips/image/mt7621.mk5
3 files changed, 9 insertions, 4 deletions
diff --git a/target/linux/ramips/image/Makefile b/target/linux/ramips/image/Makefile
index c70761b250..ea7ce0bc90 100644
--- a/target/linux/ramips/image/Makefile
+++ b/target/linux/ramips/image/Makefile
@@ -39,7 +39,7 @@ define Device/Default
DEVICE_DTS_DIR := ../dts
IMAGES := sysupgrade.bin
IMAGE_SIZE := $(ralink_default_fw_size_8M)
- SUPPORTED_DEVICES = $(1)
+ SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
sysupgrade_bin := append-kernel | append-rootfs | pad-rootfs
IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
endef
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index a55cc8214b..229ccf845c 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -252,6 +252,7 @@ define Device/kng_rc
IMAGES += factory.bin
IMAGE/factory.bin := $$(sysupgrade_bin) | pad-to 64k | check-size $$$$(IMAGE_SIZE) | \
zyimage -d 8997 -v "ZyXEL Keenetic Viva"
+ SUPPORTED_DEVICES := kng_rc
endef
TARGET_DEVICES += kng_rc
@@ -262,6 +263,7 @@ define Device/kn_rc
IMAGES += factory.bin
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | pad-to 64k | check-size $$$$(IMAGE_SIZE) | \
zyimage -d 4882 -v "ZyXEL Keenetic Omni"
+ SUPPORTED_DEVICES := kn_rc
endef
TARGET_DEVICES += kn_rc
@@ -272,6 +274,7 @@ define Device/kn_rf
IMAGES += factory.bin
IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | pad-to 64k | check-size $$$$(IMAGE_SIZE) | \
zyimage -d 2102034 -v "ZyXEL Keenetic Omni II"
+ SUPPORTED_DEVICES := kn_rf
endef
TARGET_DEVICES += kn_rf
@@ -313,18 +316,21 @@ TARGET_DEVICES += mt7620a
define Device/mt7620a_mt7530
DTS := MT7620a_MT7530
DEVICE_TITLE := MediaTek MT7620a + MT7530 EVB
+ SUPPORTED_DEVICES := mt7620a_mt7530
endef
TARGET_DEVICES += mt7620a_mt7530
define Device/mt7620a_mt7610e
DTS := MT7620a_MT7610e
DEVICE_TITLE := MediaTek MT7620a + MT7610e EVB
+ SUPPORTED_DEVICES := mt7620a_mt7610e
endef
TARGET_DEVICES += mt7620a_mt7610e
define Device/mt7620a_v22sg
DTS := MT7620a_V22SG
DEVICE_TITLE := MediaTek MT7620a V22SG
+ SUPPORTED_DEVICES := mt7620a_v22sg
endef
TARGET_DEVICES += mt7620a_v22sg
diff --git a/target/linux/ramips/image/mt7621.mk b/target/linux/ramips/image/mt7621.mk
index b55f696a86..ca1e3661b1 100644
--- a/target/linux/ramips/image/mt7621.mk
+++ b/target/linux/ramips/image/mt7621.mk
@@ -329,16 +329,15 @@ define Device/zbt-we1326
endef
TARGET_DEVICES += zbt-we1326
-define Device/zbt-we3526
+define Device/zbtlink_zbt-we3526
DTS := ZBT-WE3526
IMAGE_SIZE := $(ralink_default_fw_size_16M)
- SUPPORTED_DEVICES := zbtlink,zbt-we3526
DEVICE_TITLE := ZBT WE3526
DEVICE_PACKAGES := \
kmod-sdhci-mt7620 kmod-mt7603 kmod-mt76x2 \
kmod-usb3 kmod-usb-ledtrig-usbport wpad-mini
endef
-TARGET_DEVICES += zbt-we3526
+TARGET_DEVICES += zbtlink_zbt-we3526
define Device/zbt-wg2626
DTS := ZBT-WG2626