aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2007-10-12 11:21:59 +0000
committerFlorian Fainelli <florian@openwrt.org>2007-10-12 11:21:59 +0000
commit4bc640743a56ddad268e8d74807c6b6b9fc42956 (patch)
tree6c22ad665bb1ad9b3eeab60b61f39a0bc6a50a7e /target
parent61c5597d73c27f7c09a335b707bebcf81d259051 (diff)
downloadupstream-4bc640743a56ddad268e8d74807c6b6b9fc42956.tar.gz
upstream-4bc640743a56ddad268e8d74807c6b6b9fc42956.tar.bz2
upstream-4bc640743a56ddad268e8d74807c6b6b9fc42956.zip
Upgrade rdc to 2.6.23, fix the r6040 driver printk's
SVN-Revision: 9267
Diffstat (limited to 'target')
-rw-r--r--target/linux/rdc/Makefile2
-rw-r--r--target/linux/rdc/config-2.6.23 (renamed from target/linux/rdc/config-2.6.22)34
-rw-r--r--target/linux/rdc/files/arch/i386/mach-rdc/platform.c14
-rw-r--r--target/linux/rdc/files/drivers/net/r6040.c4
-rw-r--r--target/linux/rdc/patches/001-x86_generic_gpio.patch15
-rw-r--r--target/linux/rdc/patches/004-rdc3211_leds.patch27
-rw-r--r--target/linux/rdc/patches/004-rdc_fixes.patch (renamed from target/linux/rdc/patches/000-rdc_fixes.patch)4
7 files changed, 45 insertions, 55 deletions
diff --git a/target/linux/rdc/Makefile b/target/linux/rdc/Makefile
index edda229421..e9804ee892 100644
--- a/target/linux/rdc/Makefile
+++ b/target/linux/rdc/Makefile
@@ -11,7 +11,7 @@ BOARD:=rdc
BOARDNAME:=RDC321x x86
FEATURES:=squashfs jffs2 pci
-LINUX_VERSION:=2.6.22.4
+LINUX_VERSION:=2.6.23
include $(INCLUDE_DIR)/target.mk
diff --git a/target/linux/rdc/config-2.6.22 b/target/linux/rdc/config-2.6.23
index ff1220712e..8f39251a0c 100644
--- a/target/linux/rdc/config-2.6.22
+++ b/target/linux/rdc/config-2.6.23
@@ -13,7 +13,6 @@ CONFIG_ARCH_POPULATES_NODE_MAP=y
CONFIG_ATA=m
# CONFIG_ATA_NONSTANDARD is not set
CONFIG_ATA_PIIX=m
-# CONFIG_ATM_DRIVERS is not set
CONFIG_BASE_SMALL=0
CONFIG_BINFMT_AOUT=m
CONFIG_BINFMT_MISC=m
@@ -23,14 +22,14 @@ CONFIG_BITREVERSE=y
CONFIG_BLK_DEV_IDE=m
CONFIG_BLK_DEV_IDEDISK=m
# CONFIG_BLK_DEV_IDEDMA is not set
+CONFIG_BOUNCE=y
# CONFIG_BROADCOM_PHY is not set
CONFIG_CLOCKSOURCE_WATCHDOG=y
# CONFIG_COMPAT_VDSO is not set
# CONFIG_CPU5_WDT is not set
# CONFIG_CPU_FREQ is not set
CONFIG_CRYPTO_AES_586=m
-CONFIG_CRYPTO_DEV_GEODE=m
-# CONFIG_CRYPTO_DEV_PADLOCK is not set
+# CONFIG_CRYPTO_HW is not set
CONFIG_CRYPTO_TWOFISH_586=m
# CONFIG_CS5535_GPIO is not set
# CONFIG_DCDBAS is not set
@@ -41,6 +40,7 @@ CONFIG_DEFAULT_IOSCHED="cfq"
# CONFIG_DELL_RBU is not set
CONFIG_DEVPORT=y
CONFIG_DMI=y
+CONFIG_DMIID=y
CONFIG_DOUBLEFAULT=y
# CONFIG_E100 is not set
CONFIG_EARLY_PRINTK=y
@@ -48,9 +48,12 @@ CONFIG_EARLY_PRINTK=y
# CONFIG_EDD is not set
# CONFIG_EUROTECH_WDT is not set
# CONFIG_FIXED_PHY is not set
+CONFIG_FIX_EARLYCON_MEM=y
CONFIG_FS_POSIX_ACL=y
CONFIG_GENERIC_BUG=y
CONFIG_GENERIC_CLOCKEVENTS=y
+CONFIG_GENERIC_CMOS_UPDATE=y
+CONFIG_GENERIC_GPIO=y
CONFIG_GENERIC_IOMAP=y
CONFIG_GENERIC_ISA_DMA=y
# CONFIG_GEN_RTC is not set
@@ -58,7 +61,9 @@ CONFIG_GENERIC_ISA_DMA=y
CONFIG_HAS_DMA=y
CONFIG_HAS_IOMEM=y
CONFIG_HAS_IOPORT=y
+CONFIG_HIBERNATION_UP_POSSIBLE=y
CONFIG_HID=m
+CONFIG_HID_SUPPORT=y
# CONFIG_HIGHMEM4G is not set
# CONFIG_HIGHMEM64G is not set
# CONFIG_HIGH_RES_TIMERS is not set
@@ -92,6 +97,7 @@ CONFIG_INITRAMFS_SOURCE=""
CONFIG_INPUT=m
CONFIG_INPUT_MISC=y
CONFIG_INPUT_YEALINK=m
+CONFIG_INSTRUMENTATION=y
CONFIG_IOSCHED_CFQ=y
# CONFIG_IOSCHED_DEADLINE is not set
# CONFIG_ISA is not set
@@ -102,7 +108,7 @@ CONFIG_KEXEC=y
CONFIG_KTIME_SCALAR=y
# CONFIG_KVM is not set
CONFIG_LBD=y
-CONFIG_LEDS_RDC3211=y
+CONFIG_LEDS_GPIO=y
CONFIG_LSF=y
# CONFIG_M386 is not set
CONFIG_M486=y
@@ -191,8 +197,11 @@ CONFIG_MTD_RDC3210_SIZE=0x400000
# CONFIG_NATSEMI is not set
# CONFIG_NE2K_PCI is not set
# CONFIG_NETDEV_1000 is not set
+CONFIG_NET_ACT_POLICE=y
CONFIG_NET_SCH_FIFO=y
# CONFIG_NET_VENDOR_3COM is not set
+CONFIG_NF_CT_PROTO_GRE=m
+CONFIG_NF_NAT_PROTO_GRE=m
CONFIG_NLS_ISO8859_2=m
CONFIG_NOHIGHMEM=y
# CONFIG_NO_HZ is not set
@@ -218,28 +227,29 @@ CONFIG_PCMCIA=m
CONFIG_PHYLIB=y
CONFIG_PHYSICAL_ALIGN=0x100000
CONFIG_PHYSICAL_START=0x100000
-# CONFIG_PNPACPI is not set
# CONFIG_QSEMI_PHY is not set
CONFIG_QUICKLIST=y
CONFIG_R6040=m
# CONFIG_R6040_NAPI is not set
# CONFIG_RELOCATABLE is not set
# CONFIG_RTC is not set
+# CONFIG_RTL8187 is not set
CONFIG_RWSEM_XCHGADD_ALGORITHM=y
# CONFIG_SBC8360_WDT is not set
# CONFIG_SBC_EPX_C3_WATCHDOG is not set
# CONFIG_SC1200_WDT is not set
# CONFIG_SC520_WDT is not set
+# CONFIG_SCSI_LOWLEVEL_PCMCIA is not set
# CONFIG_SCSI_MULTI_LUN is not set
CONFIG_SCSI_WAIT_SCAN=m
# CONFIG_SCx200 is not set
# CONFIG_SCx200_ACB is not set
-# CONFIG_SECCOMP is not set
CONFIG_SEMAPHORE_SLEEPERS=y
# CONFIG_SERIAL_8250_EXTENDED is not set
# CONFIG_SMP is not set
# CONFIG_SMSC37B787_WDT is not set
# CONFIG_SMSC_PHY is not set
+# CONFIG_SND_CS5530 is not set
CONFIG_SOFT_WATCHDOG=m
# CONFIG_SONYPI is not set
# CONFIG_SPARSEMEM_STATIC is not set
@@ -247,26 +257,27 @@ CONFIG_SYSVIPC_SYSCTL=y
# CONFIG_TELCLOCK is not set
# CONFIG_TICK_ONESHOT is not set
# CONFIG_TOSHIBA is not set
+# CONFIG_TUNER_TEA5761 is not set
CONFIG_UID16=y
# CONFIG_UNUSED_SYMBOLS is not set
# CONFIG_USBPCWATCHDOG is not set
-# CONFIG_USB_EHCI_BIG_ENDIAN_MMIO is not set
CONFIG_USB_EHCI_HCD=m
-# CONFIG_USB_EHCI_ROOT_HUB_TT is not set
-# CONFIG_USB_EHCI_SPLIT_ISO is not set
-# CONFIG_USB_EHCI_TT_NEWSCHED is not set
# CONFIG_USB_OHCI_BIG_ENDIAN_DESC is not set
# CONFIG_USB_OHCI_BIG_ENDIAN_MMIO is not set
CONFIG_USB_OHCI_HCD=m
CONFIG_USB_PWC=m
# CONFIG_USB_PWC_DEBUG is not set
+# CONFIG_USB_R8A66597_HCD is not set
+# CONFIG_USB_SERIAL_OTI6858 is not set
# CONFIG_USB_UHCI_HCD is not set
+# CONFIG_USER_NS is not set
CONFIG_V4L_USB_DRIVERS=y
# CONFIG_VGASTATE is not set
# CONFIG_VIA_RHINE is not set
CONFIG_VIDEO_CAPTURE_DRIVERS=y
CONFIG_VIDEO_CPIA2=m
CONFIG_VIDEO_V4L1=y
+CONFIG_VIRTUALIZATION=y
# CONFIG_VM86 is not set
# CONFIG_VMSPLIT_1G is not set
# CONFIG_VMSPLIT_2G is not set
@@ -295,9 +306,10 @@ CONFIG_X86_F00F_BUG=y
CONFIG_X86_INVLPG=y
CONFIG_X86_L1_CACHE_SHIFT=4
# CONFIG_X86_MCE is not set
-CONFIG_X86_MINIMUM_CPU_MODEL=4
+CONFIG_X86_MINIMUM_CPU_FAMILY=4
CONFIG_X86_MSR=y
# CONFIG_X86_NUMAQ is not set
+# CONFIG_X86_PAE is not set
# CONFIG_X86_PC is not set
CONFIG_X86_POPAD_OK=y
CONFIG_X86_PPRO_FENCE=y
diff --git a/target/linux/rdc/files/arch/i386/mach-rdc/platform.c b/target/linux/rdc/files/arch/i386/mach-rdc/platform.c
index 877287b856..0a607223c5 100644
--- a/target/linux/rdc/files/arch/i386/mach-rdc/platform.c
+++ b/target/linux/rdc/files/arch/i386/mach-rdc/platform.c
@@ -29,14 +29,10 @@
#include <linux/device.h>
#include <linux/platform_device.h>
#include <linux/version.h>
-#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,23)
#include <linux/leds.h>
-#endif
#include <asm/gpio.h>
-#define PFX "rdc321x: "
-
/* Flash */
static struct resource rdc_flash_resource[] = {
[0] = {
@@ -54,9 +50,8 @@ static struct platform_device rdc_flash_device = {
};
/* LEDS */
-#if LINUX_VERSION_CODE >= KERNEL_VERSION(2,6,23)
static struct gpio_led default_leds[] = {
- { .name = "rdc:dmz", .gpio = 1, },
+ { .name = "rdc321x:dmz", .gpio = 1, },
};
static struct gpio_led_platform_data rdc321x_led_data = {
@@ -71,13 +66,6 @@ static struct platform_device rdc321x_leds = {
.platform_data = &rdc321x_led_data,
}
};
-#else
-static struct platform_device rdc321x_leds = {
- .name = "rdc321x-leds",
- .id = -1,
- .num_resources = 0,
-};
-#endif
/* Watchdog */
static struct platform_device rdc321x_wdt = {
diff --git a/target/linux/rdc/files/drivers/net/r6040.c b/target/linux/rdc/files/drivers/net/r6040.c
index 38d80c7134..e2044c9ad9 100644
--- a/target/linux/rdc/files/drivers/net/r6040.c
+++ b/target/linux/rdc/files/drivers/net/r6040.c
@@ -229,7 +229,7 @@ static int __devinit r6040_init_one (struct pci_dev *pdev,
RDC_DBUG("r6040_init_one()", 0);
if (printed_version++)
- printk(KERN_INFO version);
+ printk(KERN_INFO "%s\n", version);
err = pci_enable_device(pdev);
if (err)
@@ -1021,7 +1021,7 @@ static int __init r6040_init (void)
{
RDC_DBUG("r6040_init()", 0);
- printk(KERN_INFO version);
+ printk(KERN_INFO "%s\n", version);
printed_version = 1;
if (parent != NULL) {
diff --git a/target/linux/rdc/patches/001-x86_generic_gpio.patch b/target/linux/rdc/patches/001-x86_generic_gpio.patch
new file mode 100644
index 0000000000..db3d866a1b
--- /dev/null
+++ b/target/linux/rdc/patches/001-x86_generic_gpio.patch
@@ -0,0 +1,15 @@
+diff --git a/arch/i386/Kconfig b/arch/i386/Kconfig
+index 97b64d7..f8c1d32 100644
+--- a/arch/i386/Kconfig
++++ b/arch/i386/Kconfig
+@@ -79,6 +79,10 @@ config GENERIC_BUG
+ default y
+ depends on BUG
+
++config GENERIC_GPIO
++ bool
++ default n
++
+ config GENERIC_HWEIGHT
+ bool
+ default y
diff --git a/target/linux/rdc/patches/004-rdc3211_leds.patch b/target/linux/rdc/patches/004-rdc3211_leds.patch
deleted file mode 100644
index 2e704aa600..0000000000
--- a/target/linux/rdc/patches/004-rdc3211_leds.patch
+++ /dev/null
@@ -1,27 +0,0 @@
-diff -urN linux-2.6.19.2/drivers/leds/Kconfig linux-2.6.19.2.new/drivers/leds/Kconfig
---- linux-2.6.19.2/drivers/leds/Kconfig 2007-01-10 20:10:37.000000000 +0100
-+++ linux-2.6.19.2.new/drivers/leds/Kconfig 2007-04-16 22:09:40.000000000 +0200
-@@ -76,6 +76,12 @@
- This option enables support for the Soekris net4801 and net4826 error
- LED.
-
-+config LEDS_RDC3211
-+ tristate "LED Support for RDC3211 boards"
-+ depends on LEDS_CLASS && X86_RDC
-+ help
-+ This option enables support for the RDC3211 various LEDs.
-+
- comment "LED Triggers"
-
- config LEDS_TRIGGERS
-diff -urN linux-2.6.21.1/drivers/leds/Makefile linux-2.6.21.1.new/drivers/leds/Makefile
---- linux-2.6.21.1/drivers/leds/Makefile 2007-04-27 23:49:26.000000000 +0200
-+++ linux-2.6.21.1.new/drivers/leds/Makefile 2007-05-25 12:19:13.000000000 +0200
-@@ -16,6 +16,7 @@
- obj-$(CONFIG_LEDS_WRAP) += leds-wrap.o
- obj-$(CONFIG_LEDS_H1940) += leds-h1940.o
- obj-$(CONFIG_LEDS_COBALT) += leds-cobalt.o
-+obj-$(CONFIG_LEDS_RDC3211) += leds-rdc3211.o
-
- # LED Triggers
- obj-$(CONFIG_LEDS_TRIGGER_TIMER) += ledtrig-timer.o
diff --git a/target/linux/rdc/patches/000-rdc_fixes.patch b/target/linux/rdc/patches/004-rdc_fixes.patch
index 306fac79a6..524155adf6 100644
--- a/target/linux/rdc/patches/000-rdc_fixes.patch
+++ b/target/linux/rdc/patches/004-rdc_fixes.patch
@@ -1,12 +1,14 @@
diff -urN linux-2.6.19/arch/i386/Kconfig linux-2.6.19.new/arch/i386/Kconfig
--- linux-2.6.19/arch/i386/Kconfig 2006-11-29 22:57:37.000000000 +0100
+++ linux-2.6.19.new/arch/i386/Kconfig 2006-12-17 17:13:33.000000000 +0100
-@@ -180,6 +180,14 @@
+@@ -180,6 +180,16 @@
Only choose this option if you have such a system, otherwise you
should say N here.
+config X86_RDC
+ bool "Support for RDC 3211 boards"
++ select GENERIC_GPIO
++ select LEDS_GPIO
+ help
+ Support for RDC 3211 systems. Say 'Y' here if the kernel is
+ supposed to run on an IA-32 RDC R3211 system.