aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2019-11-17 20:58:27 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2019-11-26 17:01:01 +0100
commit3a5e28bd266b8e5de59ed9d9c198184b7c3e027a (patch)
treebcb50a4a3914f6a06c435f67b1959beeea5ec25c /target
parent1cb763c559b81a7c38eadffcf1f6c6d3cde72153 (diff)
downloadupstream-3a5e28bd266b8e5de59ed9d9c198184b7c3e027a.tar.gz
upstream-3a5e28bd266b8e5de59ed9d9c198184b7c3e027a.tar.bz2
upstream-3a5e28bd266b8e5de59ed9d9c198184b7c3e027a.zip
ar71xx: ubnt-(xm,xw): add rssileds package
In order to make RSSI indicator on the device work out of box, include "rssileds" package in per-device rootfs image by default for Ubiquiti XM and XW devices, namely: - Bullet M (XM/XW) - Rocket M (XM/XW) - Nanostation M (XM/XW) - Nanostation Loco-M (XW) This moves the package addition to the individual devices in order to prevent accidental inclusions of the package when not looking at the parent node carefully enough. Signed-off-by: Lech Perczak <lech.perczak@gmail.com> [add bullet-m-xw, remove rocket-m-ti, extend commit message] Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de> (cherry picked from commit 08d9c95417399ac8615df210f4381cca68a4b25c)
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/generic-ubnt.mk10
1 files changed, 8 insertions, 2 deletions
diff --git a/target/linux/ar71xx/image/generic-ubnt.mk b/target/linux/ar71xx/image/generic-ubnt.mk
index c7d17f20aa..c155cbd817 100644
--- a/target/linux/ar71xx/image/generic-ubnt.mk
+++ b/target/linux/ar71xx/image/generic-ubnt.mk
@@ -56,7 +56,7 @@ endef
define Device/ubnt-xm
$(Device/ubnt)
- DEVICE_PACKAGES += kmod-usb-ohci rssileds
+ DEVICE_PACKAGES += kmod-usb-ohci
UBNT_TYPE := XM
UBNT_CHIP := ar7240
KERNEL := kernel-bin | patch-cmdline | relocate-kernel | lzma | uImage lzma
@@ -64,7 +64,6 @@ endef
define Device/ubnt-xw
$(Device/ubnt)
- DEVICE_PACKAGES += rssileds
UBNT_TYPE := XW
UBNT_CHIP := ar934x
UBNT_VERSION := 6.0.4
@@ -94,6 +93,7 @@ TARGET_DEVICES += ubnt-airrouter
define Device/ubnt-bullet-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Bullet-M
+ DEVICE_PACKAGES += rssileds
BOARDNAME := UBNT-BM
endef
TARGET_DEVICES += ubnt-bullet-m
@@ -101,6 +101,7 @@ TARGET_DEVICES += ubnt-bullet-m
define Device/ubnt-rocket-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Rocket-M
+ DEVICE_PACKAGES += rssileds
BOARDNAME := UBNT-RM
endef
TARGET_DEVICES += ubnt-rocket-m
@@ -108,6 +109,7 @@ TARGET_DEVICES += ubnt-rocket-m
define Device/ubnt-nano-m
$(Device/ubnt-xm)
DEVICE_TITLE := Ubiquiti Nano-M
+ DEVICE_PACKAGES += rssileds
BOARDNAME := UBNT-NM
endef
TARGET_DEVICES += ubnt-nano-m
@@ -176,6 +178,7 @@ TARGET_DEVICES += ubnt-unifi-outdoor
define Device/ubnt-nano-m-xw
$(Device/ubnt-xw)
DEVICE_TITLE := Ubiquiti Nano M XW
+ DEVICE_PACKAGES += rssileds
BOARDNAME := UBNT-NM-XW
endef
TARGET_DEVICES += ubnt-nano-m-xw
@@ -190,6 +193,7 @@ TARGET_DEVICES += ubnt-lbe-m5
define Device/ubnt-loco-m-xw
$(Device/ubnt-xw)
DEVICE_TITLE := Ubiquiti Loco XW
+ DEVICE_PACKAGES += rssileds
BOARDNAME := UBNT-LOCO-XW
endef
TARGET_DEVICES += ubnt-loco-m-xw
@@ -197,6 +201,7 @@ TARGET_DEVICES += ubnt-loco-m-xw
define Device/ubnt-bullet-m-xw
$(Device/ubnt-xw)
DEVICE_TITLE := Ubiquiti Bullet-M XW
+ DEVICE_PACKAGES += rssileds
BOARDNAME := UBNT-BM-XW
endef
TARGET_DEVICES += ubnt-bullet-m-xw
@@ -204,6 +209,7 @@ TARGET_DEVICES += ubnt-bullet-m-xw
define Device/ubnt-rocket-m-xw
$(Device/ubnt-xw)
DEVICE_TITLE := Ubiquiti Rocket M XW
+ DEVICE_PACKAGES += rssileds
BOARDNAME := UBNT-RM-XW
endef
TARGET_DEVICES += ubnt-rocket-m-xw