aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorLech Perczak <lech.perczak@gmail.com>2019-11-17 20:57:10 +0100
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>2020-01-21 14:10:13 +0100
commit1b4b4e3faeac04125540cb0bd24543d94a383784 (patch)
tree63b53b0d78f3314e308f49a330f914af3f2b2ce4 /target
parentc1245ebc96c26f3281da9d01932d727dd48f0ad2 (diff)
downloadupstream-1b4b4e3faeac04125540cb0bd24543d94a383784.tar.gz
upstream-1b4b4e3faeac04125540cb0bd24543d94a383784.tar.bz2
upstream-1b4b4e3faeac04125540cb0bd24543d94a383784.zip
ar71xx: ubnt-rocket-m-ti: fix RSSI LED definitions
When mapping for RSSI LEDs was defined for interface wlan0 on Ubiquiti Rocket M Titanium, it missed connection to actual interface. Therefore create the mapping to interface, so RSSI LEDs work without additional configuration, after starting rssileds service. While at that, split RSSI into ~equal intervals for 6 LEDs, and remove coefficients needed for PWM LEDs, as this board does not support PWM LEDs. Finally, for complete support, enable 'rssileds' package in per-device rootfs, so the indicator works out of box. Signed-off-by: Lech Perczak <lech.perczak@gmail.com> (cherry picked from commit 83708f233daceacebd1c49da44711cc87b49162a)
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds13
-rw-r--r--target/linux/ar71xx/image/generic-ubnt.mk1
2 files changed, 8 insertions, 6 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index fa8fb7a91e..bd589c1cff 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -724,12 +724,13 @@ rme-eg200)
ucidef_set_led_default "etactica" "etactica" "eg200:red:etactica" "ignore"
;;
rocket-m-ti)
- ucidef_set_led_rssi "rssiverylow" "RSSIVERYLOW" "ubnt:green:link1" "wlan0" "1" "100" "0" "13"
- ucidef_set_led_rssi "rssilow" "RSSILOW" "ubnt:green:link2" "wlan0" "26" "100" "-25" "13"
- ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "ubnt:green:link3" "wlan0" "51" "100" "-50" "13"
- ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "ubnt:green:link4" "wlan0" "76" "100" "-75" "13"
- ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "ubnt:green:link5" "wlan0" "76" "100" "-75" "13"
- ucidef_set_led_rssi "rssiveryhigh" "RSSIVERYHIGH" "ubnt:green:link4" "wlan0" "76" "100" "-75" "13"
+ ucidef_set_rssimon "wlan0" "200000" "1"
+ ucidef_set_led_rssi "rssiverylow" "RSSIVERYLOW" "ubnt:green:link1" "wlan0" "1" "100"
+ ucidef_set_led_rssi "rssilow" "RSSILOW" "ubnt:green:link2" "wlan0" "18" "100"
+ ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "ubnt:green:link3" "wlan0" "34" "100"
+ ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "ubnt:green:link4" "wlan0" "51" "100"
+ ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "ubnt:green:link5" "wlan0" "67" "100"
+ ucidef_set_led_rssi "rssiveryhigh" "RSSIVERYHIGH" "ubnt:green:link6" "wlan0" "84" "100"
;;
rut900)
ucidef_set_led_netdev "wan" "WAN" "$board:green:wan" "eth1"
diff --git a/target/linux/ar71xx/image/generic-ubnt.mk b/target/linux/ar71xx/image/generic-ubnt.mk
index c155cbd817..8d62980add 100644
--- a/target/linux/ar71xx/image/generic-ubnt.mk
+++ b/target/linux/ar71xx/image/generic-ubnt.mk
@@ -217,6 +217,7 @@ TARGET_DEVICES += ubnt-rocket-m-xw
define Device/ubnt-rocket-m-ti
$(Device/ubnt-xw)
DEVICE_TITLE := Ubiquiti Rocket M TI
+ DEVICE_PACKAGES += rssileds
BOARDNAME := UBNT-RM-TI
UBNT_TYPE := TI
endef