aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorHamish Guthrie <hcg@openwrt.org>2010-07-16 09:20:06 +0000
committerHamish Guthrie <hcg@openwrt.org>2010-07-16 09:20:06 +0000
commitd163ae3f618f65ee9e340f8f4e298975e062e222 (patch)
tree2f068a669e0d6246534b74ad8dbc13489ef5cc81 /target
parenta158af99a0bcf40ccfc79a79b712a34108061488 (diff)
downloadupstream-d163ae3f618f65ee9e340f8f4e298975e062e222.tar.gz
upstream-d163ae3f618f65ee9e340f8f4e298975e062e222.tar.bz2
upstream-d163ae3f618f65ee9e340f8f4e298975e062e222.zip
Add a profile including Jamvm for Gumstix
SVN-Revision: 22230
Diffstat (limited to 'target')
-rw-r--r--target/linux/omap35xx/gumstix/profiles/gsjava.mk25
1 files changed, 25 insertions, 0 deletions
diff --git a/target/linux/omap35xx/gumstix/profiles/gsjava.mk b/target/linux/omap35xx/gumstix/profiles/gsjava.mk
new file mode 100644
index 0000000000..3e3f073464
--- /dev/null
+++ b/target/linux/omap35xx/gumstix/profiles/gsjava.mk
@@ -0,0 +1,25 @@
+#
+# Copyright (C) 2006 - 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Gsjava
+ NAME:=gsjava
+ PACKAGES:=-iptables -ppp -ppp-mod-pppoe -kmod-ipt-nathelper \
+ -firewall -mtd -hotplug2 -udevtrigger \
+ ext2 usb udev kmod-bluetooth ntpclient wpa-supplicant \
+ wireless-tools wpa-cli \
+ bluez-utils bluez-hcidump hegw usbutils python pyserial \
+ python-mini python-openssl python-sqlite3 libstdcpp \
+ kmod-usb-serial kmod-usb-serial-cp210x kmod-usb-serial-ftdi \
+ kmod-usb-serial-pl2303 kmod-usb-uhci kmod-cfg80211 \
+ kmod-lib80211 kmod-libertas-sd kmod-mac80211 libnl-tiny \
+ crda iw kmod-usb-hid luci luci-app-ntpc jamvm
+endef
+
+define Profile/Gsjava/Description
+ Gumstix including Jamvm Java VM
+endef
+$(eval $(call Profile,Gsjava))