aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMathias Kresin <dev@kresin.me>2017-03-25 19:24:26 +0100
committerMathias Kresin <dev@kresin.me>2017-04-08 14:30:00 +0200
commitaf9afa2811f0cfb373071b27a03affd77f9e00eb (patch)
tree02bbe02cd484aae1b7b08c3d2a78c9defb8bbcb9 /target
parent8b3fa168b49a4aad5797ef5083c17c348d99731b (diff)
downloadupstream-af9afa2811f0cfb373071b27a03affd77f9e00eb.tar.gz
upstream-af9afa2811f0cfb373071b27a03affd77f9e00eb.tar.bz2
upstream-af9afa2811f0cfb373071b27a03affd77f9e00eb.zip
lantiq: drop tffs patches
With the fritz-tools a userspace parser for the Tiny Flash File System is available and makes the tffs2 kernel patches obsolete. Signed-off-by: Mathias Kresin <dev@kresin.me>
Diffstat (limited to 'target')
-rw-r--r--target/linux/lantiq/patches-4.4/0007-MIPS-lantiq-add-basic-tffs-driver.patch111
-rw-r--r--target/linux/lantiq/patches-4.4/0008-MIPS-lantiq-backport-old-timer-code.patch2
-rw-r--r--target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch2
-rw-r--r--target/linux/lantiq/patches-4.9/0007-MIPS-lantiq-add-basic-tffs-driver.patch111
4 files changed, 2 insertions, 224 deletions
diff --git a/target/linux/lantiq/patches-4.4/0007-MIPS-lantiq-add-basic-tffs-driver.patch b/target/linux/lantiq/patches-4.4/0007-MIPS-lantiq-add-basic-tffs-driver.patch
deleted file mode 100644
index 70813738cc..0000000000
--- a/target/linux/lantiq/patches-4.4/0007-MIPS-lantiq-add-basic-tffs-driver.patch
+++ /dev/null
@@ -1,111 +0,0 @@
-From d27ec8bb97db0f60d81ab255d51ac4e967362067 Mon Sep 17 00:00:00 2001
-From: John Crispin <blogic@openwrt.org>
-Date: Thu, 7 Aug 2014 18:34:19 +0200
-Subject: [PATCH 07/36] MIPS: lantiq: add basic tffs driver
-
-Signed-off-by: John Crispin <blogic@openwrt.org>
----
- arch/mips/lantiq/xway/Makefile | 2 +-
- arch/mips/lantiq/xway/tffs.c | 87 ++++++++++++++++++++++++++++++++++++++++
- 2 files changed, 88 insertions(+), 1 deletion(-)
- create mode 100644 arch/mips/lantiq/xway/tffs.c
-
---- a/arch/mips/lantiq/xway/Makefile
-+++ b/arch/mips/lantiq/xway/Makefile
-@@ -1,5 +1,5 @@
- obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
-
--obj-y += vmmc.o
-+obj-y += vmmc.o tffs.o
-
- obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
---- /dev/null
-+++ b/arch/mips/lantiq/xway/tffs.c
-@@ -0,0 +1,87 @@
-+#include <linux/module.h>
-+#include <linux/mtd/mtd.h>
-+#include <linux/errno.h>
-+#include <linux/slab.h>
-+
-+struct tffs_entry {
-+ uint16_t id;
-+ uint16_t len;
-+};
-+
-+static struct tffs_id {
-+ uint32_t id;
-+ char *name;
-+ unsigned char *val;
-+ uint32_t offset;
-+ uint32_t len;
-+} ids[] = {
-+ { 0x01A9, "annex" },
-+ { 0x0188, "maca" },
-+ { 0x0189, "macb" },
-+ { 0x018a, "macwlan" },
-+ { 0x0195, "macwlan2" },
-+ { 0x018b, "macdsl" },
-+ { 0x01C2, "webgui_pass" },
-+ { 0x01AB, "wlan_key" },
-+};
-+
-+static struct mtd_info *tffs1, *tffs2;
-+
-+static struct tffs_id* tffs_find_id(int id)
-+{
-+ int i;
-+
-+ for (i = 0; i < ARRAY_SIZE(ids); i++)
-+ if (id == ids[i].id)
-+ return &ids[i];
-+
-+ return NULL;
-+}
-+
-+static void tffs_index(void)
-+{
-+ struct tffs_entry *E = NULL;
-+ struct tffs_entry entry;
-+ int ret, retlen;
-+
-+ while ((unsigned int) E + sizeof(struct tffs_entry) < tffs2->size) {
-+ struct tffs_id *id;
-+ int len;
-+
-+ ret = mtd_read(tffs2, (unsigned int) E, sizeof(struct tffs_entry), &retlen, (unsigned char *)&entry);
-+ if (ret)
-+ return;
-+
-+ if (entry.id == 0xffff)
-+ return;
-+
-+ id = tffs_find_id(entry.id);
-+ if (id) {
-+ id->offset = (uint32_t) E;
-+ id->len = entry.len;
-+ id->val = kzalloc(entry.len + 1, GFP_KERNEL);
-+ mtd_read(tffs2, ((unsigned int) E) + sizeof(struct tffs_entry), entry.len, &retlen, id->val);
-+
-+ }
-+ //printk(KERN_INFO "found entry at 0x%08X-> [<0x%x> %u bytes]\n", (uint32_t) E, entry.id, entry.len);
-+ if (id && id->name)
-+ printk(KERN_INFO "found entry name -> %s=%s\n", id->name, id->val);
-+
-+ len = (entry.len + 3) & ~0x03;
-+ E = (struct tffs_entry *)(((unsigned int)E) + sizeof(struct tffs_entry) + len);
-+ }
-+}
-+
-+static int __init tffs_init(void)
-+{
-+ tffs1 = get_mtd_device_nm("tffs (1)");
-+ tffs2 = get_mtd_device_nm("tffs (2)");
-+ if (IS_ERR(tffs1) || IS_ERR(tffs2))
-+ return -1;
-+
-+ tffs_index();
-+
-+ return 0;
-+}
-+late_initcall(tffs_init);
-+
diff --git a/target/linux/lantiq/patches-4.4/0008-MIPS-lantiq-backport-old-timer-code.patch b/target/linux/lantiq/patches-4.4/0008-MIPS-lantiq-backport-old-timer-code.patch
index 55255037fa..f36a79a83b 100644
--- a/target/linux/lantiq/patches-4.4/0008-MIPS-lantiq-backport-old-timer-code.patch
+++ b/target/linux/lantiq/patches-4.4/0008-MIPS-lantiq-backport-old-timer-code.patch
@@ -176,7 +176,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
-obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
+obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o
- obj-y += vmmc.o tffs.o
+ obj-y += vmmc.o
--- /dev/null
+++ b/arch/mips/lantiq/xway/timer.c
diff --git a/target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch b/target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
index 73b3c3a3c0..15ecdb3543 100644
--- a/target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
+++ b/target/linux/lantiq/patches-4.4/0035-owrt-lantiq-wifi-and-ethernet-eeprom-handling.patch
@@ -29,7 +29,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
+++ b/arch/mips/lantiq/xway/Makefile
@@ -2,4 +2,7 @@ obj-y := prom.o sysctrl.o clk.o reset.o
- obj-y += vmmc.o tffs.o
+ obj-y += vmmc.o
+obj-y += eth_mac.o
+obj-$(CONFIG_PCI) += ath5k_eep.o
diff --git a/target/linux/lantiq/patches-4.9/0007-MIPS-lantiq-add-basic-tffs-driver.patch b/target/linux/lantiq/patches-4.9/0007-MIPS-lantiq-add-basic-tffs-driver.patch
deleted file mode 100644
index 70813738cc..0000000000
--- a/target/linux/lantiq/patches-4.9/0007-MIPS-lantiq-add-basic-tffs-driver.patch
+++ /dev/null
@@ -1,111 +0,0 @@
-From d27ec8bb97db0f60d81ab255d51ac4e967362067 Mon Sep 17 00:00:00 2001
-From: John Crispin <blogic@openwrt.org>
-Date: Thu, 7 Aug 2014 18:34:19 +0200
-Subject: [PATCH 07/36] MIPS: lantiq: add basic tffs driver
-
-Signed-off-by: John Crispin <blogic@openwrt.org>
----
- arch/mips/lantiq/xway/Makefile | 2 +-
- arch/mips/lantiq/xway/tffs.c | 87 ++++++++++++++++++++++++++++++++++++++++
- 2 files changed, 88 insertions(+), 1 deletion(-)
- create mode 100644 arch/mips/lantiq/xway/tffs.c
-
---- a/arch/mips/lantiq/xway/Makefile
-+++ b/arch/mips/lantiq/xway/Makefile
-@@ -1,5 +1,5 @@
- obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
-
--obj-y += vmmc.o
-+obj-y += vmmc.o tffs.o
-
- obj-$(CONFIG_XRX200_PHY_FW) += xrx200_phy_fw.o
---- /dev/null
-+++ b/arch/mips/lantiq/xway/tffs.c
-@@ -0,0 +1,87 @@
-+#include <linux/module.h>
-+#include <linux/mtd/mtd.h>
-+#include <linux/errno.h>
-+#include <linux/slab.h>
-+
-+struct tffs_entry {
-+ uint16_t id;
-+ uint16_t len;
-+};
-+
-+static struct tffs_id {
-+ uint32_t id;
-+ char *name;
-+ unsigned char *val;
-+ uint32_t offset;
-+ uint32_t len;
-+} ids[] = {
-+ { 0x01A9, "annex" },
-+ { 0x0188, "maca" },
-+ { 0x0189, "macb" },
-+ { 0x018a, "macwlan" },
-+ { 0x0195, "macwlan2" },
-+ { 0x018b, "macdsl" },
-+ { 0x01C2, "webgui_pass" },
-+ { 0x01AB, "wlan_key" },
-+};
-+
-+static struct mtd_info *tffs1, *tffs2;
-+
-+static struct tffs_id* tffs_find_id(int id)
-+{
-+ int i;
-+
-+ for (i = 0; i < ARRAY_SIZE(ids); i++)
-+ if (id == ids[i].id)
-+ return &ids[i];
-+
-+ return NULL;
-+}
-+
-+static void tffs_index(void)
-+{
-+ struct tffs_entry *E = NULL;
-+ struct tffs_entry entry;
-+ int ret, retlen;
-+
-+ while ((unsigned int) E + sizeof(struct tffs_entry) < tffs2->size) {
-+ struct tffs_id *id;
-+ int len;
-+
-+ ret = mtd_read(tffs2, (unsigned int) E, sizeof(struct tffs_entry), &retlen, (unsigned char *)&entry);
-+ if (ret)
-+ return;
-+
-+ if (entry.id == 0xffff)
-+ return;
-+
-+ id = tffs_find_id(entry.id);
-+ if (id) {
-+ id->offset = (uint32_t) E;
-+ id->len = entry.len;
-+ id->val = kzalloc(entry.len + 1, GFP_KERNEL);
-+ mtd_read(tffs2, ((unsigned int) E) + sizeof(struct tffs_entry), entry.len, &retlen, id->val);
-+
-+ }
-+ //printk(KERN_INFO "found entry at 0x%08X-> [<0x%x> %u bytes]\n", (uint32_t) E, entry.id, entry.len);
-+ if (id && id->name)
-+ printk(KERN_INFO "found entry name -> %s=%s\n", id->name, id->val);
-+
-+ len = (entry.len + 3) & ~0x03;
-+ E = (struct tffs_entry *)(((unsigned int)E) + sizeof(struct tffs_entry) + len);
-+ }
-+}
-+
-+static int __init tffs_init(void)
-+{
-+ tffs1 = get_mtd_device_nm("tffs (1)");
-+ tffs2 = get_mtd_device_nm("tffs (2)");
-+ if (IS_ERR(tffs1) || IS_ERR(tffs2))
-+ return -1;
-+
-+ tffs_index();
-+
-+ return 0;
-+}
-+late_initcall(tffs_init);
-+