aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorMatthias Fritzsche <txt.file@txtfile.eu>2017-05-17 05:44:49 +0200
committerJohn Crispin <john@phrozen.org>2017-05-25 09:22:37 +0200
commita4e63e2679bff07dbc8707db8742596e86462ec0 (patch)
treec049ef2cb4cedb16830f74985002f3312ed77e52 /target
parent423a7a6b752d4780f7f61722443ed5f4f50e3bda (diff)
downloadupstream-a4e63e2679bff07dbc8707db8742596e86462ec0.tar.gz
upstream-a4e63e2679bff07dbc8707db8742596e86462ec0.tar.bz2
upstream-a4e63e2679bff07dbc8707db8742596e86462ec0.zip
ar71xx: change image version for ubiquiti devices
changes the image version from hardcoded OpenWrt to $VERSION_DIST. AirOS shows a notification with the image version during a firmware upgrade. fixes #582 Signed-off-by: Matthias Fritzsche <txt.file@txtfile.eu>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/ubnt.mk6
1 files changed, 3 insertions, 3 deletions
diff --git a/target/linux/ar71xx/image/ubnt.mk b/target/linux/ar71xx/image/ubnt.mk
index 84eaaaa965..62c8d45762 100644
--- a/target/linux/ar71xx/image/ubnt.mk
+++ b/target/linux/ar71xx/image/ubnt.mk
@@ -6,7 +6,7 @@
# routerboard creates partitions out of the ubnt header
define Build/mkubntimage
-$(STAGING_DIR_HOST)/bin/mkfwimage \
- -B $(UBNT_BOARD) -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-OpenWrt-$(REVISION) \
+ -B $(UBNT_BOARD) -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
-k $(IMAGE_KERNEL) \
-r $@ \
-o $@
@@ -19,7 +19,7 @@ define Build/mkubntimage-split
dd if=$@ of=$@.old1 bs=1024k count=1; \
dd if=$@ of=$@.old2 bs=1024k skip=1; \
$(STAGING_DIR_HOST)/bin/mkfwimage \
- -B $(UBNT_BOARD) -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-OpenWrt-$(REVISION) \
+ -B $(UBNT_BOARD) -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
-k $@.old1 \
-r $@.old2 \
-o $@; \
@@ -28,7 +28,7 @@ endef
define Build/mkubntimage2
-$(STAGING_DIR_HOST)/bin/mkfwimage2 -f 0x9f000000 \
- -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-OpenWrt-$(REVISION) \
+ -v $(UBNT_TYPE).$(UBNT_CHIP).v6.0.0-$(VERSION_DIST)-$(REVISION) \
-p jffs2:0x50000:0xf60000:0:0:$@ \
-o $@.new
@mv $@.new $@