aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2017-08-19 18:26:46 +0200
committerPiotr Dymacz <pepe2k@gmail.com>2017-09-10 22:14:43 +0200
commit90d8c0f0a2f4c902348a2f514ba33f2c9c34e005 (patch)
treededb9528766064223e22304e306719a17d9eafc0 /target
parentbd24d53ea2ac1c174838cbf21f511db8718175b7 (diff)
downloadupstream-90d8c0f0a2f4c902348a2f514ba33f2c9c34e005.tar.gz
upstream-90d8c0f0a2f4c902348a2f514ba33f2c9c34e005.tar.bz2
upstream-90d8c0f0a2f4c902348a2f514ba33f2c9c34e005.zip
ar71xx: add support for GL.iNet GL-USB150
GL.iNet GL-USB150 is an USB dongle WiFi router, based on Atheros AR9331. Specification: - 400/400/200 MHz (CPU/DDR/AHB) - 64 MB of RAM (DDR2) - 16 MB of FLASH (SPI NOR) - Realtek RTL8152B USB to Ethernet bridge (connected with AR9331 PHY4) - 1T1R 2.4 GHz - 2x LED, 1x button - UART header on PCB Flash instruction: Vendor firmware is based on OpenWrt CC. GUI or sysupgrade can be used to flash LEDE firmware. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/01_leds1
-rwxr-xr-xtarget/linux/ar71xx/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ar71xx/base-files/etc/diag.sh1
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/ar71xx.sh3
-rwxr-xr-xtarget/linux/ar71xx/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ar71xx/config-4.41
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt9
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Makefile1
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-gl-usb150.c87
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h1
-rw-r--r--target/linux/ar71xx/image/generic.mk13
-rw-r--r--target/linux/ar71xx/mikrotik/config-default1
-rw-r--r--target/linux/ar71xx/nand/config-default1
13 files changed, 121 insertions, 0 deletions
diff --git a/target/linux/ar71xx/base-files/etc/board.d/01_leds b/target/linux/ar71xx/base-files/etc/board.d/01_leds
index 4132e919e4..f367885488 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/01_leds
+++ b/target/linux/ar71xx/base-files/etc/board.d/01_leds
@@ -53,6 +53,7 @@ ap121f)
ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
;;
ap531b0|\
+gl-usb150|\
sc1750|\
sc450)
ucidef_set_led_wlan "wlan" "WLAN" "$board:green:wlan" "phy0tpt"
diff --git a/target/linux/ar71xx/base-files/etc/board.d/02_network b/target/linux/ar71xx/base-files/etc/board.d/02_network
index ba54d89b8f..5fa8c2f4c8 100755
--- a/target/linux/ar71xx/base-files/etc/board.d/02_network
+++ b/target/linux/ar71xx/base-files/etc/board.d/02_network
@@ -75,6 +75,7 @@ ar71xx_setup_interfaces()
eap7660d|\
el-mini|\
fritz300e|\
+ gl-usb150|\
hiveap-121|\
loco-m-xw|\
mr12|\
diff --git a/target/linux/ar71xx/base-files/etc/diag.sh b/target/linux/ar71xx/base-files/etc/diag.sh
index 7753a7156d..6794d89115 100644
--- a/target/linux/ar71xx/base-files/etc/diag.sh
+++ b/target/linux/ar71xx/base-files/etc/diag.sh
@@ -59,6 +59,7 @@ get_status_led() {
archer-c59-v1|\
archer-c60-v1|\
fritz300e|\
+ gl-usb150|\
mr12|\
mr16|\
nbg6616|\
diff --git a/target/linux/ar71xx/base-files/lib/ar71xx.sh b/target/linux/ar71xx/base-files/lib/ar71xx.sh
index 7fd5fb4522..2eab6108f1 100755
--- a/target/linux/ar71xx/base-files/lib/ar71xx.sh
+++ b/target/linux/ar71xx/base-files/lib/ar71xx.sh
@@ -672,6 +672,9 @@ ar71xx_board_detect() {
*"GL-MIFI")
name="gl-mifi"
;;
+ *"GL-USB150")
+ name="gl-usb150"
+ ;;
*"HiveAP-121")
name="hiveap-121"
;;
diff --git a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
index 05b5634aa5..fcf329478c 100755
--- a/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ar71xx/base-files/lib/upgrade/platform.sh
@@ -250,6 +250,7 @@ platform_check_image() {
gl-ar300|\
gl-domino|\
gl-mifi|\
+ gl-usb150|\
hiwifi-hc6361|\
hornet-ub-x2|\
jwap230|\
diff --git a/target/linux/ar71xx/config-4.4 b/target/linux/ar71xx/config-4.4
index 70793af3a3..c747af918a 100644
--- a/target/linux/ar71xx/config-4.4
+++ b/target/linux/ar71xx/config-4.4
@@ -116,6 +116,7 @@ CONFIG_ATH79_MACH_GL_AR300M=y
CONFIG_ATH79_MACH_GL_DOMINO=y
CONFIG_ATH79_MACH_GL_INET=y
CONFIG_ATH79_MACH_GL_MIFI=y
+CONFIG_ATH79_MACH_GL_USB150=y
CONFIG_ATH79_MACH_GS_MINIBOX_V1=y
CONFIG_ATH79_MACH_GS_OOLITE=y
# CONFIG_ATH79_MACH_HIVEAP_121 is not set
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index ff9c3037a1..6b6188dc7b 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -768,6 +768,15 @@ config ATH79_MACH_GL_INET
select ATH79_DEV_USB
select ATH79_DEV_WMAC
+config ATH79_MACH_GL_USB150
+ bool "GL.iNet GL-USB150 support"
+ select SOC_AR933X
+ select ATH79_DEV_ETH
+ select ATH79_DEV_GPIO_BUTTONS
+ select ATH79_DEV_LEDS_GPIO
+ select ATH79_DEV_M25P80
+ select ATH79_DEV_WMAC
+
config ATH79_MACH_EAP120
bool "TP-LINK EAP120 support"
select SOC_AR934X
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Makefile b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
index 469b6a794c..9e91c44060 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Makefile
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Makefile
@@ -120,6 +120,7 @@ obj-$(CONFIG_ATH79_MACH_GL_AR300M) += mach-gl-ar300m.o
obj-$(CONFIG_ATH79_MACH_GL_DOMINO) += mach-gl-domino.o
obj-$(CONFIG_ATH79_MACH_GL_INET) += mach-gl-inet.o
obj-$(CONFIG_ATH79_MACH_GL_MIFI) += mach-gl-mifi.o
+obj-$(CONFIG_ATH79_MACH_GL_USB150) += mach-gl-usb150.o
obj-$(CONFIG_ATH79_MACH_GS_MINIBOX_V1) += mach-gs-minibox-v1.o
obj-$(CONFIG_ATH79_MACH_GS_OOLITE) += mach-gs-oolite.o
obj-$(CONFIG_ATH79_MACH_HIVEAP_121) += mach-hiveap-121.o
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-gl-usb150.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-gl-usb150.c
new file mode 100644
index 0000000000..6cc27e1ada
--- /dev/null
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-gl-usb150.c
@@ -0,0 +1,87 @@
+/*
+ * GL.iNet GL-USB150 board support
+ *
+ * Copyright (C) 2017 Piotr Dymacz <pepe2k@gmail.com>
+ *
+ * This program is free software; you can redistribute it and/or modify it
+ * under the terms of the GNU General Public License version 2 as published
+ * by the Free Software Foundation.
+ */
+
+#include <linux/gpio.h>
+#include <linux/platform_device.h>
+
+#include <asm/mach-ath79/ath79.h>
+#include <asm/mach-ath79/ar71xx_regs.h>
+
+#include "common.h"
+#include "dev-eth.h"
+#include "dev-gpio-buttons.h"
+#include "dev-leds-gpio.h"
+#include "dev-m25p80.h"
+#include "dev-wmac.h"
+#include "machtypes.h"
+
+#define GL_USB150_GPIO_LED_POWER 13
+#define GL_USB150_GPIO_LED_WLAN 0
+#define GL_USB150_GPIO_LAN_RESET 7
+#define GL_USB150_GPIO_BTN_RESET 11
+
+#define GL_USB150_KEYS_POLL_INTERVAL 20
+#define GL_USB150_KEYS_DEBOUNCE_INTERVAL \
+ (3 * GL_USB150_KEYS_POLL_INTERVAL)
+
+#define GL_USB150_WMAC_CALDATA_OFFSET 0x1000
+
+static struct gpio_led gl_usb150_leds_gpio[] __initdata = {
+ {
+ .name = "gl-usb150:green:power",
+ .gpio = GL_USB150_GPIO_LED_POWER,
+ .active_low = 0,
+ }, {
+ .name = "gl-usb150:green:wlan",
+ .gpio = GL_USB150_GPIO_LED_WLAN,
+ .active_low = 0,
+ },
+};
+
+static struct gpio_keys_button gl_usb150_gpio_keys[] __initdata = {
+ {
+ .desc = "reset",
+ .type = EV_KEY,
+ .code = KEY_RESTART,
+ .debounce_interval = GL_USB150_KEYS_DEBOUNCE_INTERVAL,
+ .gpio = GL_USB150_GPIO_BTN_RESET,
+ .active_low = 0,
+ },
+};
+
+static void __init gl_usb150_setup(void)
+{
+ u8 *art = (u8 *) KSEG1ADDR(0x1fff0000);
+
+ ath79_register_m25p80(NULL);
+
+ ath79_setup_ar933x_phy4_switch(false, false);
+
+ /* LAN (PHY4 connected with Realtek RTL8152B) */
+ ath79_init_mac(ath79_eth0_data.mac_addr, art, 0);
+ ath79_register_mdio(0, 0x0);
+ ath79_register_eth(0);
+
+ ath79_register_leds_gpio(-1, ARRAY_SIZE(gl_usb150_leds_gpio),
+ gl_usb150_leds_gpio);
+
+ ath79_register_gpio_keys_polled(-1, GL_USB150_KEYS_POLL_INTERVAL,
+ ARRAY_SIZE(gl_usb150_gpio_keys),
+ gl_usb150_gpio_keys);
+
+ gpio_request_one(GL_USB150_GPIO_LAN_RESET,
+ GPIOF_OUT_INIT_LOW | GPIOF_EXPORT_DIR_FIXED,
+ "LAN reset");
+
+ ath79_register_wmac(art + GL_USB150_WMAC_CALDATA_OFFSET, NULL);
+}
+
+MIPS_MACHINE(ATH79_MACH_GL_USB150, "GL-USB150", "GL.iNet GL-USB150",
+ gl_usb150_setup);
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index 5bc50a42ff..16fbdcef84 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -112,6 +112,7 @@ enum ath79_mach_type {
ATH79_MACH_GL_DOMINO, /* Domino */
ATH79_MACH_GL_INET, /* GL-CONNECT GL-INET */
ATH79_MACH_GL_MIFI, /* GL-MIFI support */
+ ATH79_MACH_GL_USB150, /* GL.iNet GL-USB150 */
ATH79_MACH_GS_MINIBOX_V1, /* Gainstrong MiniBox V1.0 */
ATH79_MACH_GS_OOLITE, /* GS OOLITE V1.0 */
ATH79_MACH_HIVEAP_121, /* Aerohive HiveAP-121*/
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 01c5bdc677..f0b2179f44 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -278,6 +278,19 @@ define Device/gl-mifi
endef
TARGET_DEVICES += gl-mifi
+define Device/gl-usb150
+ DEVICE_TITLE := GL.iNet GL-USB150
+ DEVICE_PACKAGES := -swconfig
+ BOARDNAME := GL-USB150
+ IMAGE_SIZE := 16000k
+ CONSOLE := ttyATH0,115200
+ MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,16000k(firmware),64k(art)ro
+ SUPPORTED_DEVICES := gl-usb150
+ IMAGE/sysupgrade.bin = append-kernel | pad-to $$$$(BLOCKSIZE) | \
+ append-rootfs | pad-rootfs | append-metadata | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += gl-usb150
+
define Device/lima
DEVICE_TITLE := 8devices Lima
DEVICE_PACKAGES := kmod-usb-core kmod-usb2
diff --git a/target/linux/ar71xx/mikrotik/config-default b/target/linux/ar71xx/mikrotik/config-default
index 34c2fc1f0f..83e3a03877 100644
--- a/target/linux/ar71xx/mikrotik/config-default
+++ b/target/linux/ar71xx/mikrotik/config-default
@@ -80,6 +80,7 @@
# CONFIG_ATH79_MACH_GL_DOMINO is not set
# CONFIG_ATH79_MACH_GL_INET is not set
# CONFIG_ATH79_MACH_GL_MIFI is not set
+# CONFIG_ATH79_MACH_GL_USB150 is not set
# CONFIG_ATH79_MACH_GS_MINIBOX_V1 is not set
# CONFIG_ATH79_MACH_GS_OOLITE is not set
# CONFIG_ATH79_MACH_HIWIFI_HC6361 is not set
diff --git a/target/linux/ar71xx/nand/config-default b/target/linux/ar71xx/nand/config-default
index 57318b38e8..99eb346e15 100644
--- a/target/linux/ar71xx/nand/config-default
+++ b/target/linux/ar71xx/nand/config-default
@@ -81,6 +81,7 @@ CONFIG_ATH79_MACH_DOMYWIFI_DW33D=y
# CONFIG_ATH79_MACH_GL_DOMINO is not set
# CONFIG_ATH79_MACH_GL_INET is not set
# CONFIG_ATH79_MACH_GL_MIFI is not set
+# CONFIG_ATH79_MACH_GL_USB150 is not set
# CONFIG_ATH79_MACH_GS_MINIBOX_V1 is not set
# CONFIG_ATH79_MACH_GS_OOLITE is not set
CONFIG_ATH79_MACH_HIVEAP_121=y