aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2018-02-18 12:39:45 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2018-02-22 18:53:22 +0100
commit22ae9b742bb0ac3290aa45858268d278f66d55b2 (patch)
treedf43215b186c051e52ce23870615670c2c3292c5 /target
parent3b8a858d5cf656b4a2832f1d831911a116aa4c74 (diff)
downloadupstream-22ae9b742bb0ac3290aa45858268d278f66d55b2.tar.gz
upstream-22ae9b742bb0ac3290aa45858268d278f66d55b2.tar.bz2
upstream-22ae9b742bb0ac3290aa45858268d278f66d55b2.zip
ar71xx: YunCore AP90Q image supports also AP80Q
Vendor released new model (AP80Q) which is identical from hardware point of view with already supported AP90Q. Include AP80Q in machine name. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt2
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c4
-rw-r--r--target/linux/ar71xx/files/arch/mips/ath79/machtypes.h2
-rw-r--r--target/linux/ar71xx/image/generic.mk2
4 files changed, 5 insertions, 5 deletions
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
index 7c0494bcc8..a9e235fa75 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
+++ b/target/linux/ar71xx/files/arch/mips/ath79/Kconfig.openwrt
@@ -217,7 +217,7 @@ config ATH79_MACH_AP531B0
select ATH79_DEV_WMAC
config ATH79_MACH_AP90Q
- bool "YunCore AP90Q support"
+ bool "YunCore AP80Q/AP90Q support"
select SOC_QCA953X
select ATH79_DEV_ETH
select ATH79_DEV_GPIO_BUTTONS
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c b/target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c
index 2e9d34d658..99fceca3a0 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c
+++ b/target/linux/ar71xx/files/arch/mips/ath79/mach-ap90q.c
@@ -1,6 +1,6 @@
/*
* Support for YunCore boards:
- * - AP90Q
+ * - AP80Q/AP90Q
* - CPE830
*
* Copyright (C) 2016 Piotr Dymacz <pepe2k@gmail.com>
@@ -172,7 +172,7 @@ static void __init ap90q_setup(void)
ap90q_leds_gpio);
}
-MIPS_MACHINE(ATH79_MACH_AP90Q, "AP90Q", "YunCore AP90Q", ap90q_setup);
+MIPS_MACHINE(ATH79_MACH_AP90Q, "AP90Q", "YunCore AP80Q/AP90Q", ap90q_setup);
static void __init cpe830_setup(void)
{
diff --git a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
index da98a811e1..9127d3fe92 100644
--- a/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
+++ b/target/linux/ar71xx/files/arch/mips/ath79/machtypes.h
@@ -40,7 +40,7 @@ enum ath79_mach_type {
ATH79_MACH_AP147_010, /* Atheros AP147-010 reference board */
ATH79_MACH_AP152, /* Atheros AP152 reference board */
ATH79_MACH_AP531B0, /* Rockeetech AP531B0 */
- ATH79_MACH_AP90Q, /* YunCore AP90Q */
+ ATH79_MACH_AP90Q, /* YunCore AP80Q/AP90Q */
ATH79_MACH_AP91_5G, /* ALFA Network AP91-5G */
ATH79_MACH_AP96, /* Atheros AP96 */
ATH79_MACH_ARCHER_C25_V1, /* TP-LINK Archer C25 V1 board */
diff --git a/target/linux/ar71xx/image/generic.mk b/target/linux/ar71xx/image/generic.mk
index 2158a9921a..137716d439 100644
--- a/target/linux/ar71xx/image/generic.mk
+++ b/target/linux/ar71xx/image/generic.mk
@@ -125,7 +125,7 @@ endef
TARGET_DEVICES += ap531b0
define Device/ap90q
- DEVICE_TITLE := YunCore AP90Q
+ DEVICE_TITLE := YunCore AP80Q/AP90Q
BOARDNAME := AP90Q
IMAGE_SIZE := 16000k
MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env),16000k(firmware),64k(art)ro