aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorAntonio Silverio <menion@gmail.com>2018-07-30 11:33:03 +0200
committerZoltan HERPAI <wigyori@uid0.hu>2018-08-09 12:06:58 +0200
commite2e39328d53c0af473df0c7aad908cff4abf3dfa (patch)
tree6fbb61a37295c6eb97baaa3727ffe2511eea895d /target
parent14b6c725411dfb3e44242bea3b000a1f58b52235 (diff)
downloadupstream-e2e39328d53c0af473df0c7aad908cff4abf3dfa.tar.gz
upstream-e2e39328d53c0af473df0c7aad908cff4abf3dfa.tar.bz2
upstream-e2e39328d53c0af473df0c7aad908cff4abf3dfa.zip
sunxi: Added support for Xunlong Orange Pi PC2
CPU: H5 High Performance Quad-core 64-bit Cortex-A53 GPU: Mali450 OpenGL ES 2.0/1.1/1.0, OpenVG 1.1, EGL Memory: 1GB DDR3 (shared with GPU) Onboard Storage: TF card (Max. 32GB) / NOR flash(2MB) Onboard Network: 1000M/100M Ethernet RJ45 USB 2.0 Ports: Three USB 2.0 HOST, one USB 2.0 OTG, HOST mode role by default in DTS Buttons: Power Button(SW4) Debug TTL UART: ..DC-IN.. >[GND][RX][TX] ..HDMI.. Signed-off-by: Antonio Silverio <menion@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/sunxi/image/cortex-a53.mk10
1 files changed, 10 insertions, 0 deletions
diff --git a/target/linux/sunxi/image/cortex-a53.mk b/target/linux/sunxi/image/cortex-a53.mk
index 344071b94d..e40f35cb32 100644
--- a/target/linux/sunxi/image/cortex-a53.mk
+++ b/target/linux/sunxi/image/cortex-a53.mk
@@ -48,4 +48,14 @@ endef
TARGET_DEVICES += sun50i-h5-orangepi-zero-plus
+define Device/sun50i-h5-orangepi-pc2
+ DEVICE_TITLE:=Xunlong Orange Pi PC2
+ SUPPORTED_DEVICES:=xunlong,orangepi-pc2
+ SUNXI_DTS:=allwinner/sun50i-h5-orangepi-pc2
+ KERNEL_NAME := Image
+ KERNEL := kernel-bin
+endef
+
+TARGET_DEVICES += sun50i-h5-orangepi-pc2
+
endif