aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorDaniel Golle <daniel@makrotopia.org>2018-01-23 02:46:36 +0100
committerDaniel Golle <daniel@makrotopia.org>2018-01-23 02:56:57 +0100
commit9c4fe103cba323684521f8e5d596e3c616c5d276 (patch)
treee53e597a3647fb29fc23a513b2636de7cb3bfd35 /target
parentb33c3e1b7c73be7750e83952f9880b9335d49873 (diff)
downloadupstream-9c4fe103cba323684521f8e5d596e3c616c5d276.tar.gz
upstream-9c4fe103cba323684521f8e5d596e3c616c5d276.tar.bz2
upstream-9c4fe103cba323684521f8e5d596e3c616c5d276.zip
ramips: add support for ZBT-WE1226
MT7628NN (580MHz), 8MB SPI NOR, 64MB DDR2 RAM Everything except for the switch LEDs works great. Signed-off-by: Daniel Golle <daniel@makrotopia.org>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds6
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/base-files/etc/diag.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/ramips.sh3
-rwxr-xr-xtarget/linux/ramips/base-files/lib/upgrade/platform.sh1
-rw-r--r--target/linux/ramips/dts/ZBT-WE1226.dts111
-rw-r--r--target/linux/ramips/image/mt76x8.mk7
7 files changed, 132 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index 0b0feb4156..37630cde66 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -491,6 +491,12 @@ zbt-we826-32M)
set_wifi_led "zbt-we826:green:wifi"
set_usb_led "zbt-we826:green:usb"
;;
+zbt-we1226)
+ set_wifi_led "$boardname:green:wlan"
+ ucidef_set_led_switch "lan1" "LAN1" "$boardname:green:lan1" "switch0" "0x01"
+ ucidef_set_led_switch "lan2" "LAN2" "$boardname:green:lan2" "switch0" "0x02"
+ ucidef_set_led_switch "wan" "WAN" "$boardname:green:wan" "switch0" "0x10"
+ ;;
zbt-wr8305rt)
ucidef_set_led_default "power" "power" "$boardname:green:sys" "1"
set_usb_led "$boardname:green:usb"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 7deebbcef0..f50a5a6d46 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -349,6 +349,7 @@ ramips_setup_interfaces()
ucidef_add_switch "switch0" \
"1:lan" "2:lan" "0:wan" "6@eth0"
;;
+ zbt-we1226|\
y1)
ucidef_add_switch "switch0" \
"0:lan:2" "1:lan:1" "4:wan" "6@eth0"
diff --git a/target/linux/ramips/base-files/etc/diag.sh b/target/linux/ramips/base-files/etc/diag.sh
index f290c3f9a7..22687b1970 100644
--- a/target/linux/ramips/base-files/etc/diag.sh
+++ b/target/linux/ramips/base-files/etc/diag.sh
@@ -314,6 +314,9 @@ get_status_led() {
zbt-we826-32M)
status_led="zbt-we826:green:power"
;;
+ zbt-we1226)
+ status_led="zbt-we1226:green:wlan"
+ ;;
zbt-wg3526-16M|\
zbt-wg3526-32M)
status_led="zbt-wg3526:green:status"
diff --git a/target/linux/ramips/base-files/lib/ramips.sh b/target/linux/ramips/base-files/lib/ramips.sh
index 3ba6d0f0f5..60cf9b298c 100755
--- a/target/linux/ramips/base-files/lib/ramips.sh
+++ b/target/linux/ramips/base-files/lib/ramips.sh
@@ -688,6 +688,9 @@ ramips_board_detect() {
*"ZBT-WA05")
name="zbt-wa05"
;;
+ *"ZBT-WE1226")
+ name="zbt-we1226"
+ ;;
*"ZBT-WE1326")
name="zbt-we1326"
;;
diff --git a/target/linux/ramips/base-files/lib/upgrade/platform.sh b/target/linux/ramips/base-files/lib/upgrade/platform.sh
index bce49a61d7..730f487b30 100755
--- a/target/linux/ramips/base-files/lib/upgrade/platform.sh
+++ b/target/linux/ramips/base-files/lib/upgrade/platform.sh
@@ -203,6 +203,7 @@ platform_check_image() {
zbt-ape522ii|\
zbt-cpe102|\
zbt-wa05|\
+ zbt-we1226|\
zbt-we1326|\
zbt-we2026|\
zbtlink,zbt-we3526|\
diff --git a/target/linux/ramips/dts/ZBT-WE1226.dts b/target/linux/ramips/dts/ZBT-WE1226.dts
new file mode 100644
index 0000000000..67e4353c12
--- /dev/null
+++ b/target/linux/ramips/dts/ZBT-WE1226.dts
@@ -0,0 +1,111 @@
+/dts-v1/;
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+#include "mt7628an.dtsi"
+
+/ {
+ compatible = "zbt,we1226", "mediatek,mt7628an-soc";
+ model = "Zbtlink ZBT-WE1226";
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ memory@0 {
+ device_type = "memory";
+ reg = <0x0 0x4000000>;
+ };
+
+ gpio-keys-polled {
+ compatible = "gpio-keys-polled";
+ #address-cells = <1>;
+ #size-cells = <0>;
+ poll-interval = <20>;
+
+ reset {
+ label = "reset";
+ gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+ linux,code = <KEY_RESTART>;
+ };
+ };
+
+ gpio-leds {
+ compatible = "gpio-leds";
+
+ lan2 {
+ label = "zbt-we1226:green:lan2";
+ gpios = <&gpio1 7 GPIO_ACTIVE_LOW>;
+ };
+
+ lan1 {
+ label = "zbt-we1226:green:lan1";
+ gpios = <&gpio1 10 GPIO_ACTIVE_LOW>;
+ };
+
+ wan {
+ label = "zbt-we1226:green:wan";
+ gpios = <&gpio1 11 GPIO_ACTIVE_LOW>;
+ };
+
+ wlan {
+ label = "zbt-we1226:green:wlan";
+ gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
+ };
+ };
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "i2c", "wled_an";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ m25p80@0 {
+ #address-cells = <1>;
+ #size-cells = <1>;
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <10000000>;
+ m25p,chunked-io = <32>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x10000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ label = "firmware";
+ reg = <0x50000 0x7b0000>;
+ };
+ };
+};
+
+&wmac {
+ status = "okay";
+ ralink,mtd-eeprom = <&factory 0x4>;
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x2e>;
+ mediatek,portmap = "llllw";
+};
diff --git a/target/linux/ramips/image/mt76x8.mk b/target/linux/ramips/image/mt76x8.mk
index 8332c7c423..ae8a1344d5 100644
--- a/target/linux/ramips/image/mt76x8.mk
+++ b/target/linux/ramips/image/mt76x8.mk
@@ -238,3 +238,10 @@ define Device/wrtnode2r
DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
endef
TARGET_DEVICES += wrtnode2r
+
+define Device/zbt-we1226
+ DTS := ZBT-WE1226
+ IMAGE_SIZE := $(ralink_default_fw_size_8M)
+ DEVICE_TITLE := ZBTlink ZBT-WE1226
+endef
+TARGET_DEVICES += zbt-we1226