aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorPiotr Dymacz <pepe2k@gmail.com>2019-03-10 01:28:28 +0100
committerPiotr Dymacz <pepe2k@gmail.com>2019-03-11 22:00:26 +0100
commit9b6413982c4c7f9191d08995f1e9b67e38f259de (patch)
treeffeba0c46e3e405aaa7029dfe8dbafb99d505f98 /target
parent6ac5144b13dd2c43f83deb715a9a2487f87d3c46 (diff)
downloadupstream-9b6413982c4c7f9191d08995f1e9b67e38f259de.tar.gz
upstream-9b6413982c4c7f9191d08995f1e9b67e38f259de.tar.bz2
upstream-9b6413982c4c7f9191d08995f1e9b67e38f259de.zip
ramips: add support for ALFA Network Tube-E4G
ALFA Network Tube-E4G is an outdoor, dual-SIM LTE Cat. 4 CPE, based on MediaTek MT7620A, equipped with Quectel EC25 miniPCIe modem. Specification: - MT7620A (580 MHz) - 64/128/256 MB of RAM (DDR2) - 16/32 MB of flash (SPI NOR) - 1x 10/100 Mbps Ethernet, with passive PoE support (24 V) - 1x miniPCIe slot (with PCIe and USB 2.0 buses) - 2x SIM slot (mini, micro) with detect and switch driven by GPIO - 1x detachable antenna (modem main) - 1x internal antenna (modem div) - 1x GPS passive antenna (optional) - 5x LED (all driven by GPIO) - 1x button (reset) - UART (4-pin, 2.54 mm pitch) header on PCB Other: Default SIM slot is selected at an early stage by U-Boot, based on 'default_sim' environment value: 1 or unset = SIM1 (mini), 2 = SIM2 (micro). U-Boot also resets the modem, using #PERST signal, before starting kernel. Flash instruction: You can use the 'sysupgrade' image directly in vendor firmware which is based on OpenWrt (make sure to not preserve settings - use 'sysupgrade -n -F ...' command). Alternatively, use web recovery mode in U-Boot: 1. Power the device with reset button pressed, the LAN LED will start blinking slowly and after ~3 seconds, when it starts blinking faster, you can release the button. 2. Setup static IP 192.168.1.2/24 on your PC. 3. Go to 192.168.1.1 in browser and upload 'sysupgrade' image. Signed-off-by: Piotr Dymacz <pepe2k@gmail.com>
Diffstat (limited to 'target')
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/01_leds4
-rwxr-xr-xtarget/linux/ramips/base-files/etc/board.d/02_network1
-rw-r--r--target/linux/ramips/dts/TUBE-E4G.dts190
-rw-r--r--target/linux/ramips/image/mt7620.mk9
4 files changed, 204 insertions, 0 deletions
diff --git a/target/linux/ramips/base-files/etc/board.d/01_leds b/target/linux/ramips/base-files/etc/board.d/01_leds
index df5dd84d5a..3a761decb1 100755
--- a/target/linux/ramips/base-files/etc/board.d/01_leds
+++ b/target/linux/ramips/base-files/etc/board.d/01_leds
@@ -38,6 +38,10 @@ alfa-network,ac1200rm)
alfa-network,awusfree1)
set_wifi_led "$boardname:blue:wlan"
;;
+alfa-network,tube-e4g)
+ ucidef_set_led_netdev "4g" "4g" "$boardname:green:4g" "wwan0"
+ ucidef_set_led_netdev "lan" "lan" "$boardname:blue:lan" "eth0"
+ ;;
all0256n-4M|\
all0256n-8M)
ucidef_set_rssimon "wlan0" "200000" "1"
diff --git a/target/linux/ramips/base-files/etc/board.d/02_network b/target/linux/ramips/base-files/etc/board.d/02_network
index 6657b7273d..5221838547 100755
--- a/target/linux/ramips/base-files/etc/board.d/02_network
+++ b/target/linux/ramips/base-files/etc/board.d/02_network
@@ -147,6 +147,7 @@ ramips_setup_interfaces()
"0:lan" "1:lan" "2:lan" "4:wan" "6@eth0"
;;
alfa-network,awusfree1|\
+ alfa-network,tube-e4g|\
cs-qr10|\
d105|\
dlink,dap-1522-a1|\
diff --git a/target/linux/ramips/dts/TUBE-E4G.dts b/target/linux/ramips/dts/TUBE-E4G.dts
new file mode 100644
index 0000000000..4097dc6140
--- /dev/null
+++ b/target/linux/ramips/dts/TUBE-E4G.dts
@@ -0,0 +1,190 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7620a.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/ {
+ compatible = "alfa-network,tube-e4g", "ralink,mt7620a-soc";
+ model = "ALFA Network Tube-E4G";
+
+ aliases {
+ led-boot = &power;
+ led-failsafe = &power;
+ led-running = &power;
+ led-upgrade = &power;
+ };
+
+ chosen {
+ bootargs = "console=ttyS0,115200";
+ };
+
+ gpio-export {
+ compatible = "gpio-export";
+ #size-cells = <0>;
+
+ modem-enable {
+ gpio-export,name = "modem-enable";
+ gpio-export,output = <1>;
+ gpios = <&gpio1 12 GPIO_ACTIVE_HIGH>;
+ };
+
+ modem-rf-enable {
+ gpio-export,name = "modem-rf-enable";
+ gpio-export,output = <1>;
+ gpios = <&gpio0 12 GPIO_ACTIVE_HIGH>;
+ };
+
+ sim-select {
+ gpio-export,name = "sim-select";
+ gpio-export,output = <0>;
+ gpios = <&gpio0 13 GPIO_ACTIVE_HIGH>;
+ };
+
+ sim1-detect {
+ gpio-export,name = "sim1-detect";
+ gpios = <&gpio0 9 GPIO_ACTIVE_HIGH>;
+ };
+
+ sim2-detect {
+ gpio-export,name = "sim2-detect";
+ gpios = <&gpio2 1 GPIO_ACTIVE_HIGH>;
+ };
+ };
+
+ keys {
+ compatible = "gpio-keys";
+
+ reset {
+ label = "reset";
+ linux,code = <KEY_RESTART>;
+ gpios = <&gpio2 15 GPIO_ACTIVE_LOW>;
+ debounce-interval = <60>;
+ };
+ };
+
+ leds {
+ compatible = "gpio-leds";
+
+ 4g {
+ label = "tube-e4g:green:4g";
+ gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+ };
+
+ lan {
+ label = "tube-e4g:blue:lan";
+ gpios = <&gpio2 4 GPIO_ACTIVE_LOW>;
+ };
+
+ power: power {
+ label = "tube-e4g:green:power";
+ gpios = <&gpio2 0 GPIO_ACTIVE_LOW>;
+ default-state = "keep";
+ };
+
+ sim1 {
+ label = "tube-e4g:green:sim1";
+ gpios = <&gpio2 3 GPIO_ACTIVE_LOW>;
+ default-state = "keep";
+ };
+
+ sim2 {
+ label = "tube-e4g:green:sim2";
+ gpios = <&gpio2 2 GPIO_ACTIVE_LOW>;
+ default-state = "keep";
+ };
+ };
+};
+
+&ehci {
+ status = "okay";
+};
+
+&ethernet {
+ mtd-mac-address = <&factory 0x28>;
+};
+
+&gpio0 {
+ status = "okay";
+};
+
+&gpio1 {
+ status = "okay";
+};
+
+&gpio2 {
+ status = "okay";
+};
+
+&gsw {
+ mediatek,port4 = "ephy";
+};
+
+&ohci {
+ status = "okay";
+};
+
+&pcie {
+ status = "disabled";
+};
+
+&pinctrl {
+ state_default: pinctrl0 {
+ gpio {
+ ralink,group = "ephy", "nd_sd", "pcie", "uartf";
+ ralink,function = "gpio";
+ };
+ };
+};
+
+&spi0 {
+ status = "okay";
+
+ flash@0 {
+ compatible = "jedec,spi-nor";
+ reg = <0>;
+ spi-max-frequency = <50000000>;
+ m25p,fast-read;
+
+ partitions {
+ compatible = "fixed-partitions";
+ #address-cells = <1>;
+ #size-cells = <1>;
+
+ partition@0 {
+ label = "u-boot";
+ reg = <0x0 0x30000>;
+ read-only;
+ };
+
+ partition@30000 {
+ label = "u-boot-env";
+ reg = <0x30000 0x1000>;
+ };
+
+ partition@31000 {
+ label = "config";
+ reg = <0x31000 0xf000>;
+ read-only;
+ };
+
+ factory: partition@40000 {
+ label = "factory";
+ reg = <0x40000 0x10000>;
+ read-only;
+ };
+
+ partition@50000 {
+ compatible = "denx,uimage";
+ label = "firmware";
+ reg = <0x50000 0xfb0000>;
+ };
+ };
+ };
+};
+
+&wmac {
+ status = "disabled";
+};
diff --git a/target/linux/ramips/image/mt7620.mk b/target/linux/ramips/image/mt7620.mk
index 7ac228db16..77a5b5724d 100644
--- a/target/linux/ramips/image/mt7620.mk
+++ b/target/linux/ramips/image/mt7620.mk
@@ -51,6 +51,15 @@ define Device/alfa-network_ac1200rm
endef
TARGET_DEVICES += alfa-network_ac1200rm
+define Device/alfa-network_tube-e4g
+ DTS := TUBE-E4G
+ IMAGE_SIZE := 16064k
+ DEVICE_TITLE := ALFA Network Tube-E4G
+ DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci uboot-envtools uqmi \
+ -iwinfo -kmod-rt2800-pci -kmod-rt2800-soc -wpad-basic
+endef
+TARGET_DEVICES += alfa-network_tube-e4g
+
define Device/Archer
TPLINK_HWREVADD := 0
TPLINK_HVERSION := 3