aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFlorian Fainelli <florian@openwrt.org>2009-03-12 08:54:04 +0000
committerFlorian Fainelli <florian@openwrt.org>2009-03-12 08:54:04 +0000
commit6495fa36ea584bbc5f58d21df982bf100e4d6591 (patch)
treef1ea43aa20adcb9fe0221d6fd7f736af6832a68f /target
parent8065eb4a551f4c2874a761325a0a83ef6784784d (diff)
downloadupstream-6495fa36ea584bbc5f58d21df982bf100e4d6591.tar.gz
upstream-6495fa36ea584bbc5f58d21df982bf100e4d6591.tar.bz2
upstream-6495fa36ea584bbc5f58d21df982bf100e4d6591.zip
add support for AGPF-S0 (Pirelli Alice Gate VoIP 2 Plus Wi-Fi) #4366
SVN-Revision: 14850
Diffstat (limited to 'target')
-rw-r--r--target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c23
-rw-r--r--target/linux/brcm63xx/image/Makefile11
2 files changed, 34 insertions, 0 deletions
diff --git a/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c b/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
index 56da94b8c2..8e71fd12c2 100644
--- a/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
+++ b/target/linux/brcm63xx/files/arch/mips/bcm63xx/boards/board_bcm963xx.c
@@ -260,6 +260,28 @@ static struct board_info __initdata board_96358vw2 = {
.has_pccard = 1,
.has_ehci0 = 1,
};
+
+static struct board_info __initdata board_AGPFS0 = {
+ .name = "AGPF-S0",
+ .expected_cpu_id = 0x6358,
+
+ .has_enet0 = 1,
+ .has_enet1 = 1,
+ .has_pci = 1,
+
+ .enet0 = {
+ .has_phy = 1,
+ .use_internal_phy = 1,
+ },
+
+ .enet1 = {
+ .force_speed_100 = 1,
+ .force_duplex_full = 1,
+ },
+
+ .has_ohci0 = 1,
+ .has_ehci0 = 1,
+};
#endif
/*
@@ -282,6 +304,7 @@ static const struct board_info __initdata *bcm963xx_boards[] = {
#ifdef CONFIG_BCM63XX_CPU_6358
&board_96358vw,
&board_96358vw2,
+ &board_AGPFS0,
#endif
};
diff --git a/target/linux/brcm63xx/image/Makefile b/target/linux/brcm63xx/image/Makefile
index 6cb7a34c01..250cc8236d 100644
--- a/target/linux/brcm63xx/image/Makefile
+++ b/target/linux/brcm63xx/image/Makefile
@@ -37,6 +37,15 @@ define Image/Build/CFE
$(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
endef
+define Image/Build/CFEAGPF
+ # Generate the tagged image
+ $(STAGING_DIR_HOST)/bin/imagetag -i $(KDIR)/vmlinux.lzma.cfe -f $(KDIR)/root.$(1) \
+ -o $(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin \
+ -b $(2) -c $(3) -e $(LOADADDR) -l $(LOADADDR) \
+ -v 8 -m IMAGE -k 131072
+ $(call prepare_generic_squashfs,$(BIN_DIR)/openwrt-$(2)-$(1)-cfe.bin)
+endef
+
define Image/Build/RedBoot
cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(1)-vmlinux.elf
gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
@@ -104,6 +113,8 @@ define Image/Build
$(call Image/Build/CFE,$(1),F@ST2404,6348)
# Inventel Livebox
$(call Image/Build/RedBoot,livebox)
+ # Pirelli Alice Gate VoIP 2 Plus Wi-Fi AGPF-S0
+ $(call Image/Build/CFEAGPF,$(1),AGPF-S0,6358)
endef
$(eval $(call BuildImage))