aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2010-12-23 12:42:16 +0000
committerGabor Juhos <juhosg@openwrt.org>2010-12-23 12:42:16 +0000
commit0f659a13ddecb98e16241cf043a15d6045cab357 (patch)
tree8d4bc509b025f294f1e4cb0768427930d3506fca /target
parent76774e1daadb6e69ab00d76593b76afab78a0db7 (diff)
downloadupstream-0f659a13ddecb98e16241cf043a15d6045cab357.tar.gz
upstream-0f659a13ddecb98e16241cf043a15d6045cab357.tar.bz2
upstream-0f659a13ddecb98e16241cf043a15d6045cab357.zip
ar71xx: add support for TL-WR740N v1
Same as TL-WR741ND but with different hardware ID and without detachable antenna. Signed-off-by: Paul Fertser <fercerpav@gmail.com> SVN-Revision: 24811
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/generic/profiles/tp-link.mk11
-rw-r--r--target/linux/ar71xx/image/Makefile5
2 files changed, 16 insertions, 0 deletions
diff --git a/target/linux/ar71xx/generic/profiles/tp-link.mk b/target/linux/ar71xx/generic/profiles/tp-link.mk
index a36e1756f6..df3873c034 100644
--- a/target/linux/ar71xx/generic/profiles/tp-link.mk
+++ b/target/linux/ar71xx/generic/profiles/tp-link.mk
@@ -49,6 +49,17 @@ endef
$(eval $(call Profile,TLWR741NDV1))
+define Profile/TLWR740NV1
+ NAME:=TP-LINK TL-WR740N v1
+ PACKAGES:=kmod-ath9k wpad-mini
+endef
+
+define Profile/TLWR740NV1/Description
+ Package set optimized for the TP-LINK TL-WR740N v1.
+endef
+
+$(eval $(call Profile,TLWR740NV1))
+
define Profile/TLWR841NV15
NAME:=TP-LINK TL-WR841N v1.5
PACKAGES:=kmod-ath9k wpad-mini
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index f6dc3b01fd..f1a9362184 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -590,6 +590,10 @@ define Image/Build/Profile/TLWR741NDV1
$(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr741nd-v1,board=TL-WR741ND,TL-WR741NDv1)
endef
+define Image/Build/Profile/TLWR740NV1
+ $(call Image/Build/Template/$(fs_4k)/$(1),TPLINK,tl-wr740n-v1,board=TL-WR741ND,TL-WR740Nv1)
+endef
+
define Image/Build/Profile/TLWR841NV15
$(call Image/Build/Template/$(fs_squash)/$(1),TPLINK,tl-wr841n-v1.5,board=TL-WR841N-v1.5,TL-WR841Nv1.5)
endef
@@ -677,6 +681,7 @@ define Image/Build/Profile/Default
$(call Image/Build/Profile/TLMR3420V1,$(1))
$(call Image/Build/Profile/TLWA901NDV1,$(1))
$(call Image/Build/Profile/TLWR741NDV1,$(1))
+ $(call Image/Build/Profile/TLWR740NV1,$(1))
$(call Image/Build/Profile/TLWR841NV15,$(1))
$(call Image/Build/Profile/TLWR841NDV3,$(1))
$(call Image/Build/Profile/TLWR841NDV5,$(1))