aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorKoen Vandeputte <koen.vandeputte@ncentric.com>2019-05-13 12:50:25 +0200
committerKoen Vandeputte <koen.vandeputte@ncentric.com>2019-05-13 19:17:41 +0200
commit09050b6fe22848c6b8d59a437e357c7ad34bc523 (patch)
tree30cd5f93b5da3a0096b7ca214a466e810c93a602 /target
parent461ef393451842c28abffdb42250dd55d5ee85fb (diff)
downloadupstream-09050b6fe22848c6b8d59a437e357c7ad34bc523.tar.gz
upstream-09050b6fe22848c6b8d59a437e357c7ad34bc523.tar.bz2
upstream-09050b6fe22848c6b8d59a437e357c7ad34bc523.zip
kernel: bump 4.14 to 4.14.118
Refreshed all patches. Remove upstreamed: - 060-v5.1-serial-ar933x_uart-Fix-build-failure-with-disabled-c.patch Altered: - 143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch Compile-tested on: ar71xx, cns3xxx, imx6, x86_64 Runtime-tested on: ar71xx, cns3xxx, imx6 Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/apm821xx/patches-4.14/140-GPIO-add-named-gpio-exports.patch2
-rw-r--r--target/linux/ar71xx/patches-4.14/310-lib-add-rle-decompression.patch2
-rw-r--r--target/linux/ath79/patches-4.14/0036-GPIO-add-named-gpio-exports.patch2
-rw-r--r--target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch2
-rw-r--r--target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch21
-rw-r--r--target/linux/generic/backport-4.14/060-v5.1-serial-ar933x_uart-Fix-build-failure-with-disabled-c.patch94
-rw-r--r--target/linux/generic/backport-4.14/293-v4.16-netfilter-reduce-size-of-hook-entry-point-locations.patch2
-rw-r--r--target/linux/generic/pending-4.14/530-jffs2_make_lzma_available.patch4
-rw-r--r--target/linux/generic/pending-4.14/630-packet_socket_type.patch6
-rw-r--r--target/linux/lantiq/patches-4.14/0030-GPIO-add-named-gpio-exports.patch2
-rw-r--r--target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch2
-rw-r--r--target/linux/ramips/patches-4.14/0024-GPIO-add-named-gpio-exports.patch2
12 files changed, 27 insertions, 114 deletions
diff --git a/target/linux/apm821xx/patches-4.14/140-GPIO-add-named-gpio-exports.patch b/target/linux/apm821xx/patches-4.14/140-GPIO-add-named-gpio-exports.patch
index fe4ea4fc24..8f0ac8d0f8 100644
--- a/target/linux/apm821xx/patches-4.14/140-GPIO-add-named-gpio-exports.patch
+++ b/target/linux/apm821xx/patches-4.14/140-GPIO-add-named-gpio-exports.patch
@@ -22,7 +22,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#include "gpiolib.h"
-@@ -507,3 +509,72 @@ void of_gpiochip_remove(struct gpio_chip
+@@ -513,3 +515,72 @@ void of_gpiochip_remove(struct gpio_chip
gpiochip_remove_pin_ranges(chip);
of_node_put(chip->of_node);
}
diff --git a/target/linux/ar71xx/patches-4.14/310-lib-add-rle-decompression.patch b/target/linux/ar71xx/patches-4.14/310-lib-add-rle-decompression.patch
index 766ffbeb76..07faeab5bb 100644
--- a/target/linux/ar71xx/patches-4.14/310-lib-add-rle-decompression.patch
+++ b/target/linux/ar71xx/patches-4.14/310-lib-add-rle-decompression.patch
@@ -12,7 +12,7 @@
# ZLIB_INFLATE; DECOMPRESS_GZIP is just a wrapper.)
--- a/lib/Makefile
+++ b/lib/Makefile
-@@ -134,6 +134,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
+@@ -135,6 +135,7 @@ obj-$(CONFIG_XZ_DEC) += xz/
obj-$(CONFIG_RAID6_PQ) += raid6/
obj-$(CONFIG_LZMA_COMPRESS) += lzma/
obj-$(CONFIG_LZMA_DECOMPRESS) += lzma/
diff --git a/target/linux/ath79/patches-4.14/0036-GPIO-add-named-gpio-exports.patch b/target/linux/ath79/patches-4.14/0036-GPIO-add-named-gpio-exports.patch
index a1d5d9d9ff..61ed9ea784 100644
--- a/target/linux/ath79/patches-4.14/0036-GPIO-add-named-gpio-exports.patch
+++ b/target/linux/ath79/patches-4.14/0036-GPIO-add-named-gpio-exports.patch
@@ -22,7 +22,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#include "gpiolib.h"
-@@ -507,3 +509,68 @@ void of_gpiochip_remove(struct gpio_chip
+@@ -513,3 +515,68 @@ void of_gpiochip_remove(struct gpio_chip
gpiochip_remove_pin_ranges(chip);
of_node_put(chip->of_node);
}
diff --git a/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch b/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch
index b80a38d6a8..9611f81445 100644
--- a/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch
+++ b/target/linux/brcm2708/patches-4.14/950-0037-Add-dwc_otg-driver.patch
@@ -852,7 +852,7 @@ Signed-off-by: Malik Olivier Boussejra <malik@boussejra.com>
msleep(100); /* Cool down */
--- a/drivers/usb/core/message.c
+++ b/drivers/usb/core/message.c
-@@ -1923,6 +1923,85 @@ free_interfaces:
+@@ -1925,6 +1925,85 @@ free_interfaces:
if (cp->string == NULL &&
!(dev->quirks & USB_QUIRK_CONFIG_INTF_STRINGS))
cp->string = usb_cache_string(dev, cp->desc.iConfiguration);
diff --git a/target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch b/target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch
index 436f1aa532..61e1b282c7 100644
--- a/target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch
+++ b/target/linux/brcm63xx/patches-4.14/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch
@@ -68,18 +68,25 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
ret = gpiod_hog(desc, name, lflags, dflags);
if (ret < 0) {
of_node_put(np);
-@@ -499,7 +506,10 @@ int of_gpiochip_add(struct gpio_chip *ch
+@@ -499,12 +506,13 @@ int of_gpiochip_add(struct gpio_chip *ch
of_node_get(chip->of_node);
-- return of_gpiochip_scan_gpios(chip);
-+ if (!chip->request)
-+ status = of_gpiochip_scan_gpios(chip, 0, chip->ngpio);
-+
-+ return status;
+- status = of_gpiochip_scan_gpios(chip);
+- if (status) {
+- of_node_put(chip->of_node);
+- gpiochip_remove_pin_ranges(chip);
++ if (!chip->request) {
++ status = of_gpiochip_scan_gpios(chip);
++ if (status) {
++ of_node_put(chip->of_node);
++ gpiochip_remove_pin_ranges(chip);
++ }
+ }
+-
+ return status;
}
- void of_gpiochip_remove(struct gpio_chip *chip)
--- a/drivers/gpio/gpiolib.c
+++ b/drivers/gpio/gpiolib.c
@@ -1938,7 +1938,8 @@ int gpiochip_add_pingroup_range(struct g
diff --git a/target/linux/generic/backport-4.14/060-v5.1-serial-ar933x_uart-Fix-build-failure-with-disabled-c.patch b/target/linux/generic/backport-4.14/060-v5.1-serial-ar933x_uart-Fix-build-failure-with-disabled-c.patch
deleted file mode 100644
index 657a869493..0000000000
--- a/target/linux/generic/backport-4.14/060-v5.1-serial-ar933x_uart-Fix-build-failure-with-disabled-c.patch
+++ /dev/null
@@ -1,94 +0,0 @@
-From 72ff51d8dd262d1fef25baedc2ac35116435be47 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Petr=20=C5=A0tetiar?= <ynezz@true.cz>
-Date: Wed, 6 Mar 2019 17:54:03 +0100
-Subject: [PATCH] serial: ar933x_uart: Fix build failure with disabled console
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-Andrey has reported on OpenWrt's bug tracking system[1], that he
-currently can't use ar93xx_uart as pure serial UART without console
-(CONFIG_SERIAL_8250_CONSOLE and CONFIG_SERIAL_AR933X_CONSOLE undefined),
-because compilation ends with following error:
-
- ar933x_uart.c: In function 'ar933x_uart_console_write':
- ar933x_uart.c:550:14: error: 'struct uart_port' has no
- member named 'sysrq'
-
-So this patch moves all the code related to console handling behind
-series of CONFIG_SERIAL_AR933X_CONSOLE ifdefs.
-
-1. https://bugs.openwrt.org/index.php?do=details&task_id=2152
-
-Cc: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
-Cc: Jiri Slaby <jslaby@suse.com>
-Cc: Andrey Batyiev <batyiev@gmail.com>
-Reported-by: Andrey Batyiev <batyiev@gmail.com>
-Tested-by: Andrey Batyiev <batyiev@gmail.com>
-Signed-off-by: Petr Štetiar <ynezz@true.cz>
-Signed-off-by: Greg Kroah-Hartman <gregkh@linuxfoundation.org>
----
- drivers/tty/serial/ar933x_uart.c | 24 ++++++++----------------
- 1 file changed, 8 insertions(+), 16 deletions(-)
-
---- a/drivers/tty/serial/ar933x_uart.c
-+++ b/drivers/tty/serial/ar933x_uart.c
-@@ -52,11 +52,6 @@ struct ar933x_uart_port {
- struct clk *clk;
- };
-
--static inline bool ar933x_uart_console_enabled(void)
--{
-- return IS_ENABLED(CONFIG_SERIAL_AR933X_CONSOLE);
--}
--
- static inline unsigned int ar933x_uart_read(struct ar933x_uart_port *up,
- int offset)
- {
-@@ -511,6 +506,7 @@ static const struct uart_ops ar933x_uart
- .verify_port = ar933x_uart_verify_port,
- };
-
-+#ifdef CONFIG_SERIAL_AR933X_CONSOLE
- static struct ar933x_uart_port *
- ar933x_console_ports[CONFIG_SERIAL_AR933X_NR_UARTS];
-
-@@ -607,14 +603,7 @@ static struct console ar933x_uart_consol
- .index = -1,
- .data = &ar933x_uart_driver,
- };
--
--static void ar933x_uart_add_console_port(struct ar933x_uart_port *up)
--{
-- if (!ar933x_uart_console_enabled())
-- return;
--
-- ar933x_console_ports[up->port.line] = up;
--}
-+#endif /* CONFIG_SERIAL_AR933X_CONSOLE */
-
- static struct uart_driver ar933x_uart_driver = {
- .owner = THIS_MODULE,
-@@ -703,7 +692,9 @@ static int ar933x_uart_probe(struct plat
- baud = ar933x_uart_get_baud(port->uartclk, 0, AR933X_UART_MAX_STEP);
- up->max_baud = min_t(unsigned int, baud, AR933X_UART_MAX_BAUD);
-
-- ar933x_uart_add_console_port(up);
-+#ifdef CONFIG_SERIAL_AR933X_CONSOLE
-+ ar933x_console_ports[up->port.line] = up;
-+#endif
-
- ret = uart_add_one_port(&ar933x_uart_driver, &up->port);
- if (ret)
-@@ -752,8 +743,9 @@ static int __init ar933x_uart_init(void)
- {
- int ret;
-
-- if (ar933x_uart_console_enabled())
-- ar933x_uart_driver.cons = &ar933x_uart_console;
-+#ifdef CONFIG_SERIAL_AR933X_CONSOLE
-+ ar933x_uart_driver.cons = &ar933x_uart_console;
-+#endif
-
- ret = uart_register_driver(&ar933x_uart_driver);
- if (ret)
diff --git a/target/linux/generic/backport-4.14/293-v4.16-netfilter-reduce-size-of-hook-entry-point-locations.patch b/target/linux/generic/backport-4.14/293-v4.16-netfilter-reduce-size-of-hook-entry-point-locations.patch
index 007b8315e5..9b33393c01 100644
--- a/target/linux/generic/backport-4.14/293-v4.16-netfilter-reduce-size-of-hook-entry-point-locations.patch
+++ b/target/linux/generic/backport-4.14/293-v4.16-netfilter-reduce-size-of-hook-entry-point-locations.patch
@@ -92,7 +92,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
#endif
--- a/net/bridge/br_netfilter_hooks.c
+++ b/net/bridge/br_netfilter_hooks.c
-@@ -987,7 +987,7 @@ int br_nf_hook_thresh(unsigned int hook,
+@@ -988,7 +988,7 @@ int br_nf_hook_thresh(unsigned int hook,
unsigned int i;
int ret;
diff --git a/target/linux/generic/pending-4.14/530-jffs2_make_lzma_available.patch b/target/linux/generic/pending-4.14/530-jffs2_make_lzma_available.patch
index 834876fa84..838d4168a2 100644
--- a/target/linux/generic/pending-4.14/530-jffs2_make_lzma_available.patch
+++ b/target/linux/generic/pending-4.14/530-jffs2_make_lzma_available.patch
@@ -244,7 +244,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
+}
--- a/fs/jffs2/super.c
+++ b/fs/jffs2/super.c
-@@ -371,14 +371,41 @@ static int __init init_jffs2_fs(void)
+@@ -374,14 +374,41 @@ static int __init init_jffs2_fs(void)
BUILD_BUG_ON(sizeof(struct jffs2_raw_inode) != 68);
BUILD_BUG_ON(sizeof(struct jffs2_raw_summary) != 32);
@@ -1119,7 +1119,7 @@ Signed-off-by: Alexandros C. Couloumbis <alex@ozo.com>
ifdef CONFIG_FUNCTION_TRACER
ORIG_CFLAGS := $(KBUILD_CFLAGS)
KBUILD_CFLAGS = $(subst $(CC_FLAGS_FTRACE),,$(ORIG_CFLAGS))
-@@ -122,6 +132,8 @@ obj-$(CONFIG_ZSTD_COMPRESS) += zstd/
+@@ -123,6 +133,8 @@ obj-$(CONFIG_ZSTD_COMPRESS) += zstd/
obj-$(CONFIG_ZSTD_DECOMPRESS) += zstd/
obj-$(CONFIG_XZ_DEC) += xz/
obj-$(CONFIG_RAID6_PQ) += raid6/
diff --git a/target/linux/generic/pending-4.14/630-packet_socket_type.patch b/target/linux/generic/pending-4.14/630-packet_socket_type.patch
index e8eae3b7ff..0b9addc36e 100644
--- a/target/linux/generic/pending-4.14/630-packet_socket_type.patch
+++ b/target/linux/generic/pending-4.14/630-packet_socket_type.patch
@@ -87,7 +87,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (!net_eq(dev_net(dev), sock_net(sk)))
goto drop;
-@@ -3269,6 +3271,7 @@ static int packet_create(struct net *net
+@@ -3273,6 +3275,7 @@ static int packet_create(struct net *net
mutex_init(&po->pg_vec_lock);
po->rollover = NULL;
po->prot_hook.func = packet_rcv;
@@ -95,7 +95,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
if (sock->type == SOCK_PACKET)
po->prot_hook.func = packet_rcv_spkt;
-@@ -3882,6 +3885,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3886,6 +3889,16 @@ packet_setsockopt(struct socket *sock, i
po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
return 0;
}
@@ -112,7 +112,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
default:
return -ENOPROTOOPT;
}
-@@ -3934,6 +3947,13 @@ static int packet_getsockopt(struct sock
+@@ -3938,6 +3951,13 @@ static int packet_getsockopt(struct sock
case PACKET_VNET_HDR:
val = po->has_vnet_hdr;
break;
diff --git a/target/linux/lantiq/patches-4.14/0030-GPIO-add-named-gpio-exports.patch b/target/linux/lantiq/patches-4.14/0030-GPIO-add-named-gpio-exports.patch
index fe4ea4fc24..8f0ac8d0f8 100644
--- a/target/linux/lantiq/patches-4.14/0030-GPIO-add-named-gpio-exports.patch
+++ b/target/linux/lantiq/patches-4.14/0030-GPIO-add-named-gpio-exports.patch
@@ -22,7 +22,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#include "gpiolib.h"
-@@ -507,3 +509,72 @@ void of_gpiochip_remove(struct gpio_chip
+@@ -513,3 +515,72 @@ void of_gpiochip_remove(struct gpio_chip
gpiochip_remove_pin_ranges(chip);
of_node_put(chip->of_node);
}
diff --git a/target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch b/target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
index 333dc9f3d5..03e84637f1 100644
--- a/target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
+++ b/target/linux/layerscape/patches-4.14/807-usb-support-layerscape.patch
@@ -1485,7 +1485,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
#define BCSR5_INT_USB (0x02)
--- a/include/linux/usb.h
+++ b/include/linux/usb.h
-@@ -434,6 +434,7 @@ struct usb_bus {
+@@ -432,6 +432,7 @@ struct usb_bus {
* for control transfers?
*/
u8 otg_port; /* 0, or number of OTG/HNP port */
diff --git a/target/linux/ramips/patches-4.14/0024-GPIO-add-named-gpio-exports.patch b/target/linux/ramips/patches-4.14/0024-GPIO-add-named-gpio-exports.patch
index a1d5d9d9ff..61ed9ea784 100644
--- a/target/linux/ramips/patches-4.14/0024-GPIO-add-named-gpio-exports.patch
+++ b/target/linux/ramips/patches-4.14/0024-GPIO-add-named-gpio-exports.patch
@@ -22,7 +22,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
#include "gpiolib.h"
-@@ -507,3 +509,68 @@ void of_gpiochip_remove(struct gpio_chip
+@@ -513,3 +515,68 @@ void of_gpiochip_remove(struct gpio_chip
gpiochip_remove_pin_ranges(chip);
of_node_put(chip->of_node);
}