aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorChris Blake <chrisrblake93@gmail.com>2017-01-14 10:20:25 -0600
committerJo-Philipp Wich <jo@mein.io>2017-02-01 17:45:25 +0100
commite9b60b587b619309c30615cc6a844c00b2360490 (patch)
treec221055fee502bd6bd707d511d9f5aa8f2e0f0fd /target
parentaf3ae4b37ce1d476c7ab73e8f73ce1f1b47748b9 (diff)
downloadupstream-e9b60b587b619309c30615cc6a844c00b2360490.tar.gz
upstream-e9b60b587b619309c30615cc6a844c00b2360490.tar.bz2
upstream-e9b60b587b619309c30615cc6a844c00b2360490.zip
x86: add kernel module for sp5100_tco watchdog
This change adds the sp5100_tco driver as a kernel module for the x86 target. Specifically, this can be used by the PCEngines APU2/APU3. The reason for having this as a kernel module is to allow users to load/unload it on demand, as the I2C interface on the APU2/APU3 will not work while this module is loaded. More info can be found on GitHub at https://github.com/riptidewave93/LEDE-APU2/pull/5#issuecomment-255667736 Signed-off-by: Chris Blake <chrisrblake93@gmail.com>
Diffstat (limited to 'target')
-rw-r--r--target/linux/x86/modules.mk15
1 files changed, 15 insertions, 0 deletions
diff --git a/target/linux/x86/modules.mk b/target/linux/x86/modules.mk
index 656500b290..87733c2850 100644
--- a/target/linux/x86/modules.mk
+++ b/target/linux/x86/modules.mk
@@ -19,3 +19,18 @@ define KernelPackage/sound-cs5535audio/description
endef
$(eval $(call KernelPackage,sound-cs5535audio))
+
+define KernelPackage/sp5100_tco
+ SUBMENU:=$(OTHER_MENU)
+ TITLE:=SP5100 Watchdog Support
+ DEPENDS:=@TARGET_x86
+ KCONFIG:=CONFIG_SP5100_TCO
+ FILES:=$(LINUX_DIR)/drivers/watchdog/sp5100_tco.ko
+ AUTOLOAD:=$(call AutoLoad,50,sp5100_tco,1)
+endef
+
+define KernelPackage/sp5100_tco/description
+ Kernel module for the SP5100_TCO hardware watchdog.
+endef
+
+$(eval $(call KernelPackage,sp5100_tco))