aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRafał Miłecki <rafal@milecki.pl>2017-02-17 06:57:33 +0100
committerRafał Miłecki <rafal@milecki.pl>2017-02-17 06:58:33 +0100
commit982dd01ac37f64892deb4003f4e53d3bc7a114c4 (patch)
treed8ad248dec70ab6bc99a38f9ab5d3d0ec3d11855 /target
parent25b7295617cc6b2e317ef970d6d8d04ada49822c (diff)
downloadupstream-982dd01ac37f64892deb4003f4e53d3bc7a114c4.tar.gz
upstream-982dd01ac37f64892deb4003f4e53d3bc7a114c4.tar.bz2
upstream-982dd01ac37f64892deb4003f4e53d3bc7a114c4.zip
Mark targets using kernel 3.18 as source-only
We're past v17.01.0-rc2 phase and these few targets are stuck at 3.18 kernel. We obviously don't want to have targets like this built for the release, especially with 3.18 being EOL. It may be not too late for bringing these targets back for the next minor release, so just mark them as source-only instead of dropping completely. Signed-off-by: Rafał Miłecki <rafal@milecki.pl>
Diffstat (limited to 'target')
-rw-r--r--target/linux/adm5120/Makefile2
-rw-r--r--target/linux/adm8668/Makefile2
-rw-r--r--target/linux/ar7/Makefile2
-rw-r--r--target/linux/au1000/Makefile2
-rw-r--r--target/linux/mcs814x/Makefile2
-rw-r--r--target/linux/xburst/Makefile2
6 files changed, 6 insertions, 6 deletions
diff --git a/target/linux/adm5120/Makefile b/target/linux/adm5120/Makefile
index 419c53434f..56916bdcea 100644
--- a/target/linux/adm5120/Makefile
+++ b/target/linux/adm5120/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
BOARD:=adm5120
BOARDNAME:=Infineon/ADMtek ADM5120
-FEATURES:=low_mem
+FEATURES:=low_mem source-only
SUBTARGETS:=router_le router_be rb1xx
INITRAMFS_EXTRA_FILES:=
diff --git a/target/linux/adm8668/Makefile b/target/linux/adm8668/Makefile
index ddca8d4a27..cc82ec1606 100644
--- a/target/linux/adm8668/Makefile
+++ b/target/linux/adm8668/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=mipsel
BOARD:=adm8668
BOARDNAME:=Infineon WildPass ADM8668
-FEATURES:=squashfs usb pci
+FEATURES:=squashfs usb pci source-only
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
KERNEL_PATCHVER:=3.18
diff --git a/target/linux/ar7/Makefile b/target/linux/ar7/Makefile
index c5a6035b53..4a09aa09a4 100644
--- a/target/linux/ar7/Makefile
+++ b/target/linux/ar7/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=mipsel
BOARD:=ar7
BOARDNAME:=TI AR7
-FEATURES:=squashfs atm low_mem
+FEATURES:=squashfs atm low_mem source-only
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
SUBTARGETS:=generic ac49x
diff --git a/target/linux/au1000/Makefile b/target/linux/au1000/Makefile
index debc41e978..ddc28d0f09 100644
--- a/target/linux/au1000/Makefile
+++ b/target/linux/au1000/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=mipsel
BOARD:=au1000
BOARDNAME:=RMI/AMD AU1x00
-FEATURES:=squashfs usb pci
+FEATURES:=squashfs usb pci source-only
SUBTARGETS:=au1500 au1550
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
diff --git a/target/linux/mcs814x/Makefile b/target/linux/mcs814x/Makefile
index 8ba58886e9..0f69bbe322 100644
--- a/target/linux/mcs814x/Makefile
+++ b/target/linux/mcs814x/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=arm
BOARD:=mcs814x
BOARDNAME:=Moschip MCS814x
-FEATURES:=usb squashfs low_mem
+FEATURES:=usb squashfs low_mem source-only
CPU_TYPE:=arm926ej-s
MAINTAINER:=Florian Fainelli <florian@openwrt.org>
diff --git a/target/linux/xburst/Makefile b/target/linux/xburst/Makefile
index 2a64b7c46f..16d0b8b1b4 100644
--- a/target/linux/xburst/Makefile
+++ b/target/linux/xburst/Makefile
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
ARCH:=mipsel
BOARD:=xburst
BOARDNAME:=Ingenic XBurst
-FEATURES:=targz nand ubifs audio
+FEATURES:=targz nand ubifs audio source-only
SUBTARGETS:=qi_lb60
KERNEL_PATCHVER:=3.18