aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-03-25 17:58:10 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-03-25 17:58:10 +0000
commit8d2d62ca951eb14ea05331c421b89c63a536c4e0 (patch)
treea6d2d760a23aa56df7e471cbc14a18354a2405ea /target
parent41785176ec55d02b9226fbd44d2af467f4309510 (diff)
downloadupstream-8d2d62ca951eb14ea05331c421b89c63a536c4e0.tar.gz
upstream-8d2d62ca951eb14ea05331c421b89c63a536c4e0.tar.bz2
upstream-8d2d62ca951eb14ea05331c421b89c63a536c4e0.zip
ar71xx/image: add tplink device template for new building code
Signed-off-by: Alexander Couzens <lynxis@fe80.eu> SVN-Revision: 44999
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile22
1 files changed, 22 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 4023b1af92..040d1a9772 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -132,6 +132,28 @@ endef
TARGET_DEVICES += wndr3700 wndr3700v2 wndr3800 wndr3800ch wndrmac wndrmacv2
+define Device/tplink
+ TPLINK_HWREV := 0x1
+ KERNEL := kernel-bin | patch-cmdline | lzma
+ KERNEL_INITRAMFS := kernel-bin | patch-cmdline | lzma | mktplinkfw initramfs
+ IMAGES := sysupgrade.bin factory.bin
+ IMAGE/sysupgrade.bin := append-rootfs | mktplinkfw sysupgrade
+ IMAGE/factory.bin := append-rootfs | mktplinkfw factory
+endef
+
+define Device/tplink-4mlzma
+$(Device/tplink)
+ TPLINK_FLASHLAYOUT := 4Mlzma
+ IMAGE_SIZE := 3904k
+endef
+
+define Device/tplink-8mlzma
+$(Device/tplink)
+ TPLINK_FLASHLAYOUT := 8Mlzma
+ IMAGE_SIZE := 8000k
+endef
+
+
rootfs_type=$(patsubst jffs2-%,jffs2,$(patsubst squashfs-%,squashfs,$(1)))
# $(1): rootfs type.