aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorNicolas Thill <nico@openwrt.org>2009-12-19 14:45:43 +0000
committerNicolas Thill <nico@openwrt.org>2009-12-19 14:45:43 +0000
commit775ab67b6b06c0552d7139381cf65997728a3986 (patch)
treee7f6ceb3f5ca4cee01f018ca71a05fdfa36d1fbe /target
parent8b10e4eab27ab287f6c20347f0b3939ea80beac1 (diff)
downloadupstream-775ab67b6b06c0552d7139381cf65997728a3986.tar.gz
upstream-775ab67b6b06c0552d7139381cf65997728a3986.tar.bz2
upstream-775ab67b6b06c0552d7139381cf65997728a3986.zip
ar71xx: fix WNDR3700 image generation
SVN-Revision: 18849
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index 051f0a3f29..92f698a35c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -237,14 +237,13 @@ wndr3700_mtdlayout=mtdparts=spi0.0:320k(u-boot)ro,128k(u-boot-env)ro,1024k(kerne
define Image/Build/WNDR3700
$(call PatchKernelLzma,$(2),$(3) $(wndr3700_mtdlayout))
$(call MkImageLzma,$(KDIR)/vmlinux-$(2).bin.lzma,$(KDIR)/vmlinux-$(2).uImage)
- mkdir $(KDIR)/wndr3700
- mkdir $(KDIR)/wndr3700/image
+ mkdir -p $(KDIR)/wndr3700/image
$(STAGING_DIR_HOST)/bin/wndr3700 \
$(KDIR)/vmlinux-$(2).uImage \
$(KDIR)/wndr3700/image/uImage
- $(STAGING_DIR_HOST)/bin/mksquashfs-lzma \
+ $(MKSQUASHFS_CMD) \
$(KDIR)/wndr3700 $(KDIR)/vmlinux-$(2).uImage.squashfs.tmp \
- -nopad -noappend -root-owned -be
+ -nopad -noappend -root-owned $(SQUASHFS_OPTS)
-rm -rf $(KDIR)/wndr3700
mkimage -A mips -O linux -T filesystem -C none \
-a 0xbf070000 -e 0xbf070000 \