aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2015-05-30 22:55:50 +0000
committerFelix Fietkau <nbd@openwrt.org>2015-05-30 22:55:50 +0000
commit677741ef959b303c61c0e6a2a66cad289fee3685 (patch)
treefcd186986407c11369f0c39525ff53ac42d05200 /target
parent64b789db561adae1a9097f692ba4e78d0bd4f238 (diff)
downloadupstream-677741ef959b303c61c0e6a2a66cad289fee3685.tar.gz
upstream-677741ef959b303c61c0e6a2a66cad289fee3685.tar.bz2
upstream-677741ef959b303c61c0e6a2a66cad289fee3685.zip
ar71xx: use Image/BuildLoaderPatched for TPLINK-SAFELOADER images
Building the loader in Image/Build/TPLINK-SAFELOADER would break the image builder as no target compiler is available in that stage. Fixes #19580 Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net> SVN-Revision: 45855
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile8
1 files changed, 2 insertions, 6 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index fc66908d64..580a640786 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -1495,14 +1495,10 @@ define Image/Build/TPLINK-LZMA/initramfs
endef
-Image/Build/TPLINK-SAFELOADER/buildkernel=$(call PatchKernelLzma,$(2),$(3) $(4))
+Image/Build/TPLINK-SAFELOADER/loader = $(call Image/BuildLoaderPatched,$(1),elf,$(2) $(3))
define Image/Build/TPLINK-SAFELOADER
- -rm -rf $(KDIR)/lzma-loader
- $(LOADER_MAKE) LOADER=loader-$(2).elf\
- LZMA_TEXT_START=0x80a00000 LOADADDR=0x80060000 \
- LOADER_DATA="$(KDIR_TMP)/vmlinux-$(2).bin.lzma" BOARD="$(2)" \
- compile loader.elf
+ [ -e "$(KDIR)/loader-$(2).elf" ]
-$(STAGING_DIR_HOST)/bin/tplink-safeloader \
-B $(5) \