aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorJohn Crispin <blogic@openwrt.org>2013-08-06 16:25:45 +0000
committerJohn Crispin <blogic@openwrt.org>2013-08-06 16:25:45 +0000
commitb431cd831e4ae9a43f2654de3efca0c244bfd90b (patch)
tree9b1707f1878256dca7ac1e8426af2e277514df52 /target
parentf42c0bb6735550bc9fdb39386fd8ef2201f53f3d (diff)
downloadupstream-b431cd831e4ae9a43f2654de3efca0c244bfd90b.tar.gz
upstream-b431cd831e4ae9a43f2654de3efca0c244bfd90b.tar.bz2
upstream-b431cd831e4ae9a43f2654de3efca0c244bfd90b.zip
lantiq: fix TD-W8970 image generation to work with the new tool
Signed-off-by: John Crispin <blogic@openwrt.org> git-svn-id: svn://svn.openwrt.org/openwrt/trunk@37727 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/lantiq/image/Makefile10
1 files changed, 8 insertions, 2 deletions
diff --git a/target/linux/lantiq/image/Makefile b/target/linux/lantiq/image/Makefile
index 0dbdb83854..e4e3e9e06b 100644
--- a/target/linux/lantiq/image/Makefile
+++ b/target/linux/lantiq/image/Makefile
@@ -50,7 +50,7 @@ define MkImageLzma
endef
define TPLinkImageLzma
- mktplinkfw -c -B $(2) -W 2 -F 8Mltq -s \
+ mktplinkfw2 -c -B $(2) -s \
-k $(KDIR)/vmlinux$(3)-$(1).lzma -o $(KDIR)/uImage-$(1)$(3)
endef
@@ -82,6 +82,12 @@ define Image/Build/squashfs
$(if $(3),$(call MkBrnImage,$(3),$(4),$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(3)-brnImage,$(2),$(1),$(5)))
endef
+define Image/BuildTPLink/squashfs
+ mktplinkfw2 -B $(3) -s -a 0x4 -j \
+ -k $(KDIR)/vmlinux-$(2).lzma -r $(KDIR)/root.$(1) \
+ -o $(BIN_DIR)/$(IMG_PREFIX)-$(2)-sysupgrade.image
+endef
+
define Image/BuildEVA/squashfs
cat $(KDIR)/$(2).eva $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image.eva
$(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image.eva)
@@ -264,7 +270,7 @@ Image/BuildKernel/Profile/VG3503J=$(call Image/BuildKernelLoader/Template,VG3503
Image/Build/Profile/VG3503J=$(call Image/BuildLoader/$(1),$(1),VG3503J)
Image/BuildKernel/Profile/TDW8970=$(call Image/BuildKernelTPLink/Template,TDW8970,TD-W8970v1,$(1))
-Image/Build/Profile/TDW8970=$(call Image/Build/$(1),$(1),TDW8970)
+Image/Build/Profile/TDW8970=$(call Image/BuildTPLink/$(1),$(1),TDW8970,TD-W8970v1)
endif