aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorFelix Fietkau <nbd@openwrt.org>2005-10-22 14:37:56 +0000
committerFelix Fietkau <nbd@openwrt.org>2005-10-22 14:37:56 +0000
commita74e14a00b7246b3d8757772fee807a5d1a288e2 (patch)
tree6f6e43b16e5f2aae78d79103dd6c5ba368e88a09 /target
parentb0d244cc08f1075be31494be3e379917bc2415e9 (diff)
downloadupstream-a74e14a00b7246b3d8757772fee807a5d1a288e2.tar.gz
upstream-a74e14a00b7246b3d8757772fee807a5d1a288e2.tar.bz2
upstream-a74e14a00b7246b3d8757772fee807a5d1a288e2.zip
fix unnecessary recompiling of packages
git-svn-id: svn://svn.openwrt.org/openwrt/trunk/openwrt@2239 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/linux-2.4/Makefile10
-rw-r--r--target/linux/linux-2.6/Makefile10
2 files changed, 10 insertions, 10 deletions
diff --git a/target/linux/linux-2.4/Makefile b/target/linux/linux-2.4/Makefile
index f455c92bd9..4fd8e21049 100644
--- a/target/linux/linux-2.4/Makefile
+++ b/target/linux/linux-2.4/Makefile
@@ -251,6 +251,11 @@ $(STAGING_DIR)/include/linux/version.h: $(LINUX_DIR)/.configured
$(STAMP_DIR)/.linux-compile: $(LINUX_DIR)/.modules_done
@mkdir -p $(STAMP_DIR)
@$(MAKE) $(TARGETS)
+ ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
+ @$(TRACE) target/linux/package
+ $(MAKE) -C $(TOPDIR)/target/linux/package \
+ $(KPKG_MAKEOPTS) \
+ compile
touch $@
$(TARGET_MODULES_DIR):
@@ -271,11 +276,6 @@ prepare: $(LINUX_DIR)/.configured
compile:
@$(PKG_TRACE) Compiling...
$(MAKE) $(STAMP_DIR)/.linux-compile $(MAKE_TRACE)
- ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
- @$(TRACE) target/linux/package
- $(MAKE) -C $(TOPDIR)/target/linux/package \
- $(KPKG_MAKEOPTS) \
- compile
install: compile $(TARGET_MODULES_DIR) $(KERNEL_IPKG)
rm -rf $(LINUX_BUILD_DIR)/root*
diff --git a/target/linux/linux-2.6/Makefile b/target/linux/linux-2.6/Makefile
index 7c254755de..9ff3ed7694 100644
--- a/target/linux/linux-2.6/Makefile
+++ b/target/linux/linux-2.6/Makefile
@@ -235,6 +235,11 @@ $(KERNEL_IPKG):
$(STAMP_DIR)/.linux-compile: $(LINUX_DIR)/.modules_done
@mkdir -p $(STAMP_DIR)
@$(MAKE) $(TARGETS)
+ ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
+ @$(TRACE) target/linux/package
+ $(MAKE) -C $(TOPDIR)/target/linux/package \
+ $(KPKG_MAKEOPTS) \
+ compile
touch $@
source: $(DL_DIR)/$(LINUX_SOURCE)
@@ -242,11 +247,6 @@ prepare: $(LINUX_DIR)/.configured
compile:
@$(PKG_TRACE) Compiling...
$(MAKE) $(STAMP_DIR)/.linux-compile $(MAKE_TRACE)
- ln -sf $(LINUX_BUILD_DIR)/linux-$(LINUX_VERSION) $(LINUX_DIR)
- @$(TRACE) target/linux/package
- $(MAKE) -C $(TOPDIR)/target/linux/package \
- $(KPKG_MAKEOPTS) \
- compile
install: compile $(TARGET_MODULES_DIR) $(KERNEL_IPKG)
rm -rf $(LINUX_BUILD_DIR)/root*