aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2007-07-11 13:29:57 +0000
committerRod Whitby <rod@whitby.id.au>2007-07-11 13:29:57 +0000
commit95c44817ce72a20e31ff8f52a2bfe398b1576903 (patch)
tree6ff50da2ba8d1dc78541d7ee64e196f85411bdfc /target
parent118d0d249651d653fc4ee7c7e25c502e26b917d8 (diff)
downloadupstream-95c44817ce72a20e31ff8f52a2bfe398b1576903.tar.gz
upstream-95c44817ce72a20e31ff8f52a2bfe398b1576903.tar.bz2
upstream-95c44817ce72a20e31ff8f52a2bfe398b1576903.zip
ixp4xx: Initial profile for the Freecom FSG-3
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7920 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ixp4xx-2.6/config/profile-FSG316
-rw-r--r--target/linux/ixp4xx-2.6/profiles/500-FSG3.mk20
2 files changed, 36 insertions, 0 deletions
diff --git a/target/linux/ixp4xx-2.6/config/profile-FSG3 b/target/linux/ixp4xx-2.6/config/profile-FSG3
new file mode 100644
index 0000000000..051031d070
--- /dev/null
+++ b/target/linux/ixp4xx-2.6/config/profile-FSG3
@@ -0,0 +1,16 @@
+CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
+CONFIG_ATA=y
+CONFIG_SATA_VIA=y
+CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_EHCI_SPLIT_ISO=y
+CONFIG_USB_EHCI_ROOT_HUB_TT=y
+CONFIG_USB_EHCI_TT_NEWSCHED=y
+CONFIG_USB_OHCI_HCD=y
+CONFIG_USB_OHCI_LITTLE_ENDIAN=y
+CONFIG_USB_STORAGE=y
+CONFIG_EXT3_FS=y
+CONFIG_EXT3_FS_XATTR=y
+CONFIG_EXT3_FS_POSIX_ACL=y
+CONFIG_EXT3_FS_SECURITY=y
+CONFIG_JBD=y
+CONFIG_FS_MBCACHE=y
diff --git a/target/linux/ixp4xx-2.6/profiles/500-FSG3.mk b/target/linux/ixp4xx-2.6/profiles/500-FSG3.mk
new file mode 100644
index 0000000000..d7d6a2ef75
--- /dev/null
+++ b/target/linux/ixp4xx-2.6/profiles/500-FSG3.mk
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FSG3
+ NAME:=Freecom FSG-3
+ PACKAGES:= \
+ kmod-madwifi wireless-tools \
+ kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+ kmod-fs-ext2
+endef
+
+define Profile/FSG3/Description
+ Package set optimized for the Freecom FSG-3
+endef
+$(eval $(call Profile,FSG3))
+