aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-01-22 07:35:05 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-01-22 07:35:05 +0000
commit8dbd855958a0f3e737ffc3ce080a1294ebbeecbb (patch)
tree5d03db6798bcb29500599afb1b4972fbc710af94 /target
parentd71ad0abee2f6fde28cd7775317a9b9258d26f3b (diff)
downloadupstream-8dbd855958a0f3e737ffc3ce080a1294ebbeecbb.tar.gz
upstream-8dbd855958a0f3e737ffc3ce080a1294ebbeecbb.tar.bz2
upstream-8dbd855958a0f3e737ffc3ce080a1294ebbeecbb.zip
[ar71xx] fix Ubiquiti RouterStation images
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14144 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile3
1 files changed, 2 insertions, 1 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index fea4691aee..6ed652e6bc 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -68,7 +68,8 @@ endef
define Image/Build/UBNT
cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
$(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
- $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).bin.lzma
+ $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux-$(2) $(KDIR)/vmlinux-$(2).lzma
+ dd if=$(KDIR)/vmlinux-$(2).lzma of=$(KDIR)/vmlinux-$(2).bin.lzma bs=64k conv=sync
-$(STAGING_DIR_HOST)/bin/mkfwimage \
-B $(4) -v $(5).ar7100.OpenWrt \
-k $(KDIR)/vmlinux-$(2).bin.lzma \