aboutsummaryrefslogtreecommitdiffstats
path: root/target
diff options
context:
space:
mode:
authorGabor Juhos <juhosg@openwrt.org>2009-02-26 17:02:28 +0000
committerGabor Juhos <juhosg@openwrt.org>2009-02-26 17:02:28 +0000
commit7a4e671872a80f8d3433fa0158b733a0d7478578 (patch)
tree74c959e78218ce92012116d4e222b4eede42d087 /target
parentf6347f01b653bc00ea89be9728112ecd66ddc1c2 (diff)
downloadupstream-7a4e671872a80f8d3433fa0158b733a0d7478578.tar.gz
upstream-7a4e671872a80f8d3433fa0158b733a0d7478578.tar.bz2
upstream-7a4e671872a80f8d3433fa0158b733a0d7478578.zip
[ar71xx] generate firmware image for the TL-WR941ND device
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14674 3c298f89-4303-0410-b956-a3cf2f4a3e73
Diffstat (limited to 'target')
-rw-r--r--target/linux/ar71xx/image/Makefile24
1 files changed, 24 insertions, 0 deletions
diff --git a/target/linux/ar71xx/image/Makefile b/target/linux/ar71xx/image/Makefile
index a48d5306d2..c96456759c 100644
--- a/target/linux/ar71xx/image/Makefile
+++ b/target/linux/ar71xx/image/Makefile
@@ -100,6 +100,17 @@ define Image/Build/Planex
fi; fi
endef
+define Image/Build/TPLINK
+ cp $(KDIR)/vmlinux $(KDIR)/vmlinux-$(2)
+ $(STAGING_DIR_HOST)/bin/patch-cmdline $(KDIR)/vmlinux-$(2) '$(strip $(3))'
+ gzip -9 -c $(KDIR)/vmlinux-$(2) > $(KDIR)/vmlinux-$(2).bin.gzip
+ -$(STAGING_DIR_HOST)/bin/mktplinkfw \
+ -B $(4) -N OpenWrt -V $(REVISION)\
+ -k $(KDIR)/vmlinux-$(2).bin.gzip \
+ -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
+ -o $(BIN_DIR)/openwrt-$(BOARD)-$(2)-$(1).bin
+endef
+
define Image/Build/Template/Compex
$(call Image/Build/MyLoader,$(1),$(2))
endef
@@ -116,6 +127,14 @@ define Image/Build/Template/AP81/squashfs
$(call Image/Build/Template/AP81,squashfs,$(1),$(2),$(3))
endef
+define Image/Build/Template/TPLINK
+ $(call Image/Build/TPLINK,$(1),$(2),$(3),$(4))
+endef
+
+define Image/Build/Template/TPLINK/squashfs
+ $(call Image/Build/Template/TPLINK,squashfs,$(1),$(2),$(3))
+endef
+
define Image/Build/Template/UBNT
$(call Image/Build/UBNT,$(1),$(2),$(3),$(4),$(5))
endef
@@ -156,6 +175,10 @@ define Image/Build/Profile/MZKW04NU
$(call Image/Build/Template/Planex/$(1),mzk-w04nu,board=MZK-W04NU)
endef
+define Image/Build/Profile/TLWR941NDV2
+ $(call Image/Build/Template/TPLINK/$(1),tl-wr941ndv2,board=TL-WR941ND,TL-WR941NDv2)
+endef
+
define Image/Build/squashfs
$(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
endef
@@ -170,6 +193,7 @@ define Image/Build
$(call Image/Build/Profile/TEW652BRP,$(1))
$(call Image/Build/Profile/UBNTRS,$(1))
$(call Image/Build/Profile/WP543,$(1))
+ $(call Image/Build/Profile/TLWR941NDV2,$(1))
endef
$(eval $(call BuildImage))